Gnome web urlbar very slow to show typed input

Bug #1719043 reported by Andrew Canton on 2017-09-22
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
GTK+
Expired
Medium
epiphany-browser (Ubuntu)
High
Unassigned
gtk+3.0 (Debian)
Fix Released
Unknown
gtk+3.0 (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned
mutter (Ubuntu)
Medium
Unassigned
Artful
Medium
Unassigned

Bug Description

Impact
======
It is very difficult to use the address bar in Epiphany on GNOME on Wayland because after a few characters, the address bar field stops redrawing. (This apparently was triggered by mutter 3.26?)

Test Case
=========
sudo apt install epiphany-browser
Open the Web app
Type a URL into the address bar. Type a loooong URL.
You should see all the characters you type into the address bar.

Regression Potential
===================
To fix this issue, an optimization commit applied earlier in 3.26 development was reverted. This fix is part of mutter 3.26.2 (LP: #1730097).

Other Info
==========
The first SRU gtk+3.0 3.22.24-0ubuntu2 caused a regression seen in totem and so was reverted in both gtk upstream and in the next SRU 3.22.25-0ubuntu0.1

Instead, this is being fixed in mutter.

Original Bug Report
===================
First two characters typed in urlbar show immediately, other characters take up to 30 seconds to appear, or url will appear in full once enter key is pressed.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: epiphany-browser 3.26.0-1ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-11.12-generic 4.13.1
Uname: Linux 4.13.0-11-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri Sep 22 18:42:19 2017
InstallationDate: Installed on 2017-09-22 (0 days ago)
InstallationMedia: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170919)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: epiphany-browser
UpgradeStatus: No upgrade log present (probably fresh install)

Andrew Canton (planecrazyp51) wrote :
Jeremy Bicha (jbicha) on 2017-09-25
Changed in epiphany-browser (Ubuntu):
importance: Undecided → High
status: New → Triaged
Changed in epiphany-browser (Debian):
status: Unknown → New
Changed in epiphany-browser:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.26.0-1ubuntu2

---------------
epiphany-browser (3.26.0-1ubuntu2) artful; urgency=medium

  * Add git_fix-url-bar-lag.patch:
    - Fix lag when typing in URL bar (Closes: #875826) (LP: #1719043)

 -- Jeremy Bicha <email address hidden> Mon, 25 Sep 2017 18:48:09 -0400

Changed in epiphany-browser (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) wrote :

Sorry, the new version doesn't actually appear to solve the problem.

Changed in epiphany-browser (Ubuntu):
status: Fix Released → Triaged
Changed in epiphany-browser:
status: Confirmed → Incomplete
Changed in epiphany-browser (Debian):
status: New → Confirmed
Changed in epiphany-browser:
status: Incomplete → Confirmed
Changed in epiphany-browser:
status: Confirmed → Invalid
Jeremy Bicha (jbicha) on 2017-09-30
affects: epiphany-browser (Debian) → mutter (Debian)
affects: epiphany-browser → mutter
Changed in mutter:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in mutter (Ubuntu):
status: New → Triaged
importance: Undecided → Medium
Changed in mutter:
importance: Unknown → Medium
status: Unknown → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.26.1-1ubuntu1

---------------
epiphany-browser (3.26.1-1ubuntu1) artful; urgency=medium

  * Sync with Debian. Remaining change:
    - Modify 07_bookmarks.patch:
      + Add Ubuntu-specific default bookmarks, borrowed from Firefox
  * Drop ubuntu_titlebars.patch (LP: #1719322)
    + Use traditional titlebars for non-GNOME sessions

epiphany-browser (3.26.1-1) unstable; urgency=medium

  * New upstream release
  * Drop git_fix-url-bar-lag.patch: Applied in new release
  * Bump Standards-Version to 4.1.1

 -- Jeremy Bicha <email address hidden> Sat, 30 Sep 2017 10:20:38 -0400

Changed in epiphany-browser (Ubuntu):
status: Triaged → Fix Released
Jeremy Bicha (jbicha) on 2017-09-30
Changed in epiphany-browser (Ubuntu):
status: Fix Released → Triaged
Jeremy Bicha (jbicha) on 2017-10-16
affects: mutter (Ubuntu) → gtk+3.0 (Ubuntu)
Changed in gtk+3.0 (Ubuntu):
status: Triaged → In Progress
affects: mutter → gtk
affects: mutter (Debian) → gtk+3.0 (Debian)
Changed in gtk+3.0 (Debian):
status: Confirmed → Fix Released
Changed in gtk:
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2017-10-17
description: updated
Changed in gtk:
status: Fix Released → Confirmed

Hello Andrew, or anyone else affected,

Accepted gtk+3.0 into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gtk+3.0/3.22.24-0ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in gtk+3.0 (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-artful
Jeremy Bicha (jbicha) wrote :

A regression was identified. See comments 15-16 at https://bugzilla.gnome.org/784314 which can be reproduced with

totem /usr/share/example-content/Ubuntu_Free_Culture_Showcase/Nathan\ Haines\ -\ Ubuntu\ Through\ The\ Years.ogg

tags: added: verification-failed-artful
removed: verification-needed-artful
Jeremy Bicha (jbicha) on 2017-10-20
Changed in mutter (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.22.24-0ubuntu2

---------------
gtk+3.0 (3.22.24-0ubuntu2) artful; urgency=medium

  * Add 0004_fix-gtkentry-wayland-regression.patch:
    - Cherry-pick fix for lag with Epiphany's address bar (Closes: #875826)
      (LP: #1719043)

 -- Jeremy Bicha <email address hidden> Tue, 17 Oct 2017 11:22:54 -0400

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-10-26
description: updated
Jeremy Bicha (jbicha) on 2017-10-26
Changed in mutter (Ubuntu):
status: Triaged → Fix Committed
no longer affects: gtk+3.0 (Ubuntu Artful)
no longer affects: epiphany-browser (Ubuntu Artful)
Changed in mutter (Ubuntu Artful):
status: New → In Progress
importance: Undecided → Medium
Changed in gtk+3.0 (Ubuntu Artful):
importance: Undecided → Medium
status: New → Fix Committed
Jeremy Bicha (jbicha) wrote :

I verify that the totem regression cannot be reproduced with the new gtk+3.0 3.22.25-0ubuntu0.1 SRU. Since this bug is being fixed in mutter instead, I am closing the gtk+3.0 part of this bug.

description: updated
tags: removed: verification-failed-artful
Changed in gtk+3.0 (Ubuntu Artful):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Hello Andrew, or anyone else affected,

Accepted mutter into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.26.2-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in mutter (Ubuntu Artful):
status: In Progress → Fix Committed
tags: added: verification-needed-artful
Jeremy Bicha (jbicha) wrote :

I verify that the address bar works correctly now after upgrading Ubuntu 17.10 to mutter 3.26.2-0ubuntu0.1.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Changed in mutter (Ubuntu):
status: Fix Committed → Fix Released
Jeremy Bicha (jbicha) on 2017-11-09
Changed in gtk+3.0 (Ubuntu):
status: Fix Released → Invalid
Changed in gtk+3.0 (Ubuntu Artful):
status: Fix Released → Invalid

The verification of the Stable Release Update for mutter has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.26.2-0ubuntu0.1

---------------
mutter (3.26.2-0ubuntu0.1) artful; urgency=medium

  * New upstream release (LP: #1730097):
    - Fix unredirecting full-screen windows and fix returning to
      full-screen after Alt-Tab (LP: #1725649)
    - Allow HiDPI scaling even when non-HiDPI displays are connected
      (LP: #1724024)
    - Fix Epiphany URL bar (LP: #1719043) (Closes: #875826)
  * Drop cherry-picked patches

 -- Jeremy Bicha <email address hidden> Sat, 04 Nov 2017 14:07:59 -0400

Changed in mutter (Ubuntu Artful):
status: Fix Committed → Fix Released
Changed in gtk:
status: Confirmed → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.