new upstream release 3.10

Bug #1260942 reported by Tim Lunn on 2013-12-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
epiphany-browser (Ubuntu)
Undecided
Unassigned

Bug Description

This was unblocked by the recent upload of gtk 3.10.

Includes client side decorations, but not in the Ubuntu seed so that should be fine?

Package synced from debian.

Daniel Holbach (dholbach) wrote :

This fails to build for me on trusty amd64: http://paste.ubuntu.com/6588504/

Could you also keep the old changelog entries from trusty around and maybe integrate the recent change in Debian (-5)?

Changed in epiphany-browser (Ubuntu):
status: New → Incomplete
Tim Lunn (darkxst) wrote :

Daniel, Could you attach the full build log? I cannot reproduce the build failure under pbuilder. It also built fine on the ppa builders

https://launchpad.net/~gnome3-team/+archive/gnome3/+build/5333695

Tim Lunn (darkxst) wrote :

changelog in trusty is basically just the debian log, however updated changelog with the only ubuntu entry.

Daniel Holbach (dholbach) wrote :

It must have been an intermittent issue.

Can you explain why the following change is being made? I couldn't find it in Debian (-5) either:

-Package: epiphany-extensions
+Package: epiphany-browser-webkit2

Tim Lunn (darkxst) wrote :

epiphany-extensions has been removed (that is a debian change)

I added a transitional package on epiphany-browser-webkit2 since that is the default build now in epiphany-browser. Pretty sure upgrades would break otherwise for people who had installed the optional epiphany-browser-webkit2 version

Tim Lunn (darkxst) wrote :

removed transitional -webkit2 package, that was not actually in the archive build.

Iain Lane (laney) wrote :

Looks like this was uploaded.

FWIW, in future I find it easier to work with a debdiff between the Debian and Ubuntu versions - in this case between 3.10.1-1 and 3.10.3-ubuntu1.

Changed in epiphany-browser (Ubuntu):
status: Incomplete → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package epiphany-browser - 3.10.3-0ubuntu1

---------------
epiphany-browser (3.10.3-0ubuntu1) trusty; urgency=low

  * New upstream release (LP: #1260942)
  * Sync with Debian. Remaining changes:
    - debian/patches/07_bookmarks.patch:
      Add Ubuntu-specific default bookmarks, borrowed from Firefox
    - debian/patches/81_ubuntu_force_update_bookmarks_menu.patch:
      update the bookmarks menu every time the internal structure
      is changed (needed for the indicator application menu to work
      correctly).
    - Don't depend on gnome-desktop3 3.10
   * debian/patches/00_epiphany-browser.patch: Refreshed
 -- Tim Lunn <email address hidden> Sat, 14 Dec 2013 07:46:25 +1100

Changed in epiphany-browser (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers