eog 3.2.1 doesn't display raw files

Bug #967471 reported by crf on 2012-03-28
34
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Confirmed
Wishlist
eog (Ubuntu)
Low
Unassigned

Bug Description

EOG 3.2.1 (eye of gnome) doesn't display canon raw files. Neither does nautilus.
fspot and shotwell display them. The image opens, but it just displays a checkerboard pattern.

EOG displaying RAW worked in Ubuntu 11.04, but does not now work since I updated to 11.10.

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you add an image example to the bug?

Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

bug #685196 suggests it's not a new issue

crf (chrisfahlman) wrote :

I don't know whether it is a new issue, however, as I said, it worked in Ubuntu 11.04, and doesn't in 11.10. Therefore this is a new regression.
The bug linked to in the previous comment said it didn't work in 10.04 ~~ that's a release from a long time ago.

Felix Riemann (friemann) wrote :

Please note that eog doesn't support RAW images out of the box. To have it use the actual RAW data it needs the gdk-pixbuf loader from libopenraw installed (which according to packages.ubuntu.com doesn't seem to be shipped with Ubuntu).

If the loader is not installed, often the TIFF loader will kick in as many RAW formats are actually specially organized TIFF files, which is also the reason why eog is listed as a supported application for these files. The TIFF loader then tries to load the first image from the file which is often an already developed variant of the RAW image (which then will be shown in eog).

Unfortunately the pixbuf loader from libopenraw is not always a painless experience with eog at the moment. We have seen it produce wrong colors at least for Canon CR2 files (the one attached here too) with recent library versions.

crf (chrisfahlman) wrote :

I got nautilus to display raw files.
(http://ubuntuforums.org/showthread.php?t=1859267)

So it is just an eog issue now.

---
I tried building and installing libopenraw from freedesktop.org.

If I run gdk-pixbuf-query-loaders I get in the output:

"/usr/lib/x86_64-linux-gnu/gdk-pixbuf-2.0/2.10.0/loaders/libopenraw_pixbuf.so"

and I ran

gdk-pixbuf-query-loaders --update-cache

And now eog displays RAW, but in a corrupted fashion. The colours are all wrong.

Perhaps I did something wrong in building, or I see why this is not enabled on Ubuntu.

---

But why, as eog displayed my raw files fine in Ubuntu 11.04, was it all changed?

Felix Riemann (friemann) wrote :

The wrong colors are what I meant in the last paragraph with libopenraw not being entirely painless yet.

The reason for why it worked before could be changes in libtiff assuming the library version changed between Ubuntu versions.
libtiff-3.9.5 apparently became a bit more strict regarding the TIFF layout than its predecessor and doesn't seem to make an assumption about missing or wrong TIFF settings anymore which made it work before.

This is likely going to stay this way as when I once tested it with libtiff-4.0 it wouldn't even load the preview from the CR2 but will cancel the image loading with an error message.

Confirmed, as it affects me as well.

BTW, it did work in 10.04. I upgraded to 12.04 yesterday, and lost CR2-file support in EOG since then.

Changed in eog (Ubuntu):
status: Incomplete → Confirmed
Bruce Smith (b-e-smith) wrote :

Confirmed for 12.04.

This regression hit my library of 16000+ CR2 files when I migrated from 11.04 to 11.10, last year. I was hoping it would be fixed for 12.04 but no such luck.

To make matters worse, if one selects say 10 RAW files & opens them with the Shotwell Photo Viewer, then one gets 10 instances of Shotwell (back when EOG used to work - oh those were the glory days - it would let you move from one image to the next inside the one instance).

This is a MAJOR inconvenience .... I can't believe many serious photographers are using Ubuntu 11.10 or 12.04.

Eugene Romanenko (eros2) wrote :

Confirm, EOG does not show my CR2 files since Oneiric. Still not work in Precise.
Has worked in Natty.

Eugene Romanenko (eros2) wrote :

Alternative - use gThumb (needs also dcraw).

lock042 (lock042) wrote :

This bug does affect me since Ubuntu 11.10. I can read my Raw only with software like rawtherapie, ufraw, darktable, Corel AfterShot (nonfree), etc ...
I can display thumbnails in Nautilus and if I well remember the problem remains by using alternative software like gThumb.

lock042 (lock042) wrote :

Forget what I said, Gthumb works very well on Ubuntu 12.04

Sebastien Bacher (seb128) wrote :

@Bruce: shotwell should let you browse your collection just fine

Sees to be affecting Ubuntu 12.04 Image Viewer 3.4.2. This is probably a duplicate of #860672

Changed in eog:
importance: Unknown → Wishlist
status: Unknown → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.