Eye of Gnome crashs when saving a rotated image

Bug #951463 reported by Boris Pérez on 2012-03-10
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
Medium
Tom Gall

Bug Description

Ubuntu 12.4 (Beta)
Eye of Gnome 3.3.91
Steps:
Open an image
Rotate Image
Save image (it never saves)

Then it crashes

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: eog 3.3.91-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-18.28-generic 3.2.9
Uname: Linux 3.2.0-18-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.94.1-0ubuntu1
Architecture: i386
CrashCounter: 1
Date: Sat Mar 10 12:18:07 2012
ExecutablePath: /usr/bin/eog
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: eog /home/username/Escritorio/Documento\ escaneado.jpg
ProcEnviron:
 LANGUAGE=es_ES:en
 PATH=(custom, no user)
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x80a5df4 <jtransform_execute_transform+2036>: mov (%ecx,%edi,4),%eax
 PC (0x080a5df4) ok
 source "(%ecx,%edi,4)" (0x6a28a28a) not located in a known VMA region (needed readable region)!
 destination "%eax" ok
 Stack memory exhausted (SP below stack segment)
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: eog
StacktraceTop:
 jtransform_execute_transform ()
 ?? ()
 eog_image_save_by_info ()
 ?? ()
 eog_job_run ()
Title: eog crashed with SIGSEGV in jtransform_execute_transform()
UpgradeStatus: Upgraded to precise on 2012-03-09 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Boris Pérez (borisdsp) wrote :

StacktraceTop:
 do_rot_90 (dst_coef_arrays=0x6a28a28a, src_coef_arrays=0xb613255c, y_crop_offset=3188662537, x_crop_offset=2433253899, dstinfo=0xb7323c50, srcinfo=0xb7323a6c) at transupp-8a.c:431
 jtransform_execute_transform (srcinfo=0xb7323a6c, dstinfo=0xb7323c50, src_coef_arrays=0xb613255c, info=0xb7323a10) at transupp-8a.c:1467
 _save_jpeg_as_jpeg (image=<optimized out>, file=0xb6137ae0 "/tmp/eog-save-E8J2AW", error=0x8596e5c, source=<optimized out>, target=<optimized out>) at eog-image-jpeg.c:324
 eog_image_save_by_info (img=0xb6105000, source=0xb6102890, error=0x8596e5c) at eog-image.c:1864
 eog_job_save_run (ejob=0x8596e50) at eog-jobs.c:643

Changed in eog (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Boris Pérez (borisdsp) on 2012-03-10
Changed in eog (Ubuntu):
status: New → Invalid
status: Invalid → New
status: New → Invalid
status: Invalid → New
Boris Pérez (borisdsp) wrote :

I dont know why but it only happens with 1 scanned image, tested with two diferents one and no crash.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
visibility: private → public
affects: eog (Ubuntu) → libjpeg-turbo (Ubuntu)
Tom Gall (tom-gall) on 2012-04-18
Changed in libjpeg-turbo (Ubuntu):
assignee: nobody → Tom Gall (tom-gall)
Tom Gall (tom-gall) wrote :

@ borisdsp - Boris would you be willing to share you one image that is having problems? I've been locally trying various images and thus far things are working well. If you want my email address is <email address hidden>.

However (!) : with my fresh precise install I have eog 3.3.92 and I've also an updated version of libjpeg-turbo8. (1.2.1+svn823) which I'm about to queue as an update to libjpeg for the archive.

If you'd like to try this newer version of libjpeg-turbo8, it currently can be found on ppa:linaro-maintainers/staging-overlay

Boris Pérez (borisdsp) wrote :

New things happens. First of all it keep giving error (not crashing) When I rotate an image and File - Save "EOG" says:
(It says it can't save in spanish)
No se puede guardar document.jpg
Error interpreting JPEG image file: eog-save-DI5JDW
Maximum supported image dimension is 65500 pixels.
 May not an bug, just a limitation (doesn't happens on PNGs)

However, if you rotate the image and close EOG, "Do you want to save..?" And you save it, there are no errors, it just works.

Answering to Tom, I have a scanned image wich I used to test all that today.
http://ubuntuone.com/3eY9Gm2EWoL1xvOJVNqX6C

I have tested the PPA package and has been a crash again, it just doesnt fix the problem.
Cheers

Tom Gall (tom-gall) wrote :

I'll test your image, as I just fixed bug 960967, I have a strong feeling this bug is a duplicate of that one.

Changed in libjpeg-turbo (Ubuntu):
status: Confirmed → In Progress
Tom Gall (tom-gall) wrote :

Tested. Load image, rotate 90 to the right, save. works. So the fix for bug #960967 (and is attached to that bug) will address this as well. I'm going to mark as such.

EOG maintainers, please act on the other bug.

Tom Gall (tom-gall) wrote :

patch applied to bug #960967 also fixes this bug.

affects: libjpeg-turbo (Ubuntu) → eog (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers