Ubuntu

GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

Reported by Laurent Bonnaud on 2011-04-08
286
This bug affects 59 people
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
Undecided
Unassigned
libdbusmenu (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: eog

eog displays those scary error messages when displaying some JPEG images:

$ eog autotools.jpg

(eog:3215): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed
[same error message repeated 14 times]

Those messages are a problem because they can rapidly fill the ~/.xsession-errors file.

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: eog 2.32.1-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-8.41-generic-pae 2.6.38.2
Uname: Linux 2.6.38-8-generic-pae i686
Architecture: i386
Date: Fri Apr 8 15:11:48 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/eog
SourcePackage: eog
UpgradeStatus: Upgraded to natty on 2009-10-10 (545 days ago)

Here is a JPEG file to reproduce the error.

I have the same problem on natty beta 1. The file reaches the size of 100 MB in a few hours.

I attach a file with errors in the last minute

 noticed that this does not happen using nautilus as root

Hi, the problem persists even with fewer errors (nautilus 2.32.2.1-0ubuntu13 Natty x86_64 beta 2).

I attach a video that shows the error

demilord (demilord) wrote :

My xsession-errors file grows excessively after 2 hours its almost 1MB ..
with 99% with lines

(nautilus:1438): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed
Running Ubuntu gnome classic interface..

Matt (macmanes) wrote :

Same error as demilord.. Using 11.04 regular view

Glenn Mc (gmce-93) wrote :

This post probably won't help out but I'm getting the same error too...I don't want to wait 'til October for the .10 release because Natty is pretty great besides this perennial lag.

+subscribed

dino99 (9d9) wrote :

its heavily flooding xsession-errors on Oneiric i386

Changed in eog (Ubuntu):
status: New → Confirmed
RHTopics (tyrht01) wrote :

This is still happening in 11.10 Desktop i386.

(eog:2245): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

Plus the ~/.xsession-errors contains 264 of these type messages with the system being up for less than 50 minutes.

As with bug #738203, the error messages do not appear on the first eog invocation. They are only displayed the second (and later) time.

Daniel Schlieper (schlieper-r) wrote :

Happens in 11.10 Desktop x64 as well.

(eog:2749): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

Achim Behrens (k1l) wrote :

running 11.10 64bit with nvidia-current-updates
using radiance theme on unity.

getting the same error for nautilus:
(nautilus:1894): GLib-GObject-CRITICAL **: g_value_get_object: assertion `G_VALUE_HOLDS_OBJECT (value)' failed

unity lags like beeing on a pentium 2 :/

This affects me as well.

running 11.10 64bit
Intel video card --
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

using Ambiance theme on Unity

Andreas Leitgeb (avl-logic) wrote :

I start "eog somepic.png" from terminal in a directory that also contains a couple of images apart from somepic.png.
somepic shows without any critical-messages. When I change to other pics (with spacebar/backspace, or arrow-buttons) I get 4 CRITICALs per new image displayed.

Also happens in 11.10 when trying to copy and paste text in gedit, while viewing the log .xsession-error log file. Attached .xsession-errors file

Devendra Maharjan (devendram) wrote :

How to solve this problem? size of .xsession-errors file is increasing every second

David Benjamin (davidben) wrote :

Still happens on 11.10. If you use G_DEBUG=fatal-criticals and catch the error with gdb, this bug comes from dbusmenu.

I cannot reproduce this bug any longer in quantal. Could somebody else confirm this before I close the bug ?

dino99 (9d9) wrote :

hi Laurent

i get the same result on quantal i386 (gnome-classic)

dino99 (9d9) wrote :

So you can close that report i suppose.

Andreas Leitgeb (avl-logic) wrote :

Is there a remote chance for a backport to pangolin?

Changed in libdbusmenu (Ubuntu):
status: New → Fix Released
Changed in eog (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers