Ubuntu

Image Viewer fails to render text curved along a path in an SVG file

Reported by Captain Chaos on 2010-12-23
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
New
Medium
librsvg
New
Undecided
Unassigned
eog (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: eog

Image Viewer fails to render the curved text in the Sinterklaas poem I created using Inkscape. It contains text curved along a spiral path, which displays and prints correctly in Inkscape itself. Inkscape saved it as an SVG file, but in the thumbnail displayed by Nautilus the curved text is not displayed, and when I open the file in Image Viewer, the curved text is completely missing as well. I will attach the file in question.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: eog 2.30.0-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-27.49-generic 2.6.32.26+drm33.12
Uname: Linux 2.6.32-27-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu Dec 23 14:20:06 2010
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
SourcePackage: eog

Captain Chaos (launchpad-chaos) wrote :
Captain Chaos (launchpad-chaos) wrote :

I noticed that Firefox does display the curved text (although it renders it differently than Inkscape, causing a few characters to be missing at the end), so I don't think the problem is with the SVG file itself.

Robert Roth (evfool) wrote :

Added librsvg as eog uses it for SVG rendering.

Captain Chaos (launchpad-chaos) wrote :

I suspect that Nautilus uses librsvg too then, that would explain that the text is also missing from the thumbnail (or does Nautilus not generate the thumbnail itself?).

Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The issue is an upstream one and it would be nice if somebody having it could send the bug the to the people writting the software (https://wiki.ubuntu.com/Bugs/Upstream/GNOME)

Changed in eog (Ubuntu):
importance: Undecided → Low
Captain Chaos (launchpad-chaos) wrote :

I have report the bug at bugzilla.gnome.org as bug 644624: https://bugzilla.gnome.org/show_bug.cgi?id=644624

Captain Chaos (launchpad-chaos) wrote :

I also verified that the bug still exists in Ubuntu Maverick / eog version 2.32.0.

Changed in eog:
importance: Unknown → Medium
status: Unknown → New
Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in eog (Ubuntu):
status: New → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.