if saving an image fails it's done silently

Bug #673299 reported by Alan Pope 🍺🐧🐱 πŸ¦„ on 2010-11-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
High
eog (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: eog

Open a png image (such as the one attached to this bug report), and try to save as a .ico file.

Image -> Save As ->

Name: test.ico
Click Save.

No file is saved.

.ico files can be saved only up to 256x256 pixels, if the size is larger GDKPixbuf shows and error but that message is not shown to the user by eog.

DistroRelease: Ubuntu 10.10

If I resize the image down to 16x16 before opening with eog then it _will_ save as an ico, but any other size it just refuses.

Robert Roth (evfool) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME. If you have done so, please tell us the number of the upstream bug (or the link), so we can add a bugwatch that will inform us about its status. Thanks in advance.

Pedro Villavicencio (pedro) wrote :

the problem is that .ico can only be up to 256x256 pixels. GDKPixbuf returns an GError for that but eog is not catching the error nor telling the user that the image should be resized, there's an upstream bug for that here: https://bugzilla.gnome.org/show_bug.cgi?id=615376 ; readjusting the bug title and linking to that report, thanks in advance.

Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Triaged
summary: - Can't save as .ico
+ if saving an image fails it's done silently
description: updated
Changed in eog:
importance: Unknown → High
status: Unknown → Confirmed
Changed in eog:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.1.4-0ubuntu1

---------------
eog (3.1.4-0ubuntu1) oneiric; urgency=low

  * New upsteam release:
    - if saving an image fails it's done silently (LP: #673299)
  * debian/control:
    - set Vcs-Bzr to the ubuntu-desktop team, no gnome3-team
 -- Didier Roche <email address hidden> Tue, 26 Jul 2011 15:28:21 +0200

Changed in eog (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.