after editing in EOG with Shotwell, the picture in EOG is not actualized

Bug #632810 reported by YannUbuntu on 2010-09-08
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Invalid
Medium
eog (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: eog

- open an image with EOG
- click on the "Image edition" menu
- edit the image
- save the modification
-close the edition (Shotwell) window

RESULT : the image is modified indeed, but EOG does not update it, and neither Nautilus (the thumbnail on the Desktop is not updated)

EXPECTED RESULT : image is updated in EOG and in the Desktop thumbnail.

Hope this helps make Ubuntu better !

Sebastien Bacher (seb128) wrote :

thank you for your bug report, do you get other change events working? if the thumbnail doesn't work it's not an eog issue

Changed in eog (Ubuntu):
importance: Undecided → Low
YannUbuntu (yannubuntu) wrote :

Thanks for your answer Sebastien.
I remember I already reported the same bugs in Lucid when Lucid's EOG used the Fspot editor :

https://bugzilla.gnome.org/show_bug.cgi?id=614634 (EOG prevents the Desktop thumbnails to be updated.)
https://bugzilla.gnome.org/show_bug.cgi?id=614635 (EOG is not updated after the image is edited)

IMHO the problem is that EOG developpers don't care much, because this situation is due to the "Edit image" button which is added by Ubuntu devs. -> is that the kind of bugs where Ubuntu's devs should help upstream ones ?

I would had set this as more important than "Low" , as users will think that EOG's editor is not working, and will get confused for sure.

Sebastien Bacher (seb128) wrote :

is that bug a duplicate of bug #548880 then?

YannUbuntu (yannubuntu) wrote :

bug #548880 is obsolete as it concerned F-spot, but I marked it duplicate of this one as the upstream bug is the same.

I also created bug #633228 and changed this bug's description to reflect the 2 separate upstream bugs.

I hope it is clearer to understand now.

summary: - [10.10 beta] after editing in EOG with Shotwell, the picture in EOG is
- not actualized, and neither the thumbnail on the Desktop
+ after editing in EOG with Shotwell, the picture in EOG is not actualized
YannUbuntu (yannubuntu) wrote :

A patch has been created upstream (thank you Claudio!). Hope this will be integrated on time for 10.10 !

Sebastien Bacher (seb128) wrote :

the change has not been commited yet and add new strings so it will be next cycle rather

Changed in eog (Ubuntu):
status: New → Fix Committed
YannUbuntu (yannubuntu) wrote :

Then IMHO we should remove the "Edit button in EOG", until next cycle.

YannUbuntu (yannubuntu) wrote :

Other ideas (don't know if feasable) to minimize the impact of this bug in 10.10 :
- add a "Reload" button in Maverick's EOG
- automatically reload EOG when its editor (Shotwell) is closed.

The "Edit picture" button added by Ubuntu in EOG makes this bug very visible by Ubuntu users. This is not a critical bug, but I believe it is quite important because of its high visibility : everybody who will use the "Edit picture" button in EOG will be confused and will think the editor is broken.

I think we can't leave such a bad "user experience" in 10.10.

Guillaume Mazoyer (respawneral) wrote :

I agree, that can be really bad for the user experience.
If a fix has been committed upstream, then it will be a good idea to patch the current package with it.

Sebastien Bacher (seb128) wrote :

YannUbuntu, you seem to care a lot about this bug but it has one duplicate and 3 affect users, other users seems to not be bothered that much by it, it seems it can wait another cycle

Changed in eog:
importance: Unknown → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 2.31.92-0ubuntu1

---------------
eog (2.31.92-0ubuntu1) maverick; urgency=low

  * New upstream release:
    - Copy image to disk when setting as desktop background when it is
      located on removable media (Claudio Saavedra)
    - Ask user whether to reload an externally modified image
      (Claudio Saavedra)
    - Miscellaneous code fixes (Claudio Saavedra)
    - Side pane always shown at startup when plug-in is activated
      (Claudio Saavedra)
    - EOG prevents the Desktop thumbnails to be updated (Claudio Saavedra)
      (LP: #632810)
    - Background setting doesn't work as expected (Claudio Saavedra)
    - New and updated translations
  * Update debian/patches/02_toolbar_edit_button.patch
 -- Didier Roche <email address hidden> Mon, 20 Sep 2010 13:04:27 +0200

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
YannUbuntu (yannubuntu) wrote :

Thank you all for your great work, the fix works well in updated 10.10 beta.

Just a minor bug remains, but I believe it has a different origin, so I created a new bug report : bug #644133

best regards.

Changed in eog:
status: Unknown → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related blueprints

Remote bug watches

Bug watches keep track of this bug in other bug trackers.