fist double-click does nothing, second opens eog but not image

Bug #362783 reported by David Prieto on 2009-04-17
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Unknown
Unknown
eog (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: eog

I'm suffering a bug where EOG randomly fails to open (at least) PNG images: the first time I double-click them, nothing happens. The second time I double-click them EOG opens, but it does not show the image (screenshot attached).

This seems to happen randomly, and if you double-click the image several times it opens fine sooner or later.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
NonfreeKernelModules: nvidia
Package: eog 2.26.1-0ubuntu1
ProcEnviron:
 LANG=es_ES.UTF-8
 SHELL=/bin/bash
SourcePackage: eog
Uname: Linux 2.6.28-11-generic i686

Sebastien Bacher (seb128) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please answer these questions:

 * Is this reproducible?
 * If so, what specific steps should we take to recreate this bug?
 * Do you have any error in .xsession-errors?

 This will help us to find and resolve the problem.

Changed in eog (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete

Just take a screenshot, save it to the desktop and start opening and closing it once and again. It happens randomly, so you should get it sooner or later.

I didn't see anything relevant in .xsession-errors, but I'm attaching it anyway, just in case.

Sebastien Bacher (seb128) wrote :

nobody else complained about that, is that specific to eog? are you sure you don't have mouse issues?

I am sure it's not a mouse issue, as can be seen in the screenshot. I would have doubts if EOG just didn't start, but after not starting it systematically opens without opening the image.

I have to say though, I have been trying to reproduce the bug and it hasn't happened for a while. It did this morning but not now, for some reason.

Sebastien Bacher (seb128) wrote :

the bug should be opened on bugzilla.gnome.org, where the people writting the code will read it, by somebody having the issue

Sebastien Bacher (seb128) wrote :

do you still get the issue? could you open a GNOME bug?

Hi Sebastien,

No, for some reason I've never gotten it again. Only that day, several times, but never again.

Sebastien Bacher (seb128) wrote :

closing the bug since that works now

Changed in eog (Ubuntu):
status: Incomplete → Invalid

Hi all, I am reopening this bug, and would like some people to try opening the JPG file with eog attached to this post.

I had this problem with some files... but the problem seems more or less intermitent. But with this file, almost all the time. You can also try to open the file with the command line.

If some people confirm this, I'll open a bug report on bugzilla if Ubuntu 10.10 and eog 2.32 does the problem too.

Changed in eog (Ubuntu):
status: Invalid → New
Id2ndR (id2ndr) wrote :

I can confirm on Ubuntu 10.10 that the trouble appears most of the time with the image that you attached.
I get the trouble with other images (like screenshot produced by gnome-screenshot) but the rate of failure is lower with these one.

Id2ndR (id2ndr) wrote :

Interesting, I tried this : $ while true; do eog 109d51c36a79b78f81d31867daca03dd.jpg & sleep 2 ; kill %1 ; sleep 1; done

On my computer, the image appears about 50% of the time. I often get 3 or 4 tries with the images, and the 3 or 4 next tries the window of eog doesn't appear. I fail to get the window with no image inside using the commands above.

ok, it is now in bugzilla!

Robert Roth (evfool) wrote :

In the upstream bug a comment mentions, that this is caused by a the Date in status bar plugin being enabled, but has been fixes since then. I have tested with multiple images from this bug report and the related upstream ones, and none of them had this behavior, neither with the plugin enabled, nor with the plugin disabled. The images loaded 10 times out of 10. Also note, that the upstream task for this is marked as Fixed, so I am merking this bug as Fix released too. If you still experience this issue, please reopen the bug and describe the exact steps needed to reproduce this issue.

Changed in eog (Ubuntu):
status: New → Triaged
status: Triaged → Fix Released
Felix Riemann (friemann) wrote :

JFYI, the differentiation is pretty easy here.
eog-2.32.1 has the workaround, while a stock 2.32.0 (as likely included in Ubuntu 10.10) doesn't unless patched (like e.g. in Fedora 14).

Since the bug depends on the running order of the plugin thread and the image loading thread the bug might not be visible everywhere (the bug existed probably since 2008 when the plugin was introduced, yet it wasn't reported until last year) , also IIRC you needed to have automatic rotation enabled in addition to the plugin.

Robert Roth (evfool) wrote :

Set status back to Triaged as of the last comment.

Changed in eog (Ubuntu):
status: Fix Released → Triaged
carlos (cplopez) wrote :

I have the same problem with images (not only png). Also seems random to me, and has exactly the behavior written in the bug description. It is not a mouse issue since opening with "Enter" has the same effect. I use eog 2.32.0

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.