No colour conversion when image does not have embedded ICC profile

Bug #272584 reported by Milan Knizek on 2008-09-20
40
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
eog (Ubuntu)
Low
Unassigned

Bug Description

Ubuntu Hardy amd64, eog 2.22.3-0ubuntu2

Eye of Gnome correctly displays colours of images, which have embedded ICC profile. Other images are displayed without any colour conversion to the colour space of the monitor (as defined by tools like xcalib, xicc).

Correct behaviour would be to assign sRGB profile to images without embedded profile.

(sRGB colour space is de facto standard for PCs and images on the internet. Mozilla Firefox 3.x does so, too.)

Pedro Villavicencio (pedro) wrote :

thanks for the report, could you take a couple of screenshot and also attach and image sample to the report? thanks.

Changed in eog:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Milan Knizek (knizek) wrote :

Attached are the following files:

eog_screenshot.jpg - left image is correctly displayed (this is how it is displayed also in GIMP with colour management active), right image has wrong colours (too saturated red).

image_sRGB.jpg - test image with embedded ICC profile (sRGB).

image_no_icc_im.jpg - test image without embedded ICC profile. The profile was stripped by "convert image_sRGB.jpg +profile icc image_no_icc_im.jpg"

It appears to me that "image_no_icc_im.jpg" was not converted to the monitor profile and displayed "as-is" - i.e. on wide gamut monitor it appears over-saturated.

Few notes:

My monitor is Samsung XL20 capable of displaying gamut close to AdobeRGB. The monitor profile was created by ArgyllCMS; xcalib set the profile to update LUT (or rather X gamma curves) and the xicc atom, which is supposedly used by EoG, GIMP and few other applications.

The eog_screenshot.jpg was assigned the monitor profile (i.e. wide gamut) and converted to sRGB with perceptual rendering intent so that it displays correctly on standard monitors even in applications not supporting colour management.

NB that on a standard monitor, which has gamut close to sRGB, you probably won't see a significant difference between the two test images, since their gamut is sRGB, too.

Milan Knizek (knizek) wrote :

I have replaced the attachment - the test file "image_no_icc_im.jpg" was substituted by "image_noicc_noexif.jpg" to make sure that "Exif:ColorSpace" tag does not influence EoG.

Sebastien Bacher (seb128) wrote :

the issue is an upstream one, could you open the bug on bugzilla.gnome.org where the people writting the software will read it?

Sebastien Bacher (seb128) wrote :

Thank you for sending the bug to GNOME

Changed in eog:
status: Incomplete → Triaged
Changed in eog:
status: Unknown → New
Changed in eog:
status: New → Confirmed
Changed in eog:
importance: Unknown → Medium
Tayroni Alves (tayroni-alves) wrote :

Hi, this issue is on last version on precise beta!

Christophe (christophe-wk3) wrote :

There seems to be a patch over there: https://bugzilla.gnome.org/show_bug.cgi?id=668369

Changed in eog (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
pdknsk (pdknsk) wrote :

I've attached a patch to the bug tracker.

Changed in eog:
status: Confirmed → Fix Released
Changed in eog (Ubuntu):
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.10.2-0ubuntu4

---------------
eog (3.10.2-0ubuntu4) trusty; urgency=medium

  * debian/patches/git_icc_color.patch
    - use sRGB when there is no profile attached to the image (lp: #272584)
 -- Sebastien Bacher <email address hidden> Mon, 10 Mar 2014 19:17:48 +0100

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.