Ubuntu

eog doesn't ask whether to save changes

Reported by Manu Cornet on 2005-11-11
54
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
One Hundred Papercuts
Undecided
Marcus Carlson
eog (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

1. Open an image with eog
2. For example, rotate the image clockwise (to, say, let a vertical photo be
upright)
3. Close the window

eog just quits, no questions asked. The change has not been saved.

What should happen : eog should ask the user whether to save changes, or maybe
even save changes automatically (in the case of rotating images, I think it
would be natural ?).

I am running an up-to-date breezy.
eog 2.12.1-0ubuntu2

http://bugzilla.gnome.org/show_bug.cgi?id=322243: http://bugzilla.gnome.org/show_bug.cgi?id=322243

see also:
http://bugzilla.gnome.org/show_bug.cgi?id=338138

Sebastien Bacher (seb128) wrote :

Thanks for your bug. I've forwarded it upstream:
http://bugzilla.gnome.org/show_bug.cgi?id=322243

I'm not sure they will change that though. They seem to consider eog as a quick
viewer (like evince for PDF), other apps like f-spot manage your photo
collections by example.

Changed in eog:
assignee: seb128 → desktop-bugs
status: Unconfirmed → Confirmed
Changed in eog:
status: Unconfirmed → Confirmed
Changed in eog:
status: Confirmed → In Progress
Changed in eog:
status: Confirmed → Triaged
Adi Roiban (adiroiban) wrote :

I'm also requesting this feature.

I hate how slowly things are moving in gnome. They argue for years and nothing happens. It's like Debian! Maybe we should have a special gnome branch in ubuntu!

Brett Alton (brett-alton) wrote :

Oh my lord, I HATE this bug.

I go through and rotate twenty photos and then close the program never knowing that when it rotating, it wasn't also saving. I look at my collection of photos and they're still the same.

So NOW, I go and rotate one photo, save it (ctrl + s), then close eog because it resets it's position meaning you can't click next to see the next photo, then double click on the next photo in my collection. That bug is here: https://bugs.launchpad.net/ubuntu/+source/eog/+bug/152785

I think that it should cache all of the changes to your photos so when you exit and have changed 20 images, it asks if you'd like to 'Save All Changes'. If that's too intense to program, it should at the very least ask to save after every rotation of the photo.

exactt (giesbert) on 2007-11-07
description: updated
Brett Alton (brett-alton) wrote :

Sorry, but I must reiterate: I installed eog 2.21.3 in Gutsy (with magic ;) ) and there is no "What You See Is What You Get" function (where when you rotate the image, it rotates on disk) or save dialogue pop ups warning the user that their changes have not been saved upon exiting. I'm worried for the sake of functionality when it comes to the Desktop user always having to hit 'ctrl + s' after every rotation... I'm sorry, but people just don't want to do it.

Pelládi Gábor (pelladigabor) wrote :

The current behavior is the same as 3 years ago. Silently discarding the user's work, his modifications is the worst method. I would support saving the image at once after a lossless(!) rotation. The approach to ask the user on closing eog if he wants to save all rotations can be a compromise.

Lorenzo (lorenzo-delledonne) wrote :

Adding this bug to the "One Hundred Paper Cuts" project after triaging bug #389083.

Martin Albisetti (beuno) wrote :

Agreed, it should ask you.

Changed in hundredpapercuts:
status: New → Confirmed
Changed in hundredpapercuts:
milestone: none → round-5
John Montgomery (blueyonder64) wrote :

This may indeed be an easy fix to implement, but might not a more simple solution be to simply remove eog from the default Ubuntu install and instead replace it with gThumb, which already provides "save" confirmation dialogs as well as icnluding a few more editing options than eog, as the default application which opens when the user double clicks an image file? This solution would serve two purposes: 1) removing yet another application from the catalog and 2) eliminate having to deal with the confirmation dialog bug altogether. I don't believe that gThumb is an official GNOME application, but then again neither are many other applications included in a fresh Ubuntu install.

Just a suggestion.

Ben Bucksch (benbucksch) wrote :

Please only save automatically, if it's lossless (only metadata changed).

If the JPEG itself is altered when rotating (which would be lossy), saving automatically would be a several bug IMHO (this is an image *viewer*, and I don't expect it to alter my files, much less in a damaging way, just because I wanted to *view* them rotated).

John Montgomery (blueyonder64) wrote :

Completely agree with Ben Bucksch. As he already stated, this app is primarily a viewer rather than an editor, and if it's going to make any permanent changes to an image file they at all, they should certainly be implemented in a completely non-destructive manner. IMHO, this only reinforces the logic behind my previous proposal as well, as this would accomplish what Ben desires without any retooling required aside from pointing image files to gThumb as the default rather than eog. It is for these very reasons that I change the default image viewer on my own machines to gThumb immediately after a fresh install, so as to avoid the aforementioned frustration caused by the absence of save dialogs in eog, as well as the choice in quality settings presented by gThumb after choosing to save the rotated image file.

Again, just my two cents.

Changed in hundredpapercuts:
assignee: nobody → Marcus Carlson (0-launchpad-mejlamej-nu)

This should be fixed in Ubuntu 10.04 now. Thanks for reporting.

Changed in eog (Ubuntu):
status: Triaged → Fix Released
Changed in hundredpapercuts:
status: Confirmed → Fix Released
Changed in eog:
importance: Unknown → Medium
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.