Metadata box should have limited width

Bug #205483 reported by André Barmasse on 2008-03-23
6
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Medium
eog (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: eog

Hello

When an image has a large title or description in its metadata there is no automatic line break in the metadata display window of eog. If you open the metadata window by pressing ALT+ENTER it can be three or four times the width of your monitor - depending on how much metadata text you have entered. The really annoying part is that you have no possibility to resize it! Therefore, It would be nice if the metadata window had some kind of automatic line break or justifying - like this HTML page for example which breaks text automatically when resized.

It seems that this is a gnome problem as the same thing happens with evince and PDF metadata:
https://bugs.launchpad.net/ubuntu/+source/evince/+bug/184874

I have added an example picture. Try it out!

Related branches

André Barmasse (barmassus) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=528454

Changed in eog:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Triaged
Changed in eog:
status: Unknown → New
Changed in eog:
status: New → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream, thanks for reporting.

Changed in eog:
status: Triaged → Fix Committed
Sebastien Bacher (seb128) wrote :
Changed in eog:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in eog:
status: Confirmed → Fix Committed
Sebastien Bacher (seb128) wrote :

a new rebuild revision has been uploaded now to some libglib issues, would be nice to give testing to this one too

Sebastien Bacher (seb128) wrote :

there is a newer version is in intrepid now

Changed in eog:
status: Fix Committed → Fix Released
Pedro Villavicencio (pedro) wrote :

verification done:

test with eog 2.22.2-0ubuntu1, after open the metadata dialog with ALT+ENTER the dialog is resized and goes off the screen.
test with eog 2.22.3-0ubuntu2, after open the metadata dialog with ALT+ENTER the dialog isn't resized because the labels are using the ellipsize mode now which prevent it to expand too much, the bug is fixed, thanks.

Martin Pitt (pitti) wrote :

Copied to hardy-updates.

Changed in eog:
status: Fix Committed → Fix Released
Changed in eog:
importance: Unknown → Medium

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

Guten Tag

Die Adresse <email address hidden> wird demnächst deaktiviert.
Schreiben Sie in Zukunft bitte nur noch an <email address hidden>.
Ihre Nachricht wurde bereits an die neue Adresse weitergeleitet.

Mit freundlichen Grüssen. André Barmasse

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.