3.36.2 update include fix for custom loaders

Bug #1873424 reported by Marian Rainer-Harbach on 2020-04-17
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Unknown
Unknown
eog (Ubuntu)
Low
Unassigned
Focal
Undecided
Unassigned

Bug Description

* Impact
That's the current GNOME stable update, including some fixes and translation updates
https://gitlab.gnome.org/GNOME/eog/-/blob/gnome-3-36/NEWS

* Test case

The update is part of GNOME stable updates
https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

Check that opening images is still working correctly

* Regression potential

There are some changes around the shortcut dialog, check that the correct actions are listed there

---------------------------------

In Ubuntu 19.10 I was able to view HEIF/HEIC files in Eye of Gnome by installing an appropriate gdk-pixbuf loader. In Ubuntu 20.04 eog just shows the message "Could not load image <filename>. Unrecognized image file format".

The HEIF gdk-pixbuf loader itself seems to work correctly, because gcpicview is able to display HEIF images even on Ubuntu 20.04. It's just eog that doesn't seem to use the loader anymore.

I attached an example file 2020-04-11-14-45-361180.heic.

This command works and displays the file: gpicview 2020-04-11-14-45-361180.heic
This command shows the error message mentioned above: eog 2020-04-11-14-45-361180.heic

Installed versions:
eog:
  Installed: 3.36.1-1
  Candidate: 3.36.1-1
  Version table:
 *** 3.36.1-1 500
        500 http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status

heif-gdk-pixbuf:
  Installed: 1.6.1-1build1
  Candidate: 1.6.1-1build1
  Version table:
 *** 1.6.1-1build1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/status

libheif1:
  Installed: 1.6.1-1build1
  Candidate: 1.6.1-1build1
  Version table:
 *** 1.6.1-1build1 500
        500 http://archive.ubuntu.com/ubuntu focal/universe amd64 Packages
        100 /var/lib/dpkg/status

Sebastien Bacher (seb128) wrote :

Thank you for your bug report, could you report it upstream on https://gitlab.gnome.org/GNOME/eog/issues/

Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

Thanks for looking at this bug. I now reported it upstream at https://gitlab.gnome.org/GNOME/eog/-/issues/124.

Sebastien Bacher (seb128) wrote :

Thanks!

Changed in eog (Ubuntu):
status: Confirmed → Triaged

@seb128: The bug was fixed upstream for GNOME 3.36.2. Would it be possible for you to pull the change into Ubuntu's package so that it's available for the 20.04 release? It looks like a pretty small change to me.

Sebastien Bacher (seb128) wrote :

Sorry but it's late now for getting changes on the release, fixes are limited to those impacting the installer or default installation in an important way. We will get the .2 update as a stable update soon enough though

Changed in eog (Ubuntu):
status: Triaged → Fix Committed
description: updated
summary: - Regression: eog cannot open files via gdk-pixbuf loader in Ubuntu 20.04
+ 3.36.2 update include fix for custom loaders

Hello Marian, or anyone else affected,

Accepted eog into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/eog/3.36.2-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in eog (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal

I tested eog version 3.36.2-0ubuntu1 from focal-proposed:
I can confirm that this version fixes the problem. I can now open HEIF/HEIC files again. Opening JPEG and PNG files also still works.

tags: added: verification-done verification-done-focal
removed: verification-needed verification-needed-focal
Sebastien Bacher (seb128) wrote :

Thanks for doing the SRU verification!

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.36.2-0ubuntu1

---------------
eog (3.36.2-0ubuntu1) focal; urgency=medium

  * New stable update, include fix for custom image loaders (lp: #1873424)

 -- Sebastien Bacher <email address hidden> Tue, 28 Apr 2020 17:07:15 +0200

Changed in eog (Ubuntu Focal):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for eog has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.