eog does not preload the next/prev picture therefore it's slow

Bug #172719 reported by Alexandre Racine on 2007-11-29
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
eog (Ubuntu)

Bug Description

Binary package hint: eog

Mabey I am hard, but I am using irfanview on my Ubuntu machine with wine and the software is blazing fast compare to eog.

For a small test, I loaded the first picture of 133 and started to look at the pictures as fast has I can for 15 seconds.
With Irfanview, I go from 1 to 70 in 15 seconds.
With eog, I go from 1 to 13 in 15 seconds.

More notes

-eog used my CPU even after stopping the test.
-After loading the first image, Irfanview use 21MB, eog use 26,2MB
-After looking at 100 pictures, irfanview use 23,1MB, eog use 30,6MB
-eog use way more CPU power to do anything.

Been really slow is a bug. Not a critical one, but still one.

References :

Wine : http://www.winehq.org/
Irfanview : http://www.irfanview.com/

ProblemType: Bug
Architecture: i386
Date: Wed Nov 28 22:57:12 2007
DistroRelease: Ubuntu 7.10
ExecutablePath: /usr/bin/eog
NonfreeKernelModules: nvidia
Package: eog 2.20.1-0ubuntu1
PackageArchitecture: i386
ProcCmdline: eog file:///home/aracine/multimedia/photos%20originales/irfanview-temporaire/Photo%20par%20Josie%20et%20Louis%20(1)%20Josie%20%26%20Ruba.JPG
ProcCwd: /home/aracine
SourcePackage: eog
Uname: Linux aracine-maison01 2.6.22-14-386 #1 Sun Oct 14 22:36:54 GMT 2007 i686 GNU/Linux

Pedro Villavicencio (pedro) wrote :

Thanks for your report, does it happens only with that jpg file? can you attach it to the report for testing purposes? thanks!.

Changed in eog:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

Does that happen only in directories with several other jpg? That might be due to eog doing thumbnailing for the collection

I did the test with only two pictures and it is the same. Irfanview is still blazing fast.

I'll attach the two pictures.

Second picture

Pedro Villavicencio (pedro) wrote :

Thanks, I don't see where the bug is, eog load the images here in a really small amount of time, feel free to forward this upstream since you're getting the issue and can answer the question they are going to do. thanks.

Changed in eog:
status: Unknown → New
Pedro Villavicencio (pedro) wrote :

thanks you!.

Changed in eog:
status: Incomplete → Triaged
Endolith (endolith) wrote :

Eye of Gnome is just slow in general. It maxes out my CPU for several seconds when I open it, when I change images, and when I close it.

Changed in eog:
importance: Unknown → Medium
Changed in eog:
status: New → Invalid
Adam Niedling (krychek) wrote :

Gnome bug #500722 was marked as the duplicate of bug #495825. So I'm changing the upstream bug tracker's link.

EOG is still really slow for me in Oneiric. It takes ages for it to start and to view the next picture.

Changed in eog:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in eog:
importance: Unknown → Wishlist
status: Unknown → Confirmed
Jérôme (jerome-bouat) wrote :

It seems that eog doesn't cache the next or previous image.

Going to the next image is slower with eog than with gqview although I deactivated the "lisser l'image lors du zoom" option in eog (translation: "slick image while zooming").

Adam Niedling (krychek) wrote :

EOG should definitely preload the next picture in the queue!
This bug should really get some attention, it's horrible.

Adam Niedling (krychek) wrote :

Setting the correct upstream bug report to this one. The last one was about eog is slow to start, but this bug report is about preloading the next picture. (Btw eog doesn't start slowly for me anymore, I just checked with 11.10 with a slow CPU.)

Changed in eog:
importance: Wishlist → Unknown
status: Confirmed → Unknown
Adam Niedling (krychek) on 2012-03-13
summary: - eog is slow at loading JPG
+ eog does not preload the next/prev picture
summary: - eog does not preload the next/prev picture
+ eog does not preload the next/prev picture therefore it's slow
Changed in eog:
importance: Unknown → Medium
status: Unknown → Confirmed
Changed in eog:
importance: Medium → Wishlist
Adam Niedling (krychek) wrote :

The issue is still the same in Ubuntu 13.04.

Adam Niedling (krychek) on 2013-11-01
tags: added: saucy
shinyblue (shinyblue) wrote :

Still a problem in 16.04, and AFAICS in Zesty.

Changed in eog (Ubuntu):
assignee: Ubuntu Desktop Bugs (desktop-bugs) → nobody
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.