No Global menu for eog (Wily, Unity7)

Bug #1491699 reported by Khurshid Alam on 2015-09-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
eog (Ubuntu)
High
Lars Karlitski

Bug Description

It looks like there is no global for eog (3.16.3-1) in Wily (Screenshot: http://i.imgur.com/1uNr4CW.png) From the previous change-log it seems it has something to with "Update debian/patches/disable-appmenu-when-not-needed.patch to apply" which was introduced in eog 3.16.2-1. (http://bazaar.launchpad.net/~ubuntu-desktop/eog/ubuntu/revision/158).

My purpose of app-menu is to access preference (and then plugins) or toolbar menu so that I can add shotwell's "Edit Image" plugin into the toolbar (screenshot in Vivid: http://i.imgur.com/4tfsVuv.png). Without any sort preference in the menu that is not possible.

Edit: It seems "Show traditional titlebar under unity" patch does not exist under debian/patches anymore. Does this mean that it went upstream?

Related branches

Khurshid Alam (khurshid-alam) wrote :
tags: added: wily
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
Changed in eog (Ubuntu):
importance: Undecided → High
Iain Lane (laney) wrote :

hi, thanks for the report.

This feature was changed (mostly removed) upstream for 3.16, so we can't have it in Ubuntu any more.

You can go to the "Open With" menu from the toolbar to pick Shotwell - does that solve the same usecase?

Changed in eog (Ubuntu):
status: Confirmed → Won't Fix
Khurshid Alam (khurshid-alam) wrote :

@Iain

Ok. So traditional toolbar was removed. No way to add shotwell plugin in the toolbar. Fine.

But it should still show a menu under global menu. In Gnome-Shell it shows a vertical menu from which I can access preference and other app specific settings. But in Unity I couldn't because there is no global menu at all. Even if it is not patched to have horizontal menu, we should still a get vertical menu under Unity. But Its completely blank.

And it affects eog-plugins package as well. Without anyway to access preference, there is no way enable/disable any plugin.

Note: I can access preference in the menu from gnome-shell. Even without a patch that gnome-shell menu should be visible in Global menu bar like any other gnome-apps (with gtk-headerbar) which are not patched.

Khurshid Alam (khurshid-alam) wrote :

@Iain

I am still not sure why this bug was marked as "Won't Fix". How does people access eog-preference through GUI:

1. without Global (or local) menu,
2. without any sort of cog menu in the headerbar,
3. without any other menu ??

Explain.

Iain Lane (laney) wrote :

You asked for a way to open "Edit Images" and I told you a way to do that.

However there should be a way to access preferences, so this issue is probably worthwhile for that anyway.

Changed in eog (Ubuntu):
status: Won't Fix → Triaged
assignee: nobody → Lars Uebernickel (larsu)
Iain Lane (laney) wrote :

Lars fixed this in the attached MP and I asked for a user interface freeze exception

  http://article.gmane.org/gmane.linux.ubuntu.doc/19062

Once that's granted we can get this into wily.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 3.16.3-1ubuntu2

---------------
eog (3.16.3-1ubuntu2) wily; urgency=medium

  [ Iain Lane ]
  * Make the toolbar hide in fullscreen.
  * Add the new xml file to POTFILES.in so that it can be translated.

  [ Lars Uebernickel ]
  * Add debian/patches/0001-Add-a-traditional-menu-bar.patch (LP: #1491699)
  * Update debian/patches/0002-Show-traditional-title-bar-in-unity.patch:
    update to make work with menubar patch and use GActionGroup's signals
  * Add debian/patches/Put-Exit-Fullscreen-button-into-toolbar.patch
    (GNOME #755799)

 -- Lars Uebernickel <email address hidden> Wed, 30 Sep 2015 16:24:49 +0100

Changed in eog (Ubuntu):
status: Triaged → Fix Released
Khurshid Alam (khurshid-alam) wrote :

Thanks. Now it works as expected.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers