mouse pointer converted into half thumbnail

Bug #1379499 reported by Fabio Marconi on 2014-10-09
60
This bug affects 14 people
Affects Status Importance Assigned to Milestone
Unity
Won't Fix
High
Unassigned
eog (Ubuntu)
High
Unassigned

Bug Description

Hallo
TESTCASE:
open an image with image viewer or gimp, left click to drag, release and the bug appear
Actually I cannot find a way to make it return to the original state except restart.
Interesting to note that if I record with the screencaster the bug is not showed in the movie even if it was existing during the record.
See attached movies.
Best regards

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: unity 7.3.1+14.10.20140915-0ubuntu2
ProcVersionSignature: Ubuntu 3.16.0-21.28-generic 3.16.4
Uname: Linux 3.16.0-21-generic x86_64
.tmp.unity.support.test.0:

ApportVersion: 2.14.7-0ubuntu5
Architecture: amd64
BootLog:
 * Starting userspace bootsplash utility[ OK ]
 Loading the saved-state of the serial devices...
 /dev/ttyS0 at 0x03f8 (irq = 4) is a 16550A
  * Setting up X socket directories... 
[ OK ]
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
CompositorRunning: compiz
CompositorUnredirectDriverBlacklist: '(nouveau|Intel).*Mesa 8.0'
CompositorUnredirectFSW: true
CurrentDesktop: Unity
Date: Thu Oct 9 21:55:46 2014
DistUpgraded: Fresh install
DistroCodename: utopic
DistroVariant: ubuntu
EcryptfsInUse: Yes
GraphicsCard:
 Intel Corporation Core Processor Integrated Graphics Controller [8086:0042] (rev 12) (prog-if 00 [VGA controller])
   Subsystem: Gigabyte Technology Co., Ltd Device [1458:d000]
MachineType: Gigabyte Technology Co., Ltd. H55M-S2H
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.16.0-21-generic root=UUID=cc32d8a8-ff79-4de8-a08c-5900afa16b6c ro splash quiet nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw nomdmonddf nomdmonisw vt.handoff=7
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 08/20/2010
dmi.bios.vendor: Award Software International, Inc.
dmi.bios.version: F7
dmi.board.name: H55M-S2H
dmi.board.vendor: Gigabyte Technology Co., Ltd.
dmi.board.version: x.x
dmi.chassis.type: 3
dmi.chassis.vendor: Gigabyte Technology Co., Ltd.
dmi.modalias: dmi:bvnAwardSoftwareInternational,Inc.:bvrF7:bd08/20/2010:svnGigabyteTechnologyCo.,Ltd.:pnH55M-S2H:pvr:rvnGigabyteTechnologyCo.,Ltd.:rnH55M-S2H:rvrx.x:cvnGigabyteTechnologyCo.,Ltd.:ct3:cvr:
dmi.product.name: H55M-S2H
dmi.sys.vendor: Gigabyte Technology Co., Ltd.
version.compiz: compiz 1:0.9.12+14.10.20140918-0ubuntu1
version.ia32-libs: ia32-libs N/A
version.libdrm2: libdrm2 2.4.56-1
version.libgl1-mesa-dri: libgl1-mesa-dri 10.3.0-0ubuntu3
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 10.3.0-0ubuntu3
version.xserver-xorg-core: xserver-xorg-core 2:1.16.0-1ubuntu1
version.xserver-xorg-input-evdev: xserver-xorg-input-evdev 1:2.9.0-1ubuntu2
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:7.4.0-2ubuntu2
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.99.914-1~exp1ubuntu4
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:1.0.11-1ubuntu2
xserver.bootTime: Thu Oct 9 21:50:10 2014
xserver.configfile: default
xserver.devices:
 input Power Button KEYBOARD, id 6
 input Power Button KEYBOARD, id 7
 input USB Keyboard KEYBOARD, id 8
 input USB Keyboard KEYBOARD, id 9
 input PIXART USB OPTICAL MOUSE MOUSE, id 10
xserver.errors:

xserver.logfile: /var/log/Xorg.0.log
xserver.outputs:
 product id 19222
 vendor HSD
xserver.version: 2:1.16.0-1ubuntu1

Fabio Marconi (fabiomarconi) wrote :
Changed in unity (Ubuntu):
importance: Medium → High
Fabio Marconi (fabiomarconi) wrote :

video recorded with camera

Fabio Marconi (fabiomarconi) wrote :

same as before made with screencaster kazam

description: updated
Changed in unity:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Rômulo (tlromulo-o) wrote :

I have the exactly same problem with Xubuntu (64) and Lubuntu (32).

Changed in unity (Ubuntu):
milestone: ubuntu-14.10 → ubuntu-15.04
tags: added: vivid
Changed in unity:
status: New → Confirmed
Fabio Marconi (fabiomarconi) wrote :

@ Rômulo
Are you having this problems with intel based graphic cards ?
Best regards

Fabio Marconi (fabiomarconi) wrote :

@ Marco Trevisan
have you already figured out what can it be ?
as per comment at #5 seems something lower..xserver mesa?
Best regards

no longer affects: unity (Ubuntu)
Changed in unity:
status: Confirmed → Won't Fix
Changed in eog (Ubuntu):
status: New → Confirmed
importance: Undecided → High

Visual example of glitch is attached to my post. It happens every time when I open Image Viewer for the fist time in each working session, e.g. I need just to log out/in to reproduce this bug.

bapoumba (bapoumba) wrote :

Same here, lubuntu 14.10.
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)

Happens mostly click and dragging images by accident on web pages (Firefox).

Leon R. Wood (leon-r-wood) wrote :

I go around this problem by installing another image viewer.

You guys could try.

To post a comment you must log in.