Eog doesn't have permission to save on a samba share

Bug #1322974 reported by .cobnet on 2014-05-25
This bug affects 1 person
Affects Status Importance Assigned to Milestone
eog (Ubuntu)

Bug Description

Steps to reproduce the bug:
-) I've mounted a samba share with Nautilus. I needed to provide login and password to be able to access it.
-) I could access it with eog (Eye of Gnome) to view pictures.
-) But I needed to rotate an image and when I tried to save it, I got an error:

Could not save image 'filename'.
You do not have the permissions necessary to save the file.

This is strange, because I can rename filenames, copy new files, delete files,... from within Nautilus.

Workaround: open the same image with Gimp, rotate and overwrite 'filename' and this works. That's why I believe the bug is in eog.

Extra information:
-) the samba share comes from an OpenMediaVault system, which uses "2:3.5.6~dfsg-3squeeze11" as samba server.
-) my 14.04 system is up-to-date.
-) I also tried it on an Ubuntu 13.10, but I had the same problem :-(.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: eog 3.10.2-0ubuntu5
ProcVersionSignature: Ubuntu 3.13.0-24.47-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3.2
Architecture: amd64
CurrentDesktop: Unity
Date: Sun May 25 11:41:32 2014
ExecutablePath: /usr/bin/eog
InstallationDate: Installed on 2014-04-21 (33 days ago)
InstallationMedia: It
 PATH=(custom, no user)
SourcePackage: eog
UpgradeStatus: No upgrade log present (probably fresh install)

.cobnet (mattias-campe) wrote :
.cobnet (mattias-campe) wrote :

Another workaround: rotate with "Shotwell Viewer" also works.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers