Can't open .webp files

Bug #1318327 reported by Guillermo Lo Coco
100
This bug affects 21 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Confirmed
Wishlist
eog (Ubuntu)
Fix Released
Wishlist
Unassigned

Bug Description

Please, add webp support.

Changed in eog (Ubuntu):
status: New → Triaged
importance: Undecided → Wishlist
Changed in eog:
importance: Unknown → Wishlist
status: Unknown → New
Revision history for this message
Misaki (myjunkmail311006) wrote :

The bug for libwebp seems to be Bug #1407644. Should one of these bugs be marked as a duplicate and the other project added to the list of affected projects?

I notice that ffmpeg (possibly with the right compile options) can open .webp files, and ffmpeg uses the GNU General Public License version 2+ though that particular decoder might not.

eog also seems to use the GNU General Public License version 2+.

The other bug report says that using a gdk-pixbuf loader is the right way to extend support, but in the meantime, could eog just use code from ffmpeg, or even ffmpeg directly? (Imagemagick, for example, uses ffmpeg to open video files.) It seems that having a poor solution may be better than having no solution, if there is currently no motivation to implement the 'correct' solution.

Changed in eog:
status: New → Confirmed
Revision history for this message
Christian Reis (kiko) wrote :

See also bug 1864215 (Please add webp loader to gdk-pixbuf)

Revision history for this message
Ciro Santilli 六四事件 法轮功 (cirosantilli) wrote :
Revision history for this message
dinamic (dinamic6661) wrote :

WEBP is everywhere in 2021. please add support for WEBP

Revision history for this message
Marcos Alano (mhalano) wrote :

There is available code to fix that. Someone could package so we can get it working in Jammy? I think it's quite important since it's a 5-years long release.
Here is the code:
https://github.com/aruiz/webp-pixbuf-loader

Jeremy Bicha (jbicha)
Changed in eog (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package eog - 43~beta-1ubuntu2

---------------
eog (43~beta-1ubuntu2) kinetic; urgency=medium

  * Revert changes temporarily disabling webp support (LP: #1318327)
    (LP: #1979121)

 -- Jeremy Bicha <email address hidden> Mon, 22 Aug 2022 10:03:25 -0400

Changed in eog (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.