Picture displayed with noise in EOG

Bug #1247800 reported by Julien Olivier on 2013-11-04
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
eog (Ubuntu)

Bug Description

In the attached screenshot, you can clearly see artifacts in a PNG opened in both EOG and GIMP. The picture in EOG seems to have a lot of noise, but not in GIMP.

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: eog 3.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-13.20-generic 3.11.6
Uname: Linux 3.11.0-13-generic i686
ApportVersion: 2.12.5-0ubuntu2.1
Architecture: i386
Date: Mon Nov 4 12:24:10 2013
InstallationDate: Installed on 2010-09-15 (1145 days ago)
InstallationMedia: Ubuntu 10.04.1 LTS "Lucid Lynx" - Release i386 (20100816.1)
MarkForUpload: True
SourcePackage: eog
UpgradeStatus: Upgraded to saucy on 2011-04-01 (948 days ago)

Julien Olivier (julo) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. Could you add a file example to the bug?

Changed in eog (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Julien Olivier (julo) wrote :

The original picture is here: http://julien.olivier.free.fr/Scans-1.png .

The picture is very large, so the issue may be in the scaling method used by EOG vs the one used in GIMP. More over, if I open it right into Firefox, I notice that, while the picture is loading, it displays the same nois all over it. But, when finally loaded, it's clean again.

Sebastien Bacher (seb128) wrote :

The issue seems an upstream on and should be reported on https://bugzilla.gnome.org/enter_bug.cgi?product=eog

Changed in eog (Ubuntu):
status: Incomplete → New
Changed in eog (Ubuntu):
status: New → Triaged
Changed in eog:
importance: Unknown → Medium
status: Unknown → Invalid
Changed in eog:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in eog:
importance: Unknown → Medium
status: Unknown → New
florin (florin-arjocu) wrote :

Years later, the bug is still there and EOG buggy (crashes, huge memory leaker, etc.). Maybe there is some better choise instead of eog?

Changed in eog:
status: New → Confirmed
Changed in eog:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

the corresponding commit is https://git.gnome.org/browse/eog/commit/?id=fbc11280c6929852100de40e2dc70f5ec2adcea7 which looks like a good candidate to backport for the lts

Changed in eog (Ubuntu):
status: Triaged → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.