eog crashed with SIGSEGV in toolbar_content_remove ()

Bug #1208405 reported by Antonio Carlos Santos Galvão on 2013-08-05
34
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Expired
Medium
eog (Ubuntu)
Medium
Unassigned

Bug Description

Ao tentar editar a barra de ferramentas do aplicativo, ele trava e fecha repentinamente.

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: eog 3.8.2-1ubuntu1
ProcVersionSignature: Ubuntu 3.10.0-6.17-generic 3.10.3
Uname: Linux 3.10.0-6-generic x86_64
ApportVersion: 2.12-0ubuntu2
Architecture: amd64
Date: Mon Aug 5 06:40:45 2013
ExecutablePath: /usr/bin/eog
MarkForUpload: True
ProcCmdline: eog /home/username/Imagens/Dodge.jpg
SegvAnalysis:
 Segfault happened at: 0x7fc347e59499 <g_type_check_instance+25>: mov (%rax),%rdi
 PC (0x7fc347e59499) ok
 source "(%rax)" (0xaaaaaaaaaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: eog
StacktraceTop:
 g_type_check_instance () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_handlers_disconnect_matched () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgtk-3.so.0
Title: eog crashed with SIGSEGV in g_type_check_instance()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

StacktraceTop:
 g_type_check_instance (type_instance=type_instance@entry=0x2bb5dc0) at /build/buildd/glib2.0-2.37.3/./gobject/gtype.c:4082
 g_signal_handlers_disconnect_matched (instance=0x2bb5dc0, mask=mask@entry=(G_SIGNAL_MATCH_FUNC | G_SIGNAL_MATCH_DATA), signal_id=signal_id@entry=0, detail=detail@entry=0, closure=closure@entry=0x0, func=func@entry=0x7fc349806c20 <toolbar_item_visiblity_notify_cb>, data=data@entry=0x2b29b50) at /build/buildd/glib2.0-2.37.3/./gobject/gsignal.c:2874
 toolbar_content_remove (content=content@entry=0x2c7e540, toolbar=toolbar@entry=0x2b29b50) at /build/buildd/gtk+3.0-3.8.2/./gtk/gtktoolbar.c:3315
 gtk_toolbar_stop_sliding (toolbar=toolbar@entry=0x2b29b50) at /build/buildd/gtk+3.0-3.8.2/./gtk/gtktoolbar.c:1389
 toolbar_content_new_tool_item (toolbar=0x2b29b50, item=item@entry=0x2b5ddd0, is_placeholder=is_placeholder@entry=0, pos=1) at /build/buildd/gtk+3.0-3.8.2/./gtk/gtktoolbar.c:3297

Changed in eog (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace

the edit toolbar (adding print icon) crashed and closed unexpectedly.

Ao tentar editar a barra de ferramentas, o aplicativo trava e fecha repentinamente.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
summary: - eog crashed with SIGSEGV in g_type_check_instance()
+ eog crashed with SIGSEGV in toolbar_content_remove ()
information type: Private → Public
Changed in eog (Ubuntu):
status: Confirmed → Triaged
status: Triaged → Confirmed
Changed in eog (Ubuntu):
status: Confirmed → Triaged
Changed in eog:
importance: Unknown → Medium
status: Unknown → New
Changed in eog:
status: New → Expired

Antonio Carlos, please write in english you report.

Many thanks,
..
Cristian

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu Package testing tracker.

A list of all reports related to this bug can be found here:
http://packages.qa.ubuntu.com/qatracker/reports/bugs/1208405

tags: added: package-qa-testing
Sebastien Bacher (seb128) wrote :

the issue is fixed in > 3.16 versions

Changed in eog (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.