EOG-CRITICAL **: eog_list_store_length: assertion `EOG_IS_LIST_STORE (store)' failed

Bug #1114012 reported by Deepak on 2013-02-03
40
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Eye of GNOME
Fix Released
Critical
eog (Ubuntu)
Undecided
Unassigned

Bug Description

when I run image viewer(eog) from commandline it gives me following error when closing it....
EOG-CRITICAL **: eog_list_store_length: assertion `EOG_IS_LIST_STORE (store)' failed

It reproduces every time I run it, independent of image file.
either run as: gnome-open ref_scene7.png
or $ eog ref_scene7.png

Deepak (deepakiitr2015) on 2013-02-03
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in eog (Ubuntu):
status: New → Confirmed
Øyvind Stegard (oyvinst) wrote :

Upstream patch from eog master applies to 3.6.2 source [with some small hunk offsets] and works fine.

Changed in eog:
importance: Unknown → Critical
status: Unknown → Fix Released
Mörgæs (moergaes) wrote :

Fixed upstream.
If a similar bug appears in 16.04 (development) please open a new bug report.

Changed in eog (Ubuntu):
status: Confirmed → Fix Released
Marcus Hoyer (marcushoyer) wrote :

   This is my first week using Linux (Ubuntu 18.04 LTS) and Python 2.7 and am already bumping into a problem similar to that reported. In my case I open JPG files of variable size, but in this case they are no more than 3Mb.
    I also create 3 processes to split the execution on a list that can get very large when the project is finished, I do not believe this is the problem, because the software runs fine on Windows 7 and Windows 10 and even with the error message the images are presented.

   The following is part of the code:

Error in Python 2.7 executing by IDE PyCharm.

############## CODE ##########################

import webbrowser

shutil.move(src, dst)
webbrowser.open(dst)

(eog:4466): EOG-CRITICAL **: 06:49:00.874: eog_list_store_get_pos_by_image: assertion 'EOG_IS_IMAGE (image)' failed

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.