envynggtk.py crashed with ImportError in <module>()

Bug #262156 reported by computerkranker on 2008-08-28
570
This bug affects 2 people
Affects Status Importance Assigned to Milestone
envyng-gtk (Ubuntu)
Critical
Alberto Milone

Bug Description

Binary package hint: envyng-gtk

Crash by start envyng-gtk

ProblemType: Crash
Architecture: i386
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/share/envyng-gtk/envynggtk.py
InterpreterPath: /usr/bin/python2.5
Package: envyng-gtk 1.1.1ubuntu1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: python /usr/share/envyng-gtk/envynggtk.py computerkranker /home/computerkranker 1000 -g
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/envyng-gtk/envynggtk.py', 'computerkranker', '/home/computerkranker', '1000', '-g']
SourcePackage: envyng-gtk
Title: envynggtk.py crashed with ImportError in <module>()
Traceback:
 Traceback (most recent call last):
   File "/usr/share/envyng-gtk/envynggtk.py", line 7, in <module>
     from Envy import objects
 ImportError: cannot import name objects
Uname: Linux 2.6.27-1-generic i686
UserGroups:

Changed in envyng-gtk:
assignee: nobody → albertomilone
importance: Undecided → Low
status: New → In Progress

Alberto: What is the status on this? Should envyng be removed for Intrepid or are you almost ready to upload a fix?

Changed in envyng-gtk:
importance: Low → Critical
milestone: none → ubuntu-8.10
CplusGod (cicyoass) wrote :

Crash here as well. I'm thinking EnvyNG should just be removed from Intrepid for the time being, because you can either install drivers manually, or use the System->Administration->Hardware Drivers thing.

machak (machak) wrote :

same error with last beta

Siegfried Gevatter (rainct) wrote :

Seems like Alberto did lots of changes to the backend but didn't update the GTK user interface, and looking at https://code.edge.launchpad.net/~albertomilone/envy/envyng-gtk it doesn't seem like he plans to do that for Intrepid...

As a workaround, downgrading envyng-core 2.0 to 1.1.1ubuntu17 (from hardy-updates) or 1.1.1ubuntu11 (from hardy) should fix this.

Alberto Milone (albertomilone) wrote :

Cody,Siegfried: the problem will be solved as soon as this FFE is approved:
https://bugs.launchpad.net/ubuntu/+source/envyng-core/+bug/277126

same bug for me on ubuntu 8.10 x86_64

Siegfried Gevatter (rainct) wrote :

Well, I don't really consider removing the GTK frontend a solution... :(

not my suggestion. ??

On Wed, Oct 8, 2008 at 2:47 PM, Siegfried Gevatter (RainCT) <
<email address hidden>> wrote:

> Well, I don't really consider removing the GTK frontend a solution... :(
>
> --
> envynggtk.py crashed with ImportError in <module>()
> https://bugs.launchpad.net/bugs/262156
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Siegfried Gevatter (rainct) wrote :

But that's Alberto Milone's fix.

(Just to clarify, my last comment was more of a "aww what a pitty" as a "get it working!" ;). I assume that it you've decided to don't include the GTK frontend into Intrepid that's because it isn't feasible to get the GTK version ready -and tested well enough- in time.)

Alberto Milone (albertomilone) wrote :

Siegfried: right, that's the reason.

Changed in envyng-gtk:
status: In Progress → Fix Released
DasEi (mschulz45) wrote :

I think the problem is the xorg 7.4 that doesn't allow the graphics
driver to install,
as it manually works in 7.3 as with envyng.

2008/10/9, Alberto Milone <email address hidden>:
> Siegfried: right, that's the reason.
>
> ** Changed in: envyng-gtk (Ubuntu)
> Status: In Progress => Fix Released
>
> --
> envynggtk.py crashed with ImportError in <module>()
> https://bugs.launchpad.net/bugs/262156
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>
> Status in "envyng-gtk" source package in Ubuntu: Fix Released
>
> Bug description:
> Binary package hint: envyng-gtk
>
> Crash by start envyng-gtk
>
> ProblemType: Crash
> Architecture: i386
> DistroRelease: Ubuntu 8.10
> ExecutablePath: /usr/share/envyng-gtk/envynggtk.py
> InterpreterPath: /usr/bin/python2.5
> Package: envyng-gtk 1.1.1ubuntu1
> PackageArchitecture: all
> ProcAttrCurrent: unconfined
> ProcCmdline: python /usr/share/envyng-gtk/envynggtk.py computerkranker
> /home/computerkranker 1000 -g
> ProcEnviron:
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/X11R6/bin
> LANG=de_DE.UTF-8
> SHELL=/bin/bash
> PythonArgs: ['/usr/share/envyng-gtk/envynggtk.py', 'computerkranker',
> '/home/computerkranker', '1000', '-g']
> SourcePackage: envyng-gtk
> Title: envynggtk.py crashed with ImportError in <module>()
> Traceback:
> Traceback (most recent call last):
> File "/usr/share/envyng-gtk/envynggtk.py", line 7, in <module>
> from Envy import objects
> ImportError: cannot import name objects
> Uname: Linux 2.6.27-1-generic i686
> UserGroups:
>

To post a comment you must log in.