EnvyNG needs to be updated to work with current karmic python-apt (0.7.10.4ubuntu1)

Bug #396301 reported by Zorael on 2009-07-06
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
envyng-core (Ubuntu)
High
Alberto Milone

Bug Description

Binary package hint: envyng-core

EnvyNG spouts a python traceback upon starting it and promptly ends. This is on a fresh Kubuntu Karmic x64 installation, with envy-core and python packages from the main repository.

As follows;
            Traceback (most recent call last):
              File "interface.py", line 428, in <module>
                a = Interface()
              File "interface.py", line 126, in __init__
                self.abstract = abstraction.Abstraction(progress, True)
              File "/usr/lib/python2.6/dist-packages/Envy/abstraction.py", line 54, in __init__
                installed, candidate = self.pkg.getPkgInfo(drv)
              File "/usr/lib/python2.6/dist-packages/Envy/packagemanager.py", line 173, in getPkgInfo
                pkg = apt.package.Package(self.cache, self.depcache, self.records, self.sourcelist, None, pkgiter)
            TypeError: __init__() takes exactly 3 arguments (7 given)

From #ubuntu+1 on freenode;
            [01:27] <kklimonda> Zorael^2: it can't work with python-apt and envy-core from KK - I've just checked sources
            [01:28] <kklimonda> Zorael^2: python-apt 0.7.10 has broken an API
            [01:29] <kklimonda> Zorael^2: and envy-core (at least the version from KK) wasn't ported yet

Package versions:
            envyng-core:
              Installed: 2.0.1ubuntu1
              Candidate: 2.0.1ubuntu1
              Version table:
             *** 2.0.1ubuntu1 0
                    500 http://archive.ubuntu.com karmic/universe Packages
                    100 /var/lib/dpkg/status
            python-apt:
              Installed: 0.7.10.4ubuntu1
              Candidate: 0.7.10.4ubuntu1
              Version table:
             *** 0.7.10.4ubuntu1 0
                    500 http://archive.ubuntu.com karmic/main Packages
                    100 /var/lib/dpkg/status

Related branches

cubells (cubells) wrote :

I can confirm this bug in ubuntu karmic i386 version too.

cubells (cubells) wrote :

By doing a downgrade of python-apt package (from 7.10 to 7.09) envyng works like a charm.

Changed in envyng-core (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
status: New → Confirmed
Changed in envyng-core (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package envyng-core - 2.0.1ubuntu2

---------------
envyng-core (2.0.1ubuntu2) karmic; urgency=low

  * Envy/packagemanager.py
    - Adapt file to the changes in python-apt (LP: #396301).
      Credit goes to Michael Vogt (mvo).
    - Ignore deprecation warnings.
  * debian/rules:
    - Use DH_PYCENTRAL=include-links instead of nomove.
    - Remove makefile.mk.
  * debian/control:
    - Add build dependency on python-distutils-extra (>= 2.4).
  * setup.py:
    - Switch to the DistUtilsExtra module.

 -- Alberto Milone <email address hidden> Fri, 21 Aug 2009 14:25:32 +0200

Changed in envyng-core (Ubuntu):
status: In Progress → Fix Released
ibito (ibitox) on 2010-10-13
Changed in envyng-core (Ubuntu):
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers