Plugins not loading

Bug #1716656 reported by Daniel on 2017-09-12
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
entangle (Ubuntu)
Undecided
Unassigned

Bug Description

Ubuntu: desktop 17.04
Entangle version: v0.7.1
libgphoto2 version: v2.5.12
Camera model: Canon EOS SL1 FW v101
Description of problem:
I am having trouble loading plugin's. On a fresh install I can not see plugin's in the preferences menu. I can see that they are located in '/usr/share/entangle/plugins/'. If i copy the plugin's to '/home/daniel/.config/entangle/plugins/' I can see them in the preferences menu. But checking the box dose not allow there use.

Install method is 'sudo apt-get install entangle'

tags: added: zesty
dino99 (9d9) wrote :
Changed in entangle (Ubuntu):
status: New → Invalid
Hauke Wintjen (hwintjen) wrote :

Still the same problem on 19.10. So issue is not "Invalid"....

Changed in entangle (Ubuntu):
status: Invalid → Confirmed
Daniel Berrange (berrange) wrote :

Looking at the file list for the entangle package:

   https://packages.ubuntu.com/eoan/amd64/entangle/filelist

We can see that the plugin code simply isn't included at all.

Only the gschema files in /usr/share have been installed

The code and registration metadata from /usr/lib(64) are missing.

A proper install for a plugin install would have 4 files:

/usr/lib64/entangle/plugins/shooter/shooter.plugin
/usr/lib64/entangle/plugins/shooter/shooter.py
/usr/share/entangle/plugins/shooter/schemas/gschemas.compiled
/usr/share/entangle/plugins/shooter/schemas/org.entangle-photo.plugins.shooter.gschema.xml

NB, /usr/lib64 might be elsewhere on Ubuntu

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers