Enigmail doesn't start with swedish locales

Bug #886781 reported by balp on 2011-11-06
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Enigmail
Invalid
High
enigmail (Ubuntu)
High
Unassigned

Bug Description

When runing enigmail in thunderbird with swedish locales LANG=sv_SE.utf8 the extenitons doesn't do anything, trying to get into the preferences, gives the following error, yes sorry the message is partly in swedish:

XML-tolkningsfel: odefinierad entitet
Adress: chrome://enigmail/content/pref-enigmail.xul
Radnummer 111, Kolumn 20: <description>&enigmail.keepCryptoSettingsForReply.tooltip;</description>
-------------------^

A quick search on the internet gives that this probably is the same error as seen here:

http://www.mozilla-enigmail.org/forum/viewtopic.php?f=6&t=203

Using english locales for thunderbird and the package works as one expects.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: enigmail 2:1.3.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu4
Architecture: amd64
Date: Sun Nov 6 11:27:26 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANG=sv_SE.utf8
SourcePackage: enigmail
UpgradeStatus: Upgraded to oneiric on 2011-10-17 (20 days ago)

balp (anders-arnholm) wrote :
Timo Aaltonen (tjaalton) wrote :

Confirmed the same with fi_FI, enigmail doesn't work at all on oneiric.

Changed in enigmail (Ubuntu):
importance: Undecided → High
status: New → Confirmed
Jef Mathiot (jeff-mathiot) wrote :

Same with fr_FR.UTF-8

Willi Mann (willi) wrote :
Willi Mann (willi) wrote :

I'll fix the bug in Debian with attached patch. Note that, at least in the current Debian version, this patch reintroduces the problem that the clean target does not reverse all changes to the source directory (which means that enigmail cannot be built twice in a row)

The attachment "Fix that will be applied in Debian" of this bug report has been identified as being a patch in the form of a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Changed in enigmail:
importance: Unknown → High
status: Unknown → Invalid
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enigmail - 2:1.3.5-0ubuntu2

---------------
enigmail (2:1.3.5-0ubuntu2) precise; urgency=low

  * Fix LP: #886781 - build with --enable-chrome-format=omni, as this is
    what the chrome.manifest assumes (fixes chrome registration issues
    breaking non-English locales)
    - update debian/rules
 -- Chris Coulson <email address hidden> Mon, 30 Jan 2012 18:59:44 +0000

Changed in enigmail (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.