No signature detected in emails signed using pgp/mime

Bug #565014 reported by Muharem Hrnjadovic on 2010-04-16
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Enigmail
Fix Released
Unknown
enigmail (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: enigmail

When receiving a signed email with the signature in an attachment (signed using pgp/mime) enigmail would not even recognize that the email *is* signed in first place.

Signed emails with the

{{{
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.10 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/

-----END PGP SIGNATURE-----
}}}

block in-line (i.e. as a part of the message body) are properly recognized as signed and the signature is verified.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: enigmail 2:1.0.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic x86_64
Architecture: amd64
Date: Fri Apr 16 22:42:58 2010
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100114)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: enigmail

Related branches

Muharem Hrnjadovic (al-maisan) wrote :
Anil Somayaji (asomayaji) wrote :

I also see this bug, but I think enigmail is actually noticing the message is signed - if I disable automatic message verification/decryption, I get a message "Possibly PGP/MIME encrypted or signed message; click Decrypt button to verify". Of course, there is no "decrypt" button visible to click.

I also have display mail user agent installed, so I thought it might be an interaction with that; disabling that extension doesn't seem to affect that bug.

This is for Ubuntu 10.04 (Lucid) on amd64.

  --Anil

Alex Bachmeier (cebalrai) wrote :

I can confirm this bug on Lucid amd64.
I also have the "mail user agent extension" installed.

Erik Hetzner (egh) wrote :

I seem to have the same bug with enigmail on lucid., x86_64. If I install enigmail from http://enigmail.mozdev.org/download/index.php, it works properly.

Tobias Beck (vitrex) wrote :

Workaround #4 worked for me.

- Uninstall enigmail package
- Download xpi
- Install it over Addons in Thunderbird

Pete Stephenson (heypete) wrote :

Also confirmed on 64-bit Lucid.

PGP/MIME signatures work fine with encrypted+signed messages, but are not detected on signed-only messages.

Alexander Sack (asac) wrote :

do you get any errors in the tools -> error console when opening such a message? (or in general?)

Torsten Werner (twerner) wrote :
Download full text (3.3 KiB)

log file:

2010-06-16 21:11:14.992 enigmail.js: Logging debug output to /tmp/enigdbug.txt
2010-06-16 21:11:14.992 enigmail.js: Enigmail version 1.0.1
2010-06-16 21:11:14.992 enigmail.js: OS/CPU=Linux x86_64
2010-06-16 21:11:14.992 enigmail.js: Platform=X11
2010-06-16 21:11:14.992 enigmail.js: composeSecure=true
2010-06-16 21:11:14.993 enigmail.js: Enigmail.initialize: gEnvList = DISPLAY=:0.0,HOME=/home/twerner,LANG=de_DE.UTF-8,LOGNAME=twerner,LD_LIBRARY_PATH=/usr/lib/icedove:/usr/lib/icedove/plugins:/usr/lib/icedove,MOZILLA_FIVE_HOME=/usr/lib/icedove,PATH=/usr/local/bin:/usr/bin:/bin:/usr/games,PWD=/home/twerner,SHELL=/bin/bash,USER=twerner
2010-06-16 21:11:14.993 enigmail.js: ResolvePath: filePath=gpg
2010-06-16 21:11:14.993 EnigmailAgentPath=/usr/bin/gpg

2010-06-16 21:11:15.009 enigmail> /usr/bin/gpg --version --version --batch --no-tty --charset utf8
2010-06-16 21:11:15.009 gpg (GnuPG) 1.4.10
Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

Home: ~/.gnupg
Unterstützte Verfahren:
Öff. Schlüssel: RSA, RSA-E, RSA-S, ELG-E, DSA
Verschlü.: 3DES, CAST5, BLOWFISH, AES, AES192, AES256, TWOFISH, CAMELLIA128,
            CAMELLIA192, CAMELLIA256
Hash: MD5, SHA1, RIPEMD160, SHA256, SHA384, SHA512, SHA224
Komprimierung: nicht komprimiert, ZIP, ZLIB, BZIP2

2010-06-16 21:11:15.009 enigmail.js: detected GnuPG version '1.4.10'
2010-06-16 21:11:15.009 enigmail.js: detectGpgAgent
2010-06-16 21:11:15.009 enigmail.js: detectGpgAgent: no GPG_AGENT_INFO variable set
2010-06-16 21:11:15.009 enigmail.js: detectGpgAgent - gpg 1.x found
2010-06-16 21:11:15.009 enigmail.js: detectGpgAgent: GPG_AGENT_INFO=''
2010-06-16 21:11:15.010 enigmail.js: Enigmail.stillActive:
2010-06-16 21:11:15.010 enigmail.js: Enigmail.initialize: END
2010-06-16 21:11:15.010 enigmailMessengerOverlay.js: enigMessageDecryptCb:
2010-06-16 21:11:15.010 enigmailMessengerOverlay.js: content-type: multipart/signed; micalg="pgp-sha1"; protocol="application/pgp-signature"; boundary="=-vNdlhUF6f6mVHdJAeW0l"
2010-06-16 21:11:15.010 enigmailMessengerOverlay.js: content-transfer-encoding:
2010-06-16 21:11:15.010 enigmailMessengerOverlay.js: x-enigmail-version:
2010-06-16 21:11:15.011 enigmailMessengerOverlay.js: multipart/signed
2010-06-16 21:11:16.115 enigmailMessengerOverlay.js: enigUpdateOptionsDisplay:
2010-06-16 21:11:16.116 enigmailCommon.js: EnigCollapseAdvanced: test
2010-06-16 21:11:17.295 enigmailMessengerOverlay.js: enigUpdateOptionsDisplay:
2010-06-16 21:11:17.295 enigmailCommon.js: EnigCollapseAdvanced: test
2010-06-16 21:11:18.605 enigmailCommon.js: EnigViewConsole
2010-06-16 21:11:18.717 enigmailConsole.js: enigRefreshConsole(): hasNewData
2010-06-16 21:11:18.717 enigmailCommon.js: EnigGetFrame: name=contentFrame
2010-06-16 21:11:22.894 enigmailConsole.js: enigConsoleUnload
2010-06-16 21:11:23.795 enigmailMessengerOverlay.js: enigUpdateOptionsDisplay:
2010-06-16 21:11:23.797 enigmailCommon.js: EnigCollapseAdvanced: test
2010-06-16 21:11:24.502 enigmailMessengerOverlay.js: enigUpd...

Read more...

akhalfan (akhalfan) wrote :

confirmed here as well

Dave L (westy3) wrote :

Further to #4, #5: enigmail 1.0.1 as installed via apt is broken, enigmail 1.0.1 downloaded from Mozilla is OK, so it's an Ubuntu problem. b.t.w no need to uninstall the Ubuntu version, just disable it in add-ons before installing the official Mozilla one.

Torsten Werner (twerner) wrote :

The bug has been fixed in Debian's version 2:1.0.1-5.

Changed in enigmail:
status: Unknown → Fix Released
Hagen (hagenf) wrote :

Is the fix going to be backported to Lucid?

Micah Gersten (micahg) wrote :

This will be fixed in Maverick when we update to Enigmail 1.1.2. This will also be backported to Lucid when we update to Thunderbird 3.1 later this year.

Changed in enigmail (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Launchpad Janitor (janitor) wrote :
Download full text (3.1 KiB)

This bug was fixed in the package enigmail - 2:1.1.2-0ubuntu1

---------------
enigmail (2:1.1.2-0ubuntu1) maverick; urgency=low

  * New upstream release

  * Merge from debian unstable. Remaining changes:
    - Drop versioned mozilla-devscripts dependency since we don't build on
      mips or mipsel
    - Add back thunderbird-dev build depends
      - update debian/control
    - fixes LP: #565014 - No signature detected in emails signed using pgp/mime

  * Update build-depends on thunderbird or icedove to >= 3.1~
    - update debian/control
  * Drop frozen_api patch as changes were accepted upstream
    - drop debian/patches/frozen_api.diff
    - update debian/patches/series
  * Use system NSPR in Ubuntu as well
    - update debian/rules
  * Build with -fshort-wchar for now to make the build succeed
    - update debian/rules

enigmail (2:1.0.1-5) unstable; urgency=low

  * Update frozen_api.diff to include nsEnigMimeListener.cpp and
    nsEnigMimeService.cpp versions matching current upstream CVS. This fixes
    PGP/MIME parsing. closes: #586577
  * Pass --disable-optimize to configure script if called with noopt in
    DEB_BUILD_OPTIONS.
  * Call the distclean target of all Makefiles that support it. This allows to
    significantly reduce the number of files in debian/clean. Still there are
    some generated python build scripts.

enigmail (2:1.0.1-4) unstable; urgency=low

  * Explicitly set target machine type according to dpkg-architecture
    (DEB_BUILD_GNU_TYPE) to allow building working versions of the i386
    package in i386 chroot with amd64 kernel.
  * Add -std=gnu++0x to CXXFLAGS in order to allow building with icedove
    3.0.5-1. closes: #586860, thanks to Christoph Goehre for this hint.

enigmail (2:1.0.1-3) unstable; urgency=low

  * Remove Build-Dependency on libiw-dev. This is not used, but configure now
    requires --disable-necko-wifi to be happy. Should allow build on kfreebsds.
  * Build-Depend on mozilla-devscripts >= 0.23 to really fix FTBFS on mipsel
    and mips. (m-d changed RDF implementation used to parse install.rdf)

enigmail (2:1.0.1-2) unstable; urgency=low

  * Patch makefile-in-empty-xpcom-fix.diff: Fix FTBFS on armel, mips,
    and mipsel.

enigmail (2:1.0.1-1) unstable; urgency=low

  * Upload based on Ubuntu package:
    - New upstream version closes: #569804, #461643, #553272
  * Fix RC Bugs:
    - enigmail < 1.0 not supported in icedove >= 3. closes: #569804, #562714
    - enigmail 0.95 no longer builds. closes: #576997
  * Use build flags --with-system-nspr --with-nspr-prefix=/usr if debian
    environment is detected (detection as proposed in bug #569804)
  * According to asac, buildds cannot cope with alternatives in
    Build-Depends. Thus drop thunderbird-dev alternative.
  * Some files are not removed at clean time. Added to debian/clean, so
    deleted by debhelper.
  * lintian:
    - fix description-starts-with-package-name
    - Fix 3 consecutive changelog entries: syntax-error-in-debian-changelog
      (wrong date format)
    - Add README.source for quilt: patch-system-but-no-source-readme
  * Add myself to Uploaders.
 -- Micah Gersten <email address hidden> Fri, 20 Aug 2010 11:45:10 -05...

Read more...

Changed in enigmail (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.