Enigmail breaks Firefox browser

Bug #34574 reported by Tero Karvinen on 2006-03-12
4
Affects Status Importance Assigned to Milestone
enigmail (Ubuntu)
Medium
Adam Conrad

Bug Description

After installing mozilla-thunderbird-enigmail, firefox crashes after 1-3 page loads. Removing mozilla-thunderbird-enigmail does not fix this.

To reproduce
1) sudo apt-get install mozilla-thunderbird-enigmail
2) (optional?): open thunderbird, open Enigmail:OpenGPG key management
3) Open firefox, www.google.com, enter some text "lksdf", press enter, follow a link in the results.

Firefox crashes, no explanation is given to user. If Firefox is run from command line, it says "Illegal instruction" when crashing.

I am using Ubuntu 5.10 Breezy, firefox 1.0.7-0ubuntu2, mozilla-thunderbird 1.0.7-0ubuntu0 and mozilla-thunderbird-enigmail 2:0.92-1ubuntu5. I have multiple extensions installed in both thunderbird mua and firefox browser.

Fixing the problem:
Inital tries to fix the issue failed:
$ sudo apt-get --purge remove mozilla-thunderbird-enigmail
then logging off and on does not fix the problem.
To make firefox work again, I had to
$ sudo apt-get remove --purge mozilla-firefox
$ sudo apt-get install mozilla-firefox ubuntu-desktop
I think the fix is counter-intuitive and takes a lot of time.

I guess the problem might be related to chrome registry. When removing and installing the programs I get many warnings like:
"Updating mozilla-thunderbird chrome registry...find: warning: you have
specified the -maxdepth option ..."
The find issue is reported in
https://launchpad.net/distros/ubuntu/+source/mozilla-thunderbird/+bug/26311
https://launchpad.net/distros/ubuntu/+source/enigmail/+bug/27167

Bypass: Install enigmail to each user without using apt.
1) Download http://www.mozilla-enigmail.org/downloads/enigmail-0.93.0-tb10-linux.xpi
(315248 B, md5: edb956e2f67f000e72097cd441c6a191)
2) In Thunderbird: Tools: Extensions: Install: enigmail-0.93.0-tb10-linux.xpi
3) Close all Thunderbird windows
4) Open Thunderbird. New menu "OpenPGP" has emerged. Enigmail works. Firefox is not broken now, thus the bug is bypassed.
Tested using 5.10 Breezy and mozilla-thunderbird 1.0.7-0ubuntu05.10.

Thus, it seems that bug is in Ubuntu deb package for enigmail.

Matt Zimmerman (mdz) on 2006-04-05
Changed in enigmail:
assignee: nobody → adconrad

Seems to be fixed in Dapper. At least on one machine, enigmail worked when installed with apt.

I have Enigmail installed trough apt in use on a couple of machines. Bug seems to be fixed in Dapper.

Changed in enigmail:
status: Unconfirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers