Enigmail not asking for password when signing or encrypting

Bug #211002 reported by Kenneth Loafman on 2008-04-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Enigmail
Won't Fix
High
Mozilla Thunderbird
Invalid
High
enigmail (Ubuntu)
Low
Unassigned

Bug Description

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Thunderbird 2.0.0.12+nobinonly-0ubuntu1
Enigmail 2:0.95.0-0ubuntu4

When sending a signed or encrypted email Thunderbird hangs for several seconds then says that it cannot send the mail and asks, "Are your network settings correct?". Yes, they are! All I have to do is tell Enigmail to ignore the sign/encrypt rules and all goes through as it should. It used to ask for a password. Somewhere in the last few sets of the daily dozen updates to Hardy, it stopped asking, and now does not even ask for a password when encrypted mail is sent to me using my key. I have to manually extract and decrypt the mail using command line utilities.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4) Gecko/2008031317 Firefox/3.0b4
Build Identifier: Thunderbird 2.0.0.12+nobinonly-0ubuntu1

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"

Thunderbird 2.0.0.12+nobinonly-0ubuntu1
Enigmail 2:0.95.0-0ubuntu4

When sending a signed or encrypted email Thunderbird hangs for several seconds then says that it cannot send the mail and asks, "Are your network settings correct?". Yes, they are! All I have to do is tell Enigmail to ignore the sign/encrypt rules and all goes through as it should. It used to ask for a password. Somewhere in the last few sets of the daily dozen updates to Hardy, it stopped asking, and now does not even ask for a password when encrypted mail is sent to me using my key. I have to manually extract and decrypt the mail using command line utilities.

Reproducible: Always

Steps to Reproduce:
1.Receive valid encrypted email.
2.
Actual Results:
Body pane remains blank.
Message above header says "Click key icon"
Popup says: Error: decryption failed, secret key not available.
It never asks for a passphrase. Manually decrypting the message is possible.

Expected Results:
I expected to receive a passphrase prompt and see the encrypted message.

Please ask the enigmail authors

Changed in enigmail:
status: Unknown → Confirmed
Changed in thunderbird:
status: Unknown → Invalid

One other issue that may help locate this problem. Other than gnupg-agent, what does enigmail use for passphrase caching? Is it possible that something in that is screwed up?

In "System / Prefs / Encryption / PGP Passphrases" I see two lines:
  Remember PGP Passphrases (bold)
    A supported PGP passphrase agent is not running.

What is the "supported PGP passphrase agent"?

This bug is not in Enigmail, it's in Seahorse, as below.

https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/183514

This bug is not in Enigmail, it's in Seahorse, as below.

https://bugs.launchpad.net/ubuntu/+source/seahorse/+bug/183514

Changed in enigmail:
status: Confirmed → Won't Fix
Alex Salt (holy.cheater) wrote :

I have noticed the same problem. It also exists with debuild (while signing .dsc file)
I've installed pinentry-gtk2 package and it asks for password now, so enigmail is working.
I don't remember i've installed pinentry in gutsy, but enigmail was asking for a passphrase to decrypt a message. Also I don't remember I've deleted it while updating to hardy and it isn't shown in /var/log/dist-upgrade/*

Anyways, gnupg-agent only suggests installing pinentry, but doesn't require it.

Daniel T Chen (crimsun) on 2008-12-07
Changed in enigmail:
importance: Undecided → Low
Changed in thunderbird:
importance: Unknown → High
Changed in enigmail:
importance: Unknown → High

Can somebody tell me please if this happens also in newerenigmail versions?

Changed in enigmail (Ubuntu):
status: New → Incomplete

I have not see this in a couple of years.

On Fri, Oct 26, 2012 at 10:32 AM, Thomas Hotz <email address hidden> wrote:

> Can somebody tell me please if this happens also in newerenigmail
> versions?
>
> ** Changed in: enigmail (Ubuntu)
> Status: New => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/211002
>
> Title:
> Enigmail not asking for password when signing or encrypting
>
> Status in GnuPG extension for Thunderbird:
> Won't Fix
> Status in Mozilla Thunderbird Mail and News:
> Invalid
> Status in “enigmail” package in Ubuntu:
> Incomplete
>
> Bug description:
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=8.04
> DISTRIB_CODENAME=hardy
> DISTRIB_DESCRIPTION="Ubuntu hardy (development branch)"
>
> Thunderbird 2.0.0.12+nobinonly-0ubuntu1
> Enigmail 2:0.95.0-0ubuntu4
>
> When sending a signed or encrypted email Thunderbird hangs for several
> seconds then says that it cannot send the mail and asks, "Are your
> network settings correct?". Yes, they are! All I have to do is tell
> Enigmail to ignore the sign/encrypt rules and all goes through as it
> should. It used to ask for a password. Somewhere in the last few
> sets of the daily dozen updates to Hardy, it stopped asking, and now
> does not even ask for a password when encrypted mail is sent to me
> using my key. I have to manually extract and decrypt the mail using
> command line utilities.
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/enigmail/+bug/211002/+subscriptions
>

Then marking the bug as fixed. Thank you!

Changed in enigmail (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.