libenchant_myspell.so Causes Some Apps To Not Start

Bug #261596 reported by Duncan Lithgow on 2008-08-26
74
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Enchant
Fix Released
Medium
Debian
Fix Released
Unknown
enchant (Ubuntu)
Medium
Unassigned
Declined for Intrepid by Steve Langasek
openoffice.org-dictionaries (Ubuntu)
Undecided
Unassigned
Declined for Intrepid by Steve Langasek

Bug Description

Binary package hint: gramps

Ubuntu 8.10
gramps 3.0.1-1
Also effects gnome-xchat 1:0.24.0-0ubuntu1

All I've done is installed the Intrepid Ibex on a spare machine, installed GRAMPS via apt-get and tried to start it - resulting in this crash.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 8.10
ExecutablePath: /usr/share/gramps/gramps.py
InterpreterPath: /usr/bin/python2.5
Package: gramps 3.0.1-1
PackageArchitecture: all
ProcAttrCurrent: unconfined
ProcCmdline: /usr/bin/python /usr/share/gramps/gramps.py
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=da_DK.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: gramps
StacktraceTop:
 readdir64 () from /lib/tls/i686/cmov/libc.so.6
 g_dir_read_name () from /usr/lib/libglib-2.0.so.0
 MySpellChecker::requestDictionary ()
 ?? () from /usr/lib/enchant/libenchant_myspell.so
 ?? () from /usr/lib/libenchant.so.1
Title: gramps.py crashed with SIGSEGV in readdir64()
Uname: Linux 2.6.26-5-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy fuse lpadmin plugdev video

Related branches

Duncan Lithgow (duncan-lithgow) wrote :
Benny (bm-cage) wrote :

As a GRAMPS coder I can only say it appears to be a problem with the changes to spell checking done in Ubuntu.
So this should be filed under pygtk/spellchecking ?

The only solution at the moment would be to deactivate the spell checking in Gramps by editing the file src/Spell.py
That would be most unfortunated for GRAMPS however

Duncan Lithgow (duncan-lithgow) wrote :

marked pygtk as affected as per Benny's comment

Sebastien Bacher (seb128) wrote :

the crash is a libenchant one

> ** Tags added: need-i386-retrace
I can consistently reproduce this bug. What do I need to do to produce
am i-386 retrace?

StacktraceTop:readdir64@@GLIBC_2.2 () from /lib/tls/i686/cmov/libc.so.6
IA__g_dir_read_name (dir=0x8d061a8) at /build/buildd/glib2.0-2.17.7/glib/gdir.c:217
MySpellChecker::requestDictionary (this=0x8cfea30, szLang=0x8d05680 "hy") at myspell_checker.cpp:341
myspell_provider_request_dict (me=0x8afae98, tag=0x8d05680 "hy") at myspell_checker.cpp:495
_enchant_broker_request_dict (broker=0x8d01ac0, tag=0x8d05680 "hy") at enchant.c:1719

Changed in enchant:
importance: Undecided → Medium

Moving status to confirmed. This bug is preventing xchat-gnome from running on my system.

Changed in enchant:
status: New → Confirmed
nullack (nullack) on 2008-09-26
description: updated
Duncan Lithgow (duncan-lithgow) wrote :

Now that Ubuntu 8.10 is in beta something needs to be done about this, - it's stopping a number of people from running various applications.

Could we please have diffs for the affected packages which removes the dependency on gnome-doc-utils (and scrollkeeper?) as has been done in Debian.

We are running out of time for a proper fix, we just need these apps to run.

Jono Bacon (jonobacon) wrote :

Could this bug be the cause of https://bugs.edge.launchpad.net/ubuntu/+source/xchat-gnome/+bug/276036 - also a bug in starting xchat-gnome, based upon nullack's comment?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package enchant - 1.4.2-3.1ubuntu2

---------------
enchant (1.4.2-3.1ubuntu2) intrepid; urgency=low

  * debian/patches/02_fix_non_matching_dicts_crasher.dpatch:
    - don't close the directory before returning a dictionnary otherwise
      the code listing the next entries will crash (lp: #261596)

 -- Sebastien Bacher <email address hidden> Tue, 07 Oct 2008 15:32:37 +0200

Changed in enchant:
status: Confirmed → Fix Released
Sebastien Bacher (seb128) wrote :

thanks to jono we figured the issue and I uploaded a fixed revision now, could people have the bug do a "ls -l /usr/share/myspell/dicts" and "dpkg -l myspell-en-us" and attach the log to the bug? it seems that in some cases the "myspell-en-us" dictonnaries are not installed correctly. the change will fix the crash but those dictionnaries will still not be used correctly

duncan@duncan-laptop:~$ ls -l /usr/share/myspell/dicts
total 22464
-rw-r--r-- 1 root root 129761 2008-09-30 00:14 DicOOo.sxw
lrwxrwxrwx 1 root root 30 2008-09-30 20:20 dictionary.lst -> /etc/openoffice/dictionary.lst
lrwxrwxrwx 1 root root 9 2008-09-26 23:08 en-AU.aff -> en_AU.aff
lrwxrwxrwx 1 root root 9 2008-09-26 23:08 en-AU.dic -> en_AU.dic
-rw-r--r-- 1 root root 27828 2008-10-06 17:42 en_GB.aff
lrwxrwxrwx 1 root root 9 2008-10-07 08:42 en-GB.aff -> en_GB.aff
-rw-r--r-- 1 root root 527499 2008-10-06 17:42 en_GB.dic
lrwxrwxrwx 1 root root 9 2008-10-07 08:42 en-GB.dic -> en_GB.dic
lrwxrwxrwx 1 root root 9 2008-09-26 23:08 en-US.aff -> en_US.aff
lrwxrwxrwx 1 root root 9 2008-09-26 23:08 en-US.dic -> en_US.dic
-rw-r--r-- 1 root root 27519 2008-10-06 17:42 en_ZA.aff
-rw-r--r-- 1 root root 594430 2008-10-06 17:42 en_ZA.dic
-rw-r--r-- 1 root root 18597793 2008-10-06 17:42 th_en_US_v2.dat
-rw-r--r-- 1 root root 3044762 2008-10-06 17:42 th_en_US_v2.idx
duncan@duncan-laptop:~$ dpkg -l myspell-en-us
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
rc myspell-en-us 1:2.4.0-2ubunt English_american dictionary for myspell
duncan@duncan-laptop:~$

Could that be part of the problem? I'll try an update again in a few hours and do this again.

Sebastien Bacher (seb128) wrote :

the issue there seems that the en-US symlinks are not valid, opening an openoffice.org-dictionaries bug about those

Changed in enchant:
status: Unknown → Confirmed

This has fixed the issue with GRAMPS, although it really should have been able to handle this problem more gracefully itself.

Recent updates have fixed these issues on my system, spelling works fine (was bug 278161). Thanks!

Chris Cheney (ccheney) wrote :

Sebastien,

What was wrong with the en-US symlinks? I am looking at the hunspell-en-us package and it looks fine to me. I think maybe is something wrong with their install?

Chris

Changed in openoffice.org-dictionaries:
status: New → Incomplete
Steve Langasek (vorlon) wrote :

Chris, the problem with the symlinks is that they point to non-existent files.

Duncan, what does 'dpkg -S /usr/share/myspell/dicts/en*US* give on your system, and what does 'dpkg -l hunspell-en-us' give? Both the hunspell-en-us and myspell-en-us packages in intrepid appear to correctly include the dictionary files.

Steve Langasek (vorlon) wrote :

Not a bug in ooo-dictionaries anyway, since myspell-en-us was not installed.

Changed in openoffice.org-dictionaries:
status: Incomplete → Invalid
Chris Cheney (ccheney) wrote :

Steve,

Yes, that is why I was commenting that it looks like something was wrong with their install since the packages had both the files and symlinks in them, from what I recall when originally examining the issue.

Thanks,

Chris

For Steve:

duncan@duncan-laptop:~$ dpkg -S /usr/share/myspell/dicts/en*US*
hunspell-en-us: /usr/share/myspell/dicts/en-US.aff
hunspell-en-us: /usr/share/myspell/dicts/en-US.dic
duncan@duncan-laptop:~$ dpkg -l hunspell-en-us
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii hunspell-en-us 20070829-2ubun English_american dictionary for hunspell
duncan@duncan-laptop:~$

Chris Cheney (ccheney) wrote :

Duncan,

And as a comparison:

ccheney@laptop-c2d:~$ dpkg -S /usr/share/myspell/dicts/en*US*
hunspell-en-us: /usr/share/myspell/dicts/en_US.aff
hunspell-en-us: /usr/share/myspell/dicts/en-US.aff
hunspell-en-us: /usr/share/myspell/dicts/en_US.dic
hunspell-en-us: /usr/share/myspell/dicts/en-US.dic
ccheney@laptop-c2d:~$ dpkg -l hunspell-en-us
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name Version Description
+++-==============-==============-============================================
ii hunspell-en-us 20070829-2ubun English_american dictionary for hunspell
ccheney@laptop-c2d:~$

Which is why I thought this must be something wrong with your install, or maybe something wrong with dpkg? In any case the files are actually there in the debs it just isn't there on your system.

Steve Langasek (vorlon) wrote :

Duncan,

For comparison, please check:

$ dpkg -L hunspell-en-us | grep dicts/en.US

it should give you the same four entries that Chris's dpkg -S output shows, even if two of the files are no longer on disk.

And apt-get install --reinstall hunspell-en-us should fix the problem for you.

Changed in enchant:
status: Confirmed → Fix Released

duncan@duncan-laptop:~$ dpkg -L hunspell-en-us | grep dicts/en.US
/usr/share/myspell/dicts/en_US.aff
/usr/share/myspell/dicts/en_US.dic
/usr/share/myspell/dicts/en-US.aff
/usr/share/myspell/dicts/en-US.dic
duncan@duncan-laptop:~$

duncan@duncan-laptop:~$ sudo apt-get install --reinstall hunspell-en-us
[sudo] password for duncan:
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 255kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com intrepid/main hunspell-en-us 20070829-2ubuntu1 [255kB]
Fetched 255kB in 0s (392kB/s)
(Reading database ... 178328 files and directories currently installed.)
Preparing to replace hunspell-en-us 20070829-2ubuntu1 (using .../hunspell-en-us_20070829-2ubuntu1_all.deb) ...
Unpacking replacement hunspell-en-us ...
Setting up hunspell-en-us (20070829-2ubuntu1) ...
Updating OpenOffice.org's dictionary list... done.
duncan@duncan-laptop:~$

duncan@duncan-laptop:~$ dpkg -S /usr/share/myspell/dicts/en*US*
hunspell-en-us: /usr/share/myspell/dicts/en_US.aff
hunspell-en-us: /usr/share/myspell/dicts/en-US.aff
hunspell-en-us: /usr/share/myspell/dicts/en_US.dic
hunspell-en-us: /usr/share/myspell/dicts/en-US.dic
duncan@duncan-laptop:~$

I guess that's fixed then. Thanks.

tags: added: iso-testing
Changed in enchant:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.