Ubuntu

Spell Checker Doesn't Work Consistently

Reported by Mike McKee on 2008-08-02
30
This bug affects 4 people
Affects Status Importance Assigned to Milestone
XChat-GNOME
Expired
High
enchant (Ubuntu)
Undecided
Unassigned
tomboy (Ubuntu)
Undecided
Unassigned

Bug Description

I have Ubuntu 8.04.1, kernel 2.6.24-19-generic (Hardy Heron) and am in the USA. I have installed the 386 version instead of the AMD64 version (my laptop is an AMD64 laptop). When I use Firefox that comes with Ubuntu, the spell checker works inconsistently. On contractions (won't, doesn't, etc.) it's reporting these as misspelled most of the time. On other misspelled words it is not catching these, but only sometimes. When I rightclick in the textarea and uncheck "Check Spelling", then turn it back on again, it properly checks the spelling. This used to not occur for me in my last Ubuntu that I used, which was Ubuntu 7.04 with Firefox 2.

I'd love to see some movement on this bug. I'm sure that if it worked okay in FF2, that it's probably just a simple fix for FF3?

Mike McKee (reach-supermike) wrote :

Bug moderator: does this need to start as "Firefox Spell Checker..." instead of "Spell Checker..."?

volomike (volomike) on 2008-10-15
description: updated
komputes (komputes) wrote :

I have the same issue, I can confirm this happens. It happens to me that the word "won't" gets underlined as an incorrect word with "won" underlined. I am not sure if firefox and other programs such as gedit and pidgin share a common dictionary library - but if they do, that might be the package to attach this bug to. Also see Bug #113511 which needs to be assigned to this package.

komputes (komputes) wrote :

Here is a picture illustrating the bug. This was taken in gedit but is reproducable with other programs as well

Martin Kossick (hacktick) wrote :

Hi,
Thank you for taking the time to make Ubuntu better.
Could you test if this issue still exists in intrepid or jaunty?
If someone else than the original bug reporter can reproduce the bug, feel free to set the status to "confirmed".
Thank you for your help!

greetings
Martin

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Thank you for having taken the time to report this bug to help make
Ubuntu better. You reported this bug a while ago and there hasn't been
any activity in it recently. We were wondering is this still an issue
for you? Can you try with latest Ubuntu release? Thanks in advance.

 subscribe
 status incomplete
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: http://getfiregpg.org

iEYEARECAAYFAkk/OwoACgkQZaGzTLr7X3WakwCcDsW8Y9vWXlEPGR2wIem9JJaG
gnEAnj8AyZ6SVUbGu61qFk8mcn/ILakX
=OhXG
-----END PGP SIGNATURE-----

Micah Gersten (micahg) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Changed in firefox-3.0 (Ubuntu):
status: New → Incomplete
John Vivirito (gnomefreak) wrote :

Is this the same for all locales? Just English or does it happen in german or dutch or any other one? I'm not conviced this is Firefox bug alone.

Shehnaaz (asmals) wrote :

I am marking this as confirmed on jaunty, using en_ZA.UTF-8 locale, and shifting package to something more appropriate. I have the following dictionaries installed: myspell-en-au, myspell-en-za, myspell-en-gb, and aspell-en. Enchant, when running from the command-line, says:

mononoke@R2D2:~$ enchant -a
@(#) International Ispell Version 3.1.20 (but really Enchant 1.4.2)
error: duplicate REP tables used
Failure loading aff file /usr/share/myspell/dicts/en_ZA.aff

... but continues on to spell-check words anyway. I don't know whether this is normal or not.

Words which are extensions of a root word, such as "things", "cushioned", or "wanting", are detected as misspellings. "thing", "cushion", and "want" are accepted. 'enchant -a' detects all of these extensions as being misspellings:

mononoke@R2D2:~$ enchant -a
@(#) International Ispell Version 3.1.20 (but really Enchant 1.4.2)
error: duplicate REP tables used
Failure loading aff file /usr/share/myspell/dicts/en_ZA.aff
cushioned
& cushioned 4 0: cushion, fashioned, Cushitic, cautioned

... however, aspell does not:

mononoke@R2D2:~$ aspell -a
@(#) International Ispell Version 3.1.20 (but really Aspell 0.60.6)
cushioned
*

... but that makes sense, I suppose, since I also have this as the default:

mononoke@R2D2:~$ cat /usr/share/enchant/enchant.ordering
*:myspell,aspell,ispell

A second, possibly-related issue is that apostrophes found in words are, in *some* applications (such as OGMrip), detected as misspellings. In other applications, the same words are found to be correct. My working hypothesis is that UTF-8 curly-apostrophes and normal-keyboard-apostrophes are being interpreted differently, although there is very little perceptible difference to the user.

affects: firefox-3.0 (Ubuntu) → enchant (Ubuntu)
Changed in enchant (Ubuntu):
status: Incomplete → Confirmed
Shehnaaz (asmals) wrote :
Shehnaaz (asmals) wrote :
Shehnaaz (asmals) wrote :

Forgot to mention -- the first attachment ("Common words being detected as misspellings") is from a Pidgin IRC window.

tags: removed: firefox
Shehnaaz (asmals) wrote :

Bing! 1.5 months later, day-zero bug that affects pretty much all users, and no activity on it? Not even assigned to anyone? Nobody thinks that it's important?

'cos I can tell you that when your system comes with a "spell-checker" that can't understand the word "witches" (or just about any other common plural) as being the correct spelling, it gives the impression of a pretty shoddy system. Can someone at least respond and say you're looking into it, or something? Do you need more data?

How's that death-by-papercuts thing coming along, I wonder ... *annoyed*.

John Baptist (jepst79) wrote :

According to this thread, the problem is in pango, a text-layout library.

http://markmail.org/message/4erzorilvdgcuega

I agree with Shehnaaz, this is a pretty embarassing bug. Does anyone know if this is fixed in a later version of pango, or am I going to have to submit a patch myself? <sigh>

C (cinyc-s) wrote :

I can confirm that this bug is very much alive on a fresh install of Ubuntu 9.10 Karmic Koala, amd64. And it's now well over one year since it's been reported ... I guess you guys just don't give a damn? That's the only explanation I have for absolutely nobody from Ubuntu giving up 30 seconds of their precious time to type "We're looking into it".

Anyone know of some super-secret channel that can be used to actually get the attention of Ubuntu packagers? I'm all ears.

Changed in ubuntu:
status: Invalid → Confirmed
mobilediesel (mobilediesel) wrote :

This bug is very annoying. Contractions should definitely be accepted as correctly spelled. Plural forms of various words should be accepted as correct.

Is there at least some kind of work-around?

C (cinyc-s) wrote :

Changing from "enchant" (which nobody seems to care about) to "tomboy" (which is where the bug is most annoying to me at present, and which people presumably care about).

affects: enchant (Ubuntu) → tomboy (Ubuntu)
C (cinyc-s) wrote :
Alex Mauer (hawke) on 2009-11-22
affects: ubuntu → enchant (Ubuntu)
John Baptist (jepst79) wrote :

C: your decision to replace enchant with tomboy doesn't make sense.

enchant is a spell-checking engine, which might actually be responsible for causing this bug. Whether or not anyone cares about it doesn't matter. tomboy, on the other hand is just an application which is a victim of this bug, through no fault of its own.

So, while your change might reflect what you "care" about, it doesn't get the bug seen by people who can fix it.

If you want to note that it affects tomboy, you should add tomboy in addition to enchant in the list of affect packages, rather than removing a package that we know it affects.

John O'Brien (obrien-jk) wrote :

I see this also with xchat. I've just switched from gnome to kde, and don't remember seeing this problem with gnome, but I couldn't swear to that.

Anyway, basically... Me too!

John Baptist (jepst79) wrote :

This seems to be fixed in an updated Karmic. Haven't tested in Lucid.

The spell check problem in gedit (Bug 36227), though, is still alive and well.

Changed in xchat-gnome:
status: Unknown → Invalid
Changed in xchat-gnome:
importance: Unknown → High
status: Invalid → Expired
Changed in tomboy (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.