Empathy not connecting to Gtalk

Bug #997017 reported by Vincent on 2012-05-09
116
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Empathy
New
Medium
empathy (Ubuntu)
Low
Unassigned

Bug Description

Empathy fails to connect to gtalk on both Google apps accounts and normal gmail accounts. You also cannot create xmpp account with the Gtalk settings.
In past versions one could double check the settings under the advanced settings, but these are no longer available.

In Natty my gtalk accounts all functioned if I remembered to open Empathy after logging on to my laptop.

I also tried to edit /home/vincent/.mission-control/accounts/accounts.cfg but this also fails.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: empathy 3.4.1-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.37-generic 3.2.14
Uname: Linux 3.2.0-24-generic x86_64
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
Date: Wed May 9 10:43:10 2012
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
SourcePackage: empathy
UpgradeStatus: Upgraded to precise on 2012-04-30 (8 days ago)

Vincent (realmkeepersbox) wrote :
Bilal Shahid (s9iper1) wrote :

thanks for the bug report
please attach the auth client debug log file also with the bug report.
you can get it from help debug menu

Changed in empathy (Ubuntu):
status: New → Incomplete
Vincent (realmkeepersbox) wrote :

Hi Bilal, here is the debug log for empathy > help > debug.
I ran this one for a bit longer than the debug log above and recreated the one gmail/gtalk account just to make sure.

Bilal Shahid (s9iper1) wrote :

when you click on all there will be the option of auth client in the list attach that one log while reproducing the same issue

Vincent (realmkeepersbox) wrote :

Sorry, no auth client option in the list only 2 options that are extra when I activate the gtalk account; gabble(jabber) and haze.

Debug > All
             > mission-control
             >salut(local-xmpp)
             >Empathy.FileTransfer
             >IndicatorAppRover
             >Logger
             >haze
             >gabble(jabber)

Which one should I post?

Bilal Shahid (s9iper1) wrote :

get offline from the message indicator and than open the debug menu and clear the previous logs and than set your status available from indicator than you will see in the debug log list the auth client logs are appear you save them and attach them here.

Vincent (realmkeepersbox) wrote :

Went offline, cleared the logs then used the indicator to change to available and still no auth client option. See attached Screenshot.

Did this 4 times, but still no auth client logs. What I do see is a constant warning in the logs and the CLI output about a persona store that cannot be found.
Other thing to note is that I did clear the logs everytime, but when scanning through them I find there are time entries from before I cleared the logs. Am I maybe stuck with permission problems after my upgrade to Precise?

Bilal Shahid (s9iper1) wrote :

there is a auth client log i have it than why should'nt you have
?

I've the same issue and I confirm that I also don't have the auth client log....

I've just found out why the auth log is not present: empathy-auth-client was not running...if I manually start /usr/lib/empathy/empathy-auth-client, the Empathy.Auth appears...

P.S. I'm behind a proxy, but Gtalk was working on oneiric (even if connecting to Gtalk was requiring some minutes...)

Vincent (realmkeepersbox) wrote :

Thanks Alessio, now we are getting somewhere! Mine was also not running.

I'll run empathy for a while for the auth-client log to fill as i see only 3 entries and 1 error.

timeout_cb: Timeout reached; exiting...

empathy-ayth-client not starting mmm... another bug? Sorry, just upgrading to precise has been a nightmare.

Vincent (realmkeepersbox) wrote :

Well here is Empathy.Auth and Empathy.authEventManager

Hope this is what you are looking for Bilal

Bilal Shahid (s9iper1) wrote :

ok thanks for that i guess you have the same problem can you tell me the steps to reproduce it ?
bug #993880

Vincent (realmkeepersbox) wrote :

Maybe related, but mine won't connect no matter what, not in any of the GTK2/3 based GUIs. Pidgin connects when I terminate Empathy to release libpurple.

Cold, Fresh start - nothing
Hot start - nothing
Hibernate/Resume - nothing
Log-out/login - nothing
Suspend/resume - nothing
Reinstalled - nothing
Remove/install - nothing
Purge/reboot, install - nothing

olopopo (fraga-muerete) wrote :

I got it to work by killing every process regarding empathy (mission-control, telepathy-*,empathy*), launching empathy-auth-client from the console and then launch empathy.

I hope this helps

Yannick Warnier (ywarnier) wrote :

I have the same problem, I think.
#16 doesn't work for me, I still get no authentication with GTalk neither with an OpenFire-based XMPP service I have. With Pidgin, it works perfectly well.
Note the "only" thing that affected the fact that it works or not with Empathy is that I upgraded from Ubuntu 11.10 to 12.04 today.

Joe A (joeamoros) wrote :

I am able to connect when I put my proxy to None and apply system wide. However, when I have it on (using cntlm) I am unable to connect. As others have said, this started when I upgraded to 12.04.

I confirm that if I connect the my pc at home, where there aren't proxy, empathy starts to work as soon as I disable proxy system wide.
I think that the problem is more serious, because I've noticed that also gnome extension installation (from https://extensions.gnome.org/) doesn't work if I'm using the proxy.

P.S: the proxy address that I'm using is working, because I use it in Firefox

I am also experiencing this issue. I can confirm that by killing all empathy, telepathy, and mission control processes and restarting with empathy-auth-client and then empathy, both facebook and Google talk reconnect.

Joe A (joeamoros) wrote :

I can confirm what #20 has said. I applied proxy again and killed everything, ran empathy-auth-client, and restarted empathy, and I was able to log into gtalk.

benditoelqueviene (quasar1970) wrote :

I've the same issue. Empathy worked well until openssl and libssl 1.0.0 (1.0.1-4ubuntu3, 1.0.1-4ubuntu5.2) were updated. Should I uninstall them? I'm an absolut begginer. I've 3 accounts in GTalk, only one connects without problem, now Yahoo is having trouble also. I erase the 2 non-connecting GTalk accounts and they re-appear in the next login to Ubuntu. No proxy, Firefox 12.0 works well, so does the rest of connecting software.

Bilal Shahid (s9iper1) wrote :

you can send this bug to upstream thanks all

Does anyone have problem also with Hotmail? I've just tried, but is not connecting...maybe the issue is the same...

Bilal Shahid (s9iper1) wrote :

you file another bug for hotmail issue
i am going to upstream this bug you people please subscribe to that bug thanks.

Changed in empathy (Ubuntu):
status: Incomplete → Triaged
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
zwigno (zwigno) wrote :

This is happening to me also. Doing the steps in #20 makes no difference.

Ubuntu proxy settings are set to auto-detect, configuration URL empty.
Case 1: Home where I don't have a proxy - Empathy works as expected.
Case 2: Work WITH (squid) proxy - Empathy cannot sign in "no reason specified"
Case 3: Work, changed settings to NO proxy (I have special network access). Empathy works as expected.
Case 4: Work WITH proxy, changed settings so that configuration URL set - Empathy works as expected.

Summary: When network settings are set to auto-detect the proxy, Empathy does not query for/use the configuration URL if it isn't set. Result: gtalk/xmpp/others? fail to log in.

Skeletonix (tomaskloucek) wrote :

I have the same problem ... when I changed settings to NO proxy Empathy works properly.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.