Jabber authentication fails after 11.11 -> 12.04 upgrade

Bug #983332 reported by jasonmartens on 2012-04-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Empathy
Incomplete
Medium
empathy (Ubuntu)
Low
Unassigned

Bug Description

I just upgraded from 11.11 to 12.04, and one of my jabber accounts now fails to authenticate. I have confirmed that my username/password is correct by installing pidgin and logging into the same server. In addition, the credentials were not changed during the upgrade and it worked fine before, but failed after.

I suspect that this might have something to do with the SSL certificate the server is using (self-signed). I've tried connecting with the "ignore SSL certificate errors" option on and off, but it doesn't work either way.

I also use a Google Apps (gmail) account, and that one had no problem logging in after the upgrade (except for some crashes, which are already reported in other bug reports).

Bilal Shahid (s9iper1) wrote :

thanks for the bug report
attach the mission control log file with the bug report
you can get it from help debug menu.

Changed in empathy (Ubuntu):
status: New → Incomplete
jasonmartens (me-jasonmartens) wrote :

Here is the mission control log. To create this log I did the following:
Cleared old logs
opened chat application
pressed F4 to open account window
added jabber account which has been failing (initial connection fails here, because there is no option to add a server)
Edited the account's advanced options and set ignore ssl errors, and added a connection server name (account fails to connect)
deleted the account

At this point, I would expect it to connect successfully. I see authentication errors in the log, but I have created the same account with the same username/password prior to 12.04 upgrade and it worked correctly. I have also created an XMPP account in Pidgin with the same username/password and server, which is able to connect successfully.

Changed in empathy (Ubuntu):
status: Incomplete → New
Bilal Shahid (s9iper1) wrote :

are you using a proxy servers ?
and please dont change the status
and can you reproduce it as well ?

No, I am not using proxy servers.

Yes, I can reproduce it at will.

On Tue, Apr 24, 2012 at 1:21 PM, Bilal Shahid <email address hidden> wrote:
> are you using a proxy servers ?
> and please dont change the status
> and can you reproduce it as well ?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/983332
>
> Title:
>  Jabber authentication fails after 11.11 -> 12.04 upgrade
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/empathy/+bug/983332/+subscriptions

Bilal Shahid (s9iper1) wrote :

thanks for info i am sending your bug to the upstream you can subscribe to that one and make comments.

Changed in empathy (Ubuntu):
importance: Undecided → Low
Bilal Shahid (s9iper1) on 2012-04-29
Changed in empathy (Ubuntu):
status: New → Triaged
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
Changed in empathy:
status: New → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.