empathy-chat consistently uses 9-10 % CPU

Bug #959084 reported by Michael on 2012-03-19
68
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Adium Theme Ubuntu
Undecided
Unassigned
Empathy
Unknown
Medium
adium-theme-ubuntu (Ubuntu)
Medium
Chad Miller
Quantal
Medium
Unassigned
empathy (Ubuntu)
Low
Unassigned
Quantal
Undecided
Unassigned
webkit (Ubuntu)
Medium
Unassigned
Quantal
Undecided
Unassigned

Bug Description

[Test Case]
Verification is simple, open a chat window with someone where the history doesn't fill the chat window and leave it sit idle. While it is open, check the load created by the empathy-chat process.

[Regression potential]
Low, this really just slows down how aggressive the javascript is in detecting how close it is to the bottom of the window.

This may have started since I upgraded my system to 12.04, it was certainly a recent development at around that time. I am using empathy for IRC only, connected to four channels on two servers, though even disabling all accounts does not change this. The empathy-chat process is very consistently at 9% CPU, with spikes at 10% or higher from time to time. I have tested this on mobile broadband, wifi and ethernet.

ProblemType: BugDistroRelease: Ubuntu 12.04
Package: empathy 3.3.91-0ubuntu3
ProcVersionSignature: Ubuntu 3.2.0-19.30-generic 3.2.11
Uname: Linux 3.2.0-19-generic x86_64
ApportVersion: 1.94.1-0ubuntu2
Architecture: amd64
Date: Mon Mar 19 09:28:49 2012
ExecutablePath: /usr/lib/empathy/empathy-chatInstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_US.UTF-8SourcePackage: empathy
UpgradeStatus: Upgraded to precise on 2012-03-12 (6 days ago)

Related branches

Michael (michaeljt) wrote :
Bilal Shahid (s9iper1) wrote :

thanks for the bug
can you please attach the picture or other visual medium to show us your processor values.?

Changed in empathy (Ubuntu):
status: New → Incomplete
Michael (michaeljt) wrote :

top - 17:27:03 up 8:01, 3 users, load average: 0.07, 0.08, 0.07
Tasks: 205 total, 1 running, 204 sleeping, 0 stopped, 0 zombie
Cpu(s): 0.5%us, 0.4%sy, 0.0%ni, 99.1%id, 0.0%wa, 0.0%hi, 0.0%si, 0.0%st
Mem: 7971500k total, 4990992k used, 2980508k free, 257880k buffers
Swap: 0k total, 0k used, 0k free, 3428296k cached

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 2792 michael 20 0 1899m 69m 29m S 9 0.9 0:15.37 empathy-chat
 2660 michael 20 0 519m 21m 11m S 2 0.3 0:29.52 gnome-terminal
 1269 root 20 0 203m 31m 7748 S 1 0.4 5:08.52 Xorg
 2161 michael 20 0 1446m 82m 27m S 1 1.1 4:18.74 compiz
 1247 root 20 0 7428 420 300 S 1 0.0 0:14.88 gpm
 1260 root 20 0 15964 692 512 S 0 0.0 0:03.78 irqbalance
 2418 michael 20 0 2026m 53m 31m S 0 0.7 0:07.39 empathy
 2830 michael 20 0 17432 1400 976 R 0 0.0 0:00.02 top
    1 root 20 0 24576 2524 1380 S 0 0.0 0:00.93 init
    2 root 20 0 0 0 0 S 0 0.0 0:00.01 kthreadd
    3 root 20 0 0 0 0 S 0 0.0 0:01.99 ksoftirqd/0
    6 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/0
    7 root RT 0 0 0 0 S 0 0.0 0:00.10 watchdog/0
    8 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/1
   10 root 20 0 0 0 0 S 0 0.0 0:00.98 ksoftirqd/1
   12 root RT 0 0 0 0 S 0 0.0 0:00.09 watchdog/1
   13 root RT 0 0 0 0 S 0 0.0 0:00.00 migration/2

Lorem (lrmpsm) wrote :

This happen also to me, empathy-chat window always at 9% on a Intel i7 2600K with 8gb of ram

Lorem (lrmpsm) wrote :
quaec (quaec) wrote :

I've also the same problem. I've attached a screenshot of htop, maybe it helps.

Bilal Shahid (s9iper1) wrote :

i say when you start empathy there is load of some thing like that affects the cpu but it remains same when empathy gets loaded ?

Michael (michaeljt) wrote :

Just tested (by having XChat-GNOME open before I opened Empathy; since Empathy still can't handle alternative IRC nick names this prevents IRC from starting) and the CPU load remains normal until the chat window opens. Does that answer your question?

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Bilal Shahid (s9iper1) wrote :

so so i have also seen this when we open the chat window the cpu usage increase but when we open the empathy cpu usage increases but come on stability after the loading..

Bilal Shahid (s9iper1) wrote :

sending this bug to upstream you please subscribe to that one and make comments

Bilal Shahid (s9iper1) on 2012-04-30
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Changed in empathy:
importance: Unknown → Medium
status: Unknown → Incomplete
Changed in empathy:
status: Incomplete → Unknown
Michael (michaeljt) wrote :

As per the GNOME bug, I confirm that switching from the "Ubuntu" theme to the "Clean" theme fixes this for me. I realise that this isn't really my business, but given that Ubuntu has limited development resources available, it it really the most efficient use of those resources to maintain their own Empathy theme? If Ubuntu wants to do work on Empathy I could think of better ways to improve the user experience.

Lorem (lrmpsm) wrote :

I think that this issue can continue here, someone have to just add "adium-theme-ubuntu" (or something related to webkit, like suggested by developer) in the "Affects" section.

Bilal Shahid (s9iper1) wrote :

i have filed it there

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in adium-theme-ubuntu (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) on 2012-05-04
affects: adium-theme-ubuntu → adium-theme-ubuntu (Ubuntu)
Changed in adium-theme-ubuntu (Ubuntu):
importance: Undecided → Medium
importance: Medium → Low
status: New → Triaged
rebroad (rebroad) wrote :

Until this bug is fixed... is there a recommended alternative to empathy?

Michael (michaeljt) wrote :

XChat-GNOME? Or if you really want to stick with Empathy (do try XChat though!) you can just change the theme.

Jochen Fahrner (jofa) wrote :

I can confirm that this bug only exits with ubuntu theme.

Guillaume Desmottes (cassidy) wrote :

I did some testing and this bug only appears when using Ubuntu's adium theme so it's either a theme bug (like some js infinite loop or something) or a webkit-gtk one. I can reproduce this bug on F17 as well.

I won't have time to investigate this issue further but the next step could do to try some profiling using Webkit's inspector tool:
- gsettings set org.gnome.Empathy.conversation enable-webkit-developer-tools true
- Open a chat with the adium theme
- Right click and select 'Inspect Element'

It would be cool if some webkit(-gtk) could take a look on this issue.

Guillaume Desmottes (cassidy) wrote :

I don't think we use to have this bug with the previous ubuntu version. So another useful thing to do would be to bisect through the theme history and find which commit introduced this bug.

Ken VanDine (ken-vandine) wrote :

I tested this with the maverick version of the theme on quantal and could still reproduce this. I am certain this wasn't a problem in the past. I guess something in webkit?

Changed in webkit (Ubuntu):
assignee: nobody → Chad Miller (cmiller)
importance: Undecided → Medium
Changed in adium-theme-ubuntu (Ubuntu):
status: Triaged → Invalid
Chad Miller (cmiller) wrote :

Until the window is filled vertically, the process enters some loop. In analyzing syscalls, it's a half dozen clock_gettime()s and then a rather expensive poll() of a socket along with a recv() that fails. Loop about 200 times per second.

12:13:37 recv(8, 0x8a19060, 4096, 0) = -1 EAGAIN (Resource temporarily unavailable)
12:13:37 clock_gettime(CLOCK_MONOTONIC, {256453, 277724784}) = 0
12:13:37 poll([{fd=6, events=POLLIN}, {fd=8, events=POLLIN}, {fd=12, events=POLLIN}, {fd=16, events=POLLIN}, {fd=3, events=POLLIN}], 5, 0) = 0 (Timeout)
12:13:37 clock_gettime(CLOCK_MONOTONIC, {256453, 277835655}) = 0
12:13:37 clock_gettime(CLOCK_MONOTONIC, {256453, 277924856}) = 0
12:13:37 clock_gettime(CLOCK_MONOTONIC, {256453, 277967429}) = 0
12:13:37 clock_gettime(CLOCK_MONOTONIC, {256453, 278011174}) = 0

Chad Miller (cmiller) on 2012-10-25
Changed in adium-theme-ubuntu (Ubuntu):
status: Invalid → Confirmed
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) on 2012-10-25
Changed in adium-theme-ubuntu:
status: New → In Progress
assignee: nobody → Chad Miller (cmiller)
Chad Miller (cmiller) on 2012-10-25
Changed in webkit (Ubuntu):
status: New → Invalid
Changed in empathy (Ubuntu):
status: Triaged → Invalid
Ken VanDine (ken-vandine) wrote :

Verification is simple, open a chat window with someone where the history doesn't fill the chat window and leave it sit idle. While it is open, check the load created by the empathy-chat process.

Regression potential: Low, this really just slows down how aggressive the javascript is in detecting how close it is to the bottom of the window.

Changed in adium-theme-ubuntu:
status: In Progress → Fix Released
assignee: Chad Miller (cmiller) → nobody
Changed in adium-theme-ubuntu (Ubuntu):
importance: Low → Medium
Changed in webkit (Ubuntu):
assignee: Chad Miller (cmiller) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adium-theme-ubuntu - 0.3.3-0ubuntu1

---------------
adium-theme-ubuntu (0.3.3-0ubuntu1) raring-proposed; urgency=low

  * New upstream release.
    - Avoid an infinite loop in scrolling to the bottom of a
      window. (LP: #959084)
 -- Ken VanDine <email address hidden> Mon, 29 Oct 2012 11:10:44 +0100

Changed in adium-theme-ubuntu (Ubuntu):
status: Confirmed → Fix Released
Changed in empathy (Ubuntu Quantal):
status: New → Invalid
Changed in webkit (Ubuntu Quantal):
status: New → Invalid
Clint Byrum (clint-fewbar) wrote :

Hi! This bug report lacks a clear Test Case and Regression Potential section in the description, which are required by the SRU process. Please add them so we can accept the fix for quantal!

Brian Murray (brian-murray) wrote :

The SRU details appear in comment #22 - I'll put them in the description.

description: updated
Changed in adium-theme-ubuntu (Ubuntu Quantal):
importance: Undecided → Medium
status: New → Fix Committed
tags: added: verification-needed

Hello Michael, or anyone else affected,

Accepted adium-theme-ubuntu into quantal-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/adium-theme-ubuntu/0.3.3-0ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please change the bug tag from verification-needed to verification-done. If it does not, change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Michael (michaeljt) wrote :

I'm afraid I am no longer using Empathy, as this bug was the last straw for a piece of software which didn't have much going for it from the start.

Chad Miller (cmiller) wrote :

Before: 22528 cmiller 20 0 297m 40m 20m S 9.3 1.4 7:33.21 empathy-chat
After: 7387 cmiller 20 0 290m 43m 28m S 0.0 1.5 0:02.21 empathy-chat

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package adium-theme-ubuntu - 0.3.3-0ubuntu0.1

---------------
adium-theme-ubuntu (0.3.3-0ubuntu0.1) quantal-proposed; urgency=low

  * New upstream release.
    - Avoid an infinite loop in scrolling to the bottom of a
      window. (LP: #959084)
 -- Ken VanDine <email address hidden> Mon, 29 Oct 2012 11:10:44 +0100

Changed in adium-theme-ubuntu (Ubuntu Quantal):
status: Fix Committed → Fix Released

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Jan Nekvasil (jan-nekvasil) wrote :

12.04.2 LTS still uses 0.3.2-0ubuntu1, which is affected by this bug? It's possible to push 0.3.3 to SRU for Raring too?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.