Ubuntu

empathy-chat assert failure: *** glibc detected *** /usr/lib/empathy/empathy-chat: free(): invalid next size (fast): 0x000000000160ffc0 ***

Reported by Daniel Holbach on 2012-03-02
78
This bug affects 10 people
Affects Status Importance Assigned to Milestone
DBus Menu
High
Charles Kerr
Empathy
Unknown
Critical
empathy (Ubuntu)
Medium
Unassigned
libdbusmenu (Ubuntu)
High
Unassigned

Bug Description

No idea what happened.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: empathy 3.3.5-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-17.27-generic 3.2.6
Uname: Linux 3.2.0-17-generic x86_64
ApportVersion: 1.93-0ubuntu2
Architecture: amd64
AssertionMessage: *** glibc detected *** /usr/lib/empathy/empathy-chat: free(): invalid next size (fast): 0x000000000160ffc0 ***
CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Fri Mar 2 12:02:46 2012
ExecutablePath: /usr/lib/empathy/empathy-chat
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
ProcCmdline: /usr/lib/empathy/empathy-chat
Signal: 6
SourcePackage: empathy
StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f33bcbfe250 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f33bcbfe418 "free(): invalid next size (fast)", ptr=<optimized out>) at malloc.c:5007
 ?? () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 g_signal_handlers_disconnect_matched () from /usr/lib/x86_64-linux-gnu/libgobject-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libdbusmenu-glib.so.4
Title: empathy-chat assert failure: *** glibc detected *** /usr/lib/empathy/empathy-chat: free(): invalid next size (fast): 0x000000000160ffc0 ***
UpgradeStatus: Upgraded to precise on 2012-02-16 (15 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Daniel Holbach (dholbach) wrote :

StacktraceTop:
 __libc_message (do_abort=2, fmt=0x7f33bcbfe250 "*** glibc detected *** %s: %s: 0x%s ***\n") at ../sysdeps/unix/sysv/linux/libc_fatal.c:201
 malloc_printerr (action=3, str=0x7f33bcbfe418 "free(): invalid next size (fast)", ptr=<optimized out>) at malloc.c:5007
 handler_unref_R (handler=0x1637b00, instance=0x141b580, signal_id=<optimized out>) at /build/buildd/glib2.0-2.31.18/./gobject/gsignal.c:638
 handler_match_free1_R (instance=0x141b580, node=0x13d4c20) at /build/buildd/glib2.0-2.31.18/./gobject/gsignal.c:466
 signal_handlers_foreach_matched_R (instance=0x141b580, mask=<optimized out>, signal_id=<optimized out>, detail=<optimized out>, closure=<optimized out>, func=<optimized out>, data=0x14c3b00, callback=0x7f33bd77c800 <g_signal_handler_disconnect>) at /build/buildd/glib2.0-2.31.18/./gobject/gsignal.c:2588

Changed in empathy (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Bilal Shahid (s9iper1) wrote :

thanks for the bug report..
the stacktrace has enough info to send it to upstream so going to upstream it you please subscribe it and make comments.

visibility: private → public
Changed in empathy (Ubuntu):
status: New → Confirmed
Bilal Shahid (s9iper1) wrote :

that would be a downstream changes can you reproduce it now if so than attach the valfrind log..

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Changed in empathy:
importance: Unknown → Critical
Bilal Shahid (s9iper1) wrote :

thats the valgrind log.

Changed in empathy (Ubuntu):
status: Incomplete → Invalid
Charles Kerr (charlesk) wrote :

My guess is that this is a dbusmenu bug, rather than an Empathy one.

Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
importance: High → Undecided
Changed in dbusmenu:
importance: Undecided → High
assignee: nobody → Charles Kerr (charlesk)
Ted Gould (ted) wrote :

My bet is that it's someone unref'ing a child item when they're not supposed to be. It's going to be a tricky one to track. Basically it looks like in clean up we think we have the item, but we actually don't.

Bilal Akhtar (bilalakhtar) wrote :

The upstream bug has been marked NOTGNOME. So this is definitely a downstream bug.

Changed in libdbusmenu (Ubuntu):
status: New → Confirmed
Changed in dbusmenu:
status: New → Confirmed
Changed in empathy (Ubuntu):
status: Invalid → New
Changed in libdbusmenu (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Charles Kerr (charlesk) wrote :

It's a little interesting that we got eight reports of this during a 2 week period back in April, but apparently no duplicates of it since then.

Is anyone still seeing this behavior in 12.10 beta 2 or higher?

Bilal Shahid (s9iper1) on 2012-09-26
Changed in libdbusmenu (Ubuntu):
status: Confirmed → Triaged
Ted Gould (ted) wrote :

Seems to have gone away. Ghosts.

Changed in libdbusmenu:
status: Confirmed → Invalid
Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Changed in libdbusmenu (Ubuntu):
status: Triaged → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.