Cannot respond to friendship requests from Empathy

Bug #886056 reported by Conscious User on 2011-11-04
68
This bug affects 13 people
Affects Status Importance Assigned to Milestone
Telepathy Indicator
High
Ken VanDine
empathy (Ubuntu)
High
Unassigned
telepathy-indicator (Ubuntu)
High
Ken VanDine

Bug Description

When I'm using GTalk in Empathy and someone requests to see my status, I get a notification bubble but can't do nothing about it. If I happen to already have the person in my contact list, I can open the list and click on the name to authorize. But most of the time people will *not* already have the person in there.

I remember that in previous version of Ubuntu, a request would create an entry in the Messaging Menu, which would then show a dialog box when you clicked on it. Not sure if it was the best solution, but at least it was something. I don't know if this was disabled or broke.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: empathy 3.2.0.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: wl nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Nov 4 09:16:52 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Conscious User (conscioususer) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed

This is a quite critical regression. It prevents you entirely from accepting authorization requests, as there does not seem to be a different path to work around this bug.

Bilal Shahid (s9iper1) wrote :

so in empathy the indicator in the top panel shows the notification of friendship request and we accept but the friend is not added until we open the gmail and than accept it.

Omer Akram (om26er) on 2011-11-11
Changed in telepathy-indicator (Ubuntu):
importance: Undecided → High
Changed in empathy (Ubuntu):
importance: Undecided → High
Changed in telepathy-indicator (Ubuntu):
status: New → Confirmed
tags: added: regression-release
Pedro Villavicencio (pedro) wrote :

this looks similar to bug 512761 and bug 334201. could somebody having the problem sent it upstream ? thanks.

Conscious User (conscioususer) wrote :

I'm not entirely sure this should be forwarded to upstream. This seems to be caused by NotifyOSD bubbles not supporting actions. Shouldn't NotifyOSD fall back to an alert box in this case?

Omer Akram (om26er) wrote :

I talked to Ken the other day, its a feature not implemented in indicator-approver. hopefully will be implemented for the LTS.

Changed in telepathy-indicator (Ubuntu):
status: Confirmed → Triaged
Changed in telepathy-indicator (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Changed in telepathy-indicator (Ubuntu):
status: Triaged → Confirmed
Changed in telepathy-indicator:
importance: Undecided → High
status: New → Confirmed
milestone: none → 0.1.1
assignee: nobody → Ken VanDine (ken-vandine)
Changed in telepathy-indicator:
milestone: 0.1.1 → 0.2.0
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package telepathy-indicator - 0.2.0-0ubuntu1

---------------
telepathy-indicator (0.2.0-0ubuntu1) precise; urgency=low

  * New upstream release
    - Handle subscription requests in the indicator (LP: #886056)
  * debian/control
    - added a new build depends for libgtk-3-dev
 -- Ken VanDine <email address hidden> Thu, 16 Feb 2012 13:54:47 -0500

Changed in telepathy-indicator (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers