Video chat feature fails in Empathy messenger.

Bug #866084 reported by Anirudh Shukla on 2011-10-04
62
This bug affects 14 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Medium
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Empathy Video chat problem
Am unable to use Video chat in Empathy messenger thru google. When I receive a call it gets disconnected with the following error messages -
Can't establish video stream
There was a failure in the call engine
Technical Details
Could not link source

Can't establish audio stream
Something unexpected happened in a Telepathy component. Please report this bug and attach logs gathered from the 'Debug' window in the Help menu.
Technical Details
Invalid remote candidates passed.

Can't establish audio stream
Invalid remote candidates passed.

Any help to get video/audio calls to get thru would be much appreciated.

Thanks,
Anirudh

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: empathy 2.34.0-0ubuntu3.1
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic i686
Architecture: i386
Date: Tue Oct 4 15:46:32 2011
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcEnviron:
 SHELL=/bin/bash
 LC_MESSAGES=en_IN.UTF-8
 LANGUAGE=en_IN:en
 LANG=en_IN
SourcePackage: empathy
UpgradeStatus: No upgrade log present (probably fresh install)

Anirudh Shukla (anirudh-shukla) wrote :
Anirudh Shukla (anirudh-shukla) wrote :

The same happend when I tried calling my friend who was on google talk too. Thanks.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in empathy (Ubuntu):
importance: Undecided → Medium
milestone: none → oneiric-updates

I have the same problem, and also, when someone using GTalk is trying to make a video call with me, my webcam launches well, but then the video conference windows freezes. I can't see any video except the one of my webcam.

Hello Anirudh, or anyone else affected,

Accepted empathy into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed

Chris,

The error message has disappear, so now I can invite someone for a video chat. But there is still the freeze of the video window, after 5 / 10 seconds : I can see my video, not the one of the other side, and then the window becomes darker and freeze.

sn0m (sokol-nushaj) wrote :

Hi this is the first time when I had someone calling that was able to answer with videocall.
Amasing, love it, I hope u guys can fix it.
I still can't initiate calls though.
Regards Sokol

Martin Pitt (pitti) on 2011-10-22
Changed in empathy (Ubuntu Oneiric):
status: New → Fix Committed
Changed in empathy (Ubuntu):
status: Confirmed → Fix Committed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.2.0.1-0ubuntu1

---------------
empathy (3.2.0.1-0ubuntu1) oneiric-proposed; urgency=low

  * New upstream release
    - empathy-accounts still uses goa-prefs.desktop
    - editing of local accounts fails
    - account-widgets: fix glade sizing issues
    - Shouldn't try requesting Call channel if built without Call
      support (LP: #866084)
    - Presence misaligned in muc user tooltips
 -- Ken VanDine <email address hidden> Mon, 17 Oct 2011 16:23:42 -0400

Changed in empathy (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

precise has 3.2.1, so presumably fixed there as well.

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
dasarib (mk-kristna) wrote :

still affecting 11.10 current

teimcrr (marco-carrarini) wrote :

I have empathy 3.2.0.1-0ubuntu1.1 and still get message "Invalid remote candidates passed"

Adolfo R. Brandes (arbrandes) wrote :

Same here - updated, but still got an "Invalid remote candidates passed" for audio calls.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers