empathy-chat crashed with SIGSEGV in gtk_container_forall()

Bug #846826 reported by balo on 2011-09-11
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Medium
Unassigned

Bug Description

when empathy starts, it automatically opened my favourite irc channels (i set it).
while login other accounts i drop an irc channel window in another (they became tabs, the chat window now contains 2 tabs).
then i'm "pull out" one of the tabs to desktop and empathy crashed.

normal behaviour: create chat window from dropped tabs to desktop

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: empathy 3.1.91-0ubuntu2
ProcVersionSignature: Ubuntu 3.0.0-10.16-generic 3.0.4
Uname: Linux 3.0.0-10-generic i686
ApportVersion: 1.22.1-0ubuntu2
Architecture: i386
CrashCounter: 1
Date: Sun Sep 11 08:32:02 2011
ExecutablePath: /usr/lib/empathy/empathy-chat
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release i386 (20110427.1)
ProcCmdline: /usr/lib/empathy/empathy-chat
SegvAnalysis:
 Segfault happened at: 0xc5c67f: mov 0x4c(%eax),%edi
 PC (0x00c5c67f) ok
 source "0x4c(%eax)" (0xaaaaaaf6) not located in a known VMA region (needed readable region)!
 destination "%edi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? () from /usr/lib/libgtk-3.so.0
 ?? () from /usr/lib/libgtk-3.so.0
 gtk_container_forall () from /usr/lib/libgtk-3.so.0
 ?? () from /usr/lib/libgtk-3.so.0
 gtk_widget_hide () from /usr/lib/libgtk-3.so.0
Title: empathy-chat crashed with SIGSEGV in gtk_container_forall()
UpgradeStatus: Upgraded to oneiric on 2011-09-10 (0 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

StacktraceTop:
 gtk_widget_verify_invariants (widget=0x998e1d0) at /build/buildd/gtk+3.0-3.1.18/./gtk/gtkwidget.c:8862
 gtk_bin_forall (container=0x90d4700, include_internals=1, callback=0xc5c990 <gtk_widget_verify_child_invariants>, callback_data=0x0) at /build/buildd/gtk+3.0-3.1.18/./gtk/gtkbin.c:172
 gtk_container_forall (container=0x90d4700, callback=0xc5c990 <gtk_widget_verify_child_invariants>, callback_data=0x0) at /build/buildd/gtk+3.0-3.1.18/./gtk/gtkcontainer.c:2032
 gtk_widget_pop_verify_invariants (widget=0x90d4700) at /build/buildd/gtk+3.0-3.1.18/./gtk/gtkwidget.c:9027
 gtk_widget_pop_verify_invariants (widget=0x90d4700) at /build/buildd/gtk+3.0-3.1.18/./gtk/gtkwidget.c:9007

Changed in empathy (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
David Lawson (deej) wrote :

FWIW, this bug is present in Precise as well, with empathy-3.3.92-0ubuntu3.

tags: added: precise
information type: Private → Public
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers