empathy-chat crashed with SIGSEGV in dbus_connection_dispatch()

Bug #829826 reported by Kody Ivan McCarthy on 2011-08-19
140
This bug affects 32 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Ken VanDine
telepathy-glib (Ubuntu)
Undecided
Unassigned

Bug Description

This crash occurs whenever I try to open a chat with a MSN/Facebook/Gtalk contact, regardless of whether or not I am the one initiating the contact or not.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: empathy 3.1.5-1ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-8.11-generic 3.0.1
Uname: Linux 3.0.0-8-generic x86_64
NonfreeKernelModules: fglrx
Architecture: amd64
Date: Fri Aug 19 19:32:16 2011
ExecutablePath: /usr/lib/empathy/empathy-chat
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Release amd64 (20110427.1)
ProcCmdline: /usr/lib/empathy/empathy-chat
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
SegvAnalysis:
 Segfault happened at: 0x7fdccc5bd477: mov 0x8(%rax),%r8
 PC (0x7fdccc5bd477) ok
 source "0x8(%rax)" (0x00000008) not located in a known VMA region (needed readable region)!
 destination "%r8" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: empathy
StacktraceTop:
 ?? () from /usr/lib/libtelepathy-glib.so.0
 ?? () from /usr/lib/libtelepathy-glib.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libdbus-glib-1.so.2
 ?? () from /lib/x86_64-linux-gnu/libdbus-1.so.3
 dbus_connection_dispatch () from /lib/x86_64-linux-gnu/libdbus-1.so.3
Title: empathy-chat crashed with SIGSEGV in dbus_connection_dispatch()
UpgradeStatus: Upgraded to oneiric on 2011-08-18 (1 days ago)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Kody Ivan McCarthy (kodykodiak) wrote :
visibility: private → public
Changed in empathy (Ubuntu):
status: New → Confirmed
description: updated

This happened when I opened Empathy and tried to enter IRC room.

Ken VanDine (ken-vandine) wrote :

This seems to be a regression between telepathy-glib 0.15.4 and 0.15.5, I downgraded to libtelepathy-glib0_0.15.4-1ubuntu2 and couldn't reproduce it.

Changed in telepathy-glib (Ubuntu):
status: New → Invalid
Changed in empathy (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package empathy - 3.1.5.1-1ubuntu1

---------------
empathy (3.1.5.1-1ubuntu1) oneiric; urgency=low

  * New upstream version
    - crashed with SIGSEGV in dbus_connection_dispatch (LP: #829826)
 -- Ken VanDine <email address hidden> Mon, 22 Aug 2011 14:16:36 -0400

Changed in empathy (Ubuntu):
status: Confirmed → Fix Released
Stephen Rees-Carter (valorin) wrote :

Although it's a lot more stable with the new version, I am still experiencing occasional crashes of Empathy.
Would this be a new bug that I should report as such, or the same bug?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers