Empathy away doesn't equate to Facebook's idle

Bug #725800 reported by AmateurDev on 2011-02-26
60
This bug affects 11 people
Affects Status Importance Assigned to Milestone
Empathy
Won't Fix
Unknown
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

When Empathy is set to "Away," Facebook should be "Idle." I googled the problem, and several people say that Facebook Chat has limitations that won't allow you to set it to Idle. But at http://developers.facebook.com/docs/chat/ it says under the "Features and Limitations" Section (fifth bullet) that you can set the status to idle using its API. I'm not a programmer, and this may be posted in the wrong place, but is this a solution? If not, Facebook should be set to offline when Empathy is "Away."

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: empathy 2.32.1-0ubuntu1.1
ProcVersionSignature: Ubuntu 2.6.35-25.44-generic 2.6.35.10
Uname: Linux 2.6.35-25-generic x86_64
Architecture: amd64
Date: Sat Feb 26 17:55:02 2011
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 SHELL=/bin/bash
 PATH=(custom, user)
 LANGUAGE=en_US:fr:en
 LANG=en_US.utf8
SourcePackage: empathy

Today, there are only online and offline status.

I would like the support of all XMPP status :
Online
Free for Chat
Away
Not Available
Do not Distrib
Offline

*** This bug has been confirmed by popular vote. ***

I think that to maintain compatibility with the in-browser chat just:

Online
Away (Idle)
Offline

should be ok.

Fabio is correct. The XMPP interface is conforming to the chat states that we use in Facebook Chat. Oneline and Offline are obvious. Free for Chat is treated as an alias for Online. Away, Not Available and Do not Disturb are all compressed down into "the blue moon" (idle), which is then shown as Away to other XMPP clients.

Okay, but is an Away status in the third party client really propagated to the "blue moon" in Facebook? Currently, I can't see that, or the delay is very long. It's really only "online" or "offline".

Please reopen.

When I have this status in a XMPP client : Free for Chat / Away / Not Available / Do not Distrib, I am Online, there is a problem...

(In reply to comment #3)
> Fabio is correct. The XMPP interface is conforming to the chat states that we
> use in Facebook Chat. Oneline and Offline are obvious. Free for Chat is
> treated as an alias for Online. Away, Not Available and Do not Disturb are all
> compressed down into "the blue moon" (idle), which is then shown as Away to
> other XMPP clients.
>

No, if I set my client state to Away, Not Available and Do not Disturb I still result as available on Facebook. This is a bug

Same here. Presence updates (any of the show types) from a client to chat.facebook.com are not propagated at all, even though http://wiki.developers.facebook.com/index.php/Integrating_with_Facebook_Chat claims it is possible to change to the idle status.

chat.facebook.com just completely silently ignores any presence stanzas.

We are seeing the same results. Facebook does not set you as idle when sending a status of "away"

Perhaps #10308 should be marked as a duplicate of this or this should be marked as a duplicate of #10308

Have you news about this bug ?
Because it is very important...

If you have a problem for correct this bug, you can see the ejabberd code, a XMPP server based on Erlang...

In the same time, can you see for correct the #8744 / #8752 / #8764 / #8773 / #8807 / #8808 / #9032 / #9204 / #9589 / #9734 bugs ?

Every-time I attempt to chat with anyone I immediately receive "offline"
message and the chat screen does gray.

Facebook must be run by Nazi Sand Religions, and have no scientific bone in
their bodies.

Get a real life face book, and stop blocking people.

Every-time I attempt to chat with anyone I immediately receive "offline"
message and the chat screen does gray and then they appear to login again moments later.

Facebook must be run by Nazi Sand Religions hiding in the closet play childish antics games, and have no scientific bone in their bodies in response to social network responsibilities.

Get a real life facebook, and stop blocking people who do nothing wrong.

(In reply to comment #12)
> Every-time I attempt to chat with anyone I immediately receive "offline"
> message and the chat screen does gray and then they appear to login again
> moments later.
>
> Facebook must be run by Nazi Sand Religions hiding in the closet play childish
> antics games, and have no scientific bone in their bodies in response to social
> network responsibilities.
>
> Get a real life facebook, and stop blocking people who do nothing wrong.
>

This is caused by bug 9734 - mishandling of privacy settings - and is unrelated to this issue.

Any update on this bug? Thanks

AmateurDev (guitrguy595) wrote :
Omer Akram (om26er) wrote :

I'll discuss this with empathy people tomorrow.

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Confirmed

On Sun, Feb 27, 2011 at 00:01, AmateurDev <email address hidden> wrote:

> Public bug reported:
>
> Binary package hint: empathy
>
> When Empathy is set to "Away," Facebook should be "Idle." I googled the
> problem, and several people say that Facebook Chat has limitations that
> won't allow you to set it to Idle. But at
> http://developers.facebook.com/docs/chat/ it says under the "Features
> and Limitations" Section (fifth bullet) that you can set the status to
> idle using its API. I'm not a programmer, and this may be posted in the
> wrong place, but is this a solution?

looks quite like it, thanks for digging ;)

> If not, Facebook should be set to
> offline when Empathy is "Away."
>

yeah, away/idle is quite annoying, when it doesn't work. people see you
online and message you, expecting you to respond, since you're neither
"busy" nor "away".
Some will always think you're ignoring them or being indifferent, when you
don't respond.

Interpreting "Away" as "Offline" on the other hand is a little harsh and
doesn't solve the problem at all.

Have you news about this ?

(In reply to comment #15)
> Have you news about this ?

No, simply tell all your friends to not use facebook chat and switch to google talk ;)

Störm Poorun (subs-olan) wrote :

This has been done already in Pidgin - Facebook Chat

Quoted from: http://code.google.com/p/pidgin-facebookchat/wiki/Changelog >

"Changelog
From time to time, this plugin gets updated. This is a list of changes to it.

Version 1.68
Support for new group chats
Fix for setting status messages
Fix for when FB chat is down for maintenance"

papukaija (papukaija) wrote :

I think that's for the person's status message that appear on the news feed and not the online/idle/offline status.

AmateurDev (guitrguy595) wrote :

It doesn't seem like there is much progress on this. Should I report this "upstream" (What does that mean?)? I don't mean to rush you guys because you have a lot of work to do and you are doing a great job! I am going to learn how to program eventually, so I may be able to help in the future.

papukaija (papukaija) wrote :

The upstream, FB in this case is aware of this issue [1] and even has two bug reports about it [2][3].

[1] http://developers.facebook.com/docs/chat/
[2] http://bugs.developers.facebook.net/show_bug.cgi?id=8769
[3] http://bugs.developers.facebook.net/show_bug.cgi?id=10308

Feel free to vote up those bugs by registering to FB's bug tracker and then clicking on the vote link, next to importance at the top of page.

I linked the older (and with more votes) upstream bug to this report but I'm not sure if LP is actually able to track the bug status - at least it didn't show any error messages during the linking. I used Empathy as the project since FB doesn't have its own project on LP.

Changed in empathy:
status: Unknown → Confirmed

(In reply to comment #16)
> (In reply to comment #15)
> > Have you news about this ?
>
> No, simply tell all your friends to not use facebook chat and switch to google
> talk ;)

You DO realize that google talk has similar issues, regarding the statuses "chatty" and "extendad away" (defined in the XMPP RFC).

This may be similar but is one order of magnitude less severe. Not being able to tell your contacts that you are absent for a particularly long time is a pitty, but not being able at all to tell them that you are absent is close to unacceptable for an "instant message" service.

Note that there are very few clients that can disconnect from certain accounts while you are (only) absent.

In September last year we introduced a new tool for tracking bugs on Platform (https://developers.facebook.com/blog/post/559/). Since then we've been working to close out all the remaining issues in Bugzilla (many of which are out of date and no longer relevant) so we can focus all our efforts on bugs filed in the new tool. As this is a wishlist item and hasn't had much recent activity, we're going to close it. If this is still an issue, you can refile it in the new bug tool (http://developers.facebook.com/bugs). Thanks.

Facebook chat availability is binary: a user is either online or offline. The "idle" concept has gone away entirely. Currently, if a user has a jabber session, they are treated as online, regardless of what they set their status to. There are no plans to change this behavior.

Changed in empathy:
status: Confirmed → Won't Fix
papukaija (papukaija) wrote :
Changed in empathy (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.