Can't connect to jabber servers using CACert although ca-certificates is installed

Bug #717923 reported by Muelli on 2011-02-12
50
This bug affects 9 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

I can't connect to jabber.ccc.de because "the certificate is cryptographically weak" or has a "weak cypher" (sic!)

I do have the ca-certificates package installed and thus expected to be able to connect to a site that uses ca-cert.

Apparently, empathy doesn't integrate well with that package.

muelli@ideabox:~$ apt-cache policy ca-certificates
ca-certificates:
  Installed: 20090814+nmu2
  Candidate: 20090814+nmu2
  Version table:
 *** 20090814+nmu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
muelli@ideabox:~$

muelli@ideabox:~$ apt-cache policy empathy telepathy-gabble ca-certificates
ca-certificates:
  Installed: 20090814+nmu2
  Candidate: 20090814+nmu2
  Version table:
 *** 20090814+nmu2 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
empathy:
  Installed: 2.33.1-0ubuntu1
  Candidate: 2.33.1-0ubuntu1
  Version table:
 *** 2.33.1-0ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
telepathy-gabble:
  Installed: 0.11.6-1ubuntu1
  Candidate: 0.11.6-1ubuntu1
  Version table:
 *** 0.11.6-1ubuntu1 0
        500 http://gb.archive.ubuntu.com/ubuntu/ natty/main amd64 Packages
        100 /var/lib/dpkg/status
muelli@ideabox:~$

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: empathy 2.33.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.38-3.30-generic 2.6.38-rc4
Uname: Linux 2.6.38-3-generic x86_64
Architecture: amd64
Date: Sat Feb 12 23:56:24 2011
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha amd64 (20110201.2)
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 LC_MESSAGES=en_GB.utf8
 SHELL=/bin/bash
SourcePackage: empathy

Omer Akram (om26er) wrote :

thanks for the bug report. Please attach the telepathy gabble logs from the time when you see the problem.

You can get those logs from Help>Debug a window will pop, there in a drop down menu select gabble and click the save button and attach the log file to this bug report.

PS: it is preferred and appreciated that you clear the logs first and reproduce the bug so that the logs are less and relevant.

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
tags: removed: running-unity

Here is the log.

Changed in empathy (Ubuntu):
status: Incomplete → Opinion
status: Opinion → New

It also happens here when connecting to de.postfix.org, which uses a CA cert class 3 certificate. It's a bit unclear which certificates empathy is actually using.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers