encoding problem empathy irc

Bug #685067 reported by André Gondim on 2010-12-04
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

When have accented word when use IRC protocol only shows ? istead it.

As you can see in topic at screen shot.

$ locale
LANG=pt_BR.utf8
LANGUAGE=pt_BR:pt:en
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
LC_ALL=

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: empathy 2.32.2-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.37-7.19-generic 2.6.37-rc3
Uname: Linux 2.6.37-7-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sat Dec 4 00:06:02 2010
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Alpha i386 (20101128)
ProcEnviron:
 SHELL=/bin/bash
 LANGUAGE=pt_BR:pt:en
 LANG=pt_BR.utf8
SourcePackage: empathy

André Gondim (andregondim) wrote :
Omer Akram (om26er) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME.

Changed in empathy (Ubuntu):
importance: Undecided → Low
Omer Akram (om26er) wrote :

I cannot understand the actual problem from the image. could you explain it a little bit?

Changed in empathy (Ubuntu):
status: New → Incomplete
Id2ndR (id2ndr) wrote :

The trouble appears only on the subject in the topic. I got the trouble in both the topic and the content in my case.

Launchpad Janitor (janitor) wrote :

[Expired for empathy (Ubuntu) because there has been no activity for 60 days.]

Changed in empathy (Ubuntu):
status: Incomplete → Expired
Changed in empathy (Ubuntu):
status: Expired → Confirmed
Sergio Benjamim (sergio-br2) wrote :

Sorry for open again this bug, but this problem still happens in Ubuntu 12.04.

There's two problems, one with the irc channel topic, and other when we chatting with people.

As can be seen in picture, there's a problem in some characters like "é" or "ê".

It seems that if a user in the other side uses "IRC (Latin/Unicode Hybrid)" option in XChat, in Empathy some characters are not recognized (like "é", "à", "ç"). Is this a problem in Empathy or XChat?

Sorry for my poor english.

Sergio Benjamim (sergio-br2) wrote :

There is other example.

When the user in other side switch to UTF-8 (in Xchat), the characters appears correctly.

Sergio Benjamim (sergio-br2) wrote :

This is the picture that André Gondim tried to show the problem (take a closer look at the red arrows).

Bilal Shahid (s9iper1) wrote :

hmm tell me the your language language ?

Changed in empathy (Ubuntu):
status: Confirmed → Incomplete
Sergio Benjamim (sergio-br2) wrote :

It is Brazilian Portuguese, the same language of André Gondim's system.

Why is this bug Incomplete? Do you need more information? Are the images not sufficient to show that there is an error in the Empathy?

locale | grep LANG

LANG=pt_BR.UTF-8
LANGUAGE=pt_BR:pt:pt_PT:en

Sergio Benjamim (sergio-br2) wrote :

This encoding problem happened with 2 different persons, with 2 different Ubuntu versions, so this problem is confirmed.

Changed in empathy (Ubuntu):
status: Incomplete → Confirmed
Vitor Albuquerque (vitor-rcca) wrote :

Happened to me too! My facebook friends are receiving words like "atenção" as "aten??o"!

Ubuntu 13.04 (x64)

locale | grep LANG
LANG=pt_BR.UTF-8
LANGUAGE=pt_BR:pt:pt_PT:en

I am receiving words like "não" as "n?o".

$ lsb_release -d
Description: Ubuntu 14.04 LTS

$ locale | grep LANG
LANG=pt_BR.UTF-8
LANGUAGE=pt_BR:pt:pt_PT:en

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers