CTRL-C does not work in irc chat window

Bug #665552 reported by Alexander Gnodtke on 2010-10-23
178
This bug affects 41 people
Affects Status Importance Assigned to Milestone
Empathy
New
Low
empathy (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

- Open a chat window (i.e. enter room)
- Select text in the chat window
- Press CTRL-C
- Pasting via CTRL-V does not work.

What does work, is pasting with the middle mouse button but I do not think that this is sufficient.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: empathy 2.32.0-0ubuntu2
ProcVersionSignature: Ubuntu 2.6.35-22.34-generic 2.6.35.4
Uname: Linux 2.6.35-22-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Sat Oct 23 14:53:09 2010
EcryptfsInUse: Yes
InstallationMedia: Ubuntu-Netbook 10.10 "Maverick Meerkat" - Release i386 (20101007)
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: empathy

Alexander Gnodtke (gnodtke) wrote :
Alexander Gnodtke (gnodtke) wrote :

I just saw that an upstream bug had already been filed.
I linked this bug report to the existing one on bugzilla.gnome.org.

Changed in empathy:
importance: Unknown → Low
status: Unknown → New
Omer Akram (om26er) wrote :

seems like i reported the bug a few months ago ;)

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Alexander Gnodtke (gnodtke) wrote :

This seems to have been resolved in 2.32.0.1 (ubuntu version 2.32.0.1-0ubuntu1) can anyone confirm?

Alexander Gnodtke (gnodtke) wrote :

The upstream bug has been set to resolved, doing the same here.

Changed in empathy (Ubuntu):
status: Triaged → Invalid
Changed in empathy:
status: New → Expired
Changed in empathy:
status: Expired → New
Javier Melero (ricmelero) wrote :

I've version 2.32.1 and the bug persists. With right click on selection, copy option works, the bug is the ctrl+C shortcut, and is needed.

Paul Leger (pleger) wrote :

Hi,
       The same Javier's problem, please fix it!. It is a little bit annoying this bug!

Since this bug significantly impacts usability, it seems to me that perhaps it should be eventually nominated for natty-updates (once there is an upstream fix). With that in mind, would anyone object to me changing this from Invalid to New in empathy in Ubuntu?

Alexander Seaton (randompspam) wrote :

I'm also affected by this, but only since I updated from Ubuntu 10.10 to 11.04 - which seems odd given that in the bug report it's affecting 10.10. Actually, it does say "10.10 Ubuntu-Netbook" so could this be something to do with Unity? Although admittedly that sounds somewhat far-fetched...

Just to make clear what the issue is, if I select some text from the sent messages in the main window and press Ctrl-C, pasting using Ctrl-V or 'right click -> paste' has no effect - it merely pastes any information previously copied to the clipboard. In addition, selecting the text and then going 'right click -> copy' on it works properly, I'm able to paste the text using both of the methods mentioned before. This means that firstly, it's the copy command which isn't working - not paste, and secondly that it's the keyboard shortcut to copy which isn't working. Finally, this is specifically in relation to the sent messages section of a chat window - the issue doesn't seem to affect any other part of Empathy (e.g. Ctrl-C in the 'previous conversations' window works perfectly).

I'm using Empathy version "2.34.0-0ubuntu3" (previously I was using 2.32-... I believe which didn't appear to be affected).

Adding natty tag since this happens in Natty for Alexander Seaton. And I'm changing the status from Invalid back to New in empathy in Ubuntu because (and I should have noticed this before) it was marked Invalid when the upstream bug was thought to be solved...and the upstream bug has since been reopened, too.

Also, you may be onto something, Alexander Seaton--since Apport tagged this ubuntu-une when Alexander Gnodtke reported it, it probably happened in Unity for Alexander Gnodtke as well.

Changed in empathy (Ubuntu):
status: Invalid → New
tags: added: natty

I've just tried this on a Natty i386 system with empathy 2.34.0-0ubuntu3, and I can reproduce this bug as well. I was able to reproduce it in all four available session types: Ubuntu, Ubuntu Classic, Ubuntu Classic (no effects), and Safe Mode. Since only the first of these session types uses Unity, it seems that Unity is not the cause of this problem after all.

I was able to select text and copy it to the clipboard by right-clicking on it and clicking Copy. Then I was able to paste it with Ctrl+V. I was able to select text without copying it to the clipboard, and paste it by clicking the middle mouse button. Furthermore, when I selected text in Empathy and copied it to the clipboard (by right-clicking and clicking Copy), and then selected text in the Terminal, and then clicked the middle mouse button in Empathy, it pasted the text from the Terminal. When I pressed Ctrl+V immediately thereafter, it pasted the text that I'd copied to the clipboard earlier. Except the failure of Ctrl+C (which certainly is a bug), this is all perfectly normal and correct behavior--it's just behavior that many Ubuntu users are not aware of. In X11, there are (actually more than) two clipboards--one which uses Copy and Paste, and the other which uses selection and (by default) middle-clicking. (This is somewhat obfuscated by how, when there's nothing that's been copied by selection, in some applications middle-clicking will paste whatever is in the Copy-and-Paste clipboard; that leads many people to think of Ctrl+V and middle-click as though they are equivalent, even though they are not.) See http://wiki.tcl.tk/1217 for a quick technical explanation of how this works, and http://en.wikipedia.org/wiki/X_Window_selection for more detailed information.

The conclusion of that last paragraph: This bug has nothing to do with *pasting* functionality (even though Alexander Gnodtke reported being able to paste by middle-clicking). Only copying functionality via Ctrl+C is affected, and it appears to be (or have been) affected in precisely the same way for everyone who has experienced this bug.

Changed in empathy (Ubuntu):
status: New → Triaged
Gareth (gmccumskey) wrote :

I am currently experiencing the problem as well. Right click > Copy works but not Select > CtrlC.

I am using Empathy build 2.34.0

Dan Clark (kam3-dan-wph0) wrote :

Wondering if this is fixed or not?

I am able to reproduce this problem in IRC in empathy 3.1.92-0ubuntu1 on an Oneiric i386 system in a 3D Unity session, so no, this is not fixed. (I have not tested with other session types, but I will do so on request.) It occurs in an IRC channel window but not in an AIM chat window. Right-clicking and clicking Copy works, but Ctrl+C does not.

tags: added: oneiric
Binoy T (mailbinoyv-gmail) wrote :

Empathy 3.2.0. Problem still exists. I can reproduce this problem In Unity and Gnome Shell.

Stephen Rees-Carter (valorin) wrote :

I am experiencing this bug with all chat windows under 11.10, Unity, with Empathy 3.2.0.
Often the 'copy' option under the right-click menu does not work either.

This is a very frustrating bug when you often have people sending you details (like server addresses, and code blocks) which need to be copied somewhere locally.

John Nowak (john-nowak) wrote :

I can confirm this is still broken in XMPP multi-user chats. I *can* copy via the menus but not via Control-C. Basic functionality like copy and paste really needs to work in the default chat client. I think this deserves higher importance.

Pavel (gerpaulus) wrote :

Yes, I also confirm that Control-C not working in Empathy 3.2.0.1-0ubuntu1.1 (Ubuntu 11.10 x64).

Fred (folivier-f0) wrote :

This bug is this on. I experience this problem since more than a year. I must say, it is a big usability issue. I've had dozens of times when I though I copy-paste properly and I didnt, because of that bug. It would be greatly appreciated if someone can investigate it and fix it.

Thanks!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.