Ubuntu 10.10: proxy settings are not detected in some applications like empathy or update-manager

Bug #658445 reported by Alfredo Gemma on 2010-10-11
30
This bug affects 7 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: empathy

After upgrading from 10.04 or just after a fresh installation, proxy settings are not correctly detected by empathy or update manager.
In Ubuntu 10.04, after setting a squid proxy in System -> Preferences -> Network Proxy, empathy was able to connect to all the defined accounts and all software channel were available in update-manager.
In Ubuntu 10.10, setting a proxy in System -> Preferences -> Network Proxy prevents empathy from connecting to some or all accounts while using the "direct connection" option, in some way, makes all the accounts available again.
Some behavior with update-manager.

jeannich (jeannich) wrote :

I had this regression also with update-manager. After the following steps, it turned to be working again:

-Set your proxy in "System/Preferences/Network Proxy"
-apply system wide
-In "System/Administration/Synaptic/Settings/Preferences/Network" set your http proxy.
-Reboot

I think the key point here is a reboot ; maybe just a restart of update-manager or Network-manager wuold have been enough.

Alfredo Gemma (alfredo-gemma) wrote :

Thank you for your feedback, jeannich.

However, I think that the problem is more general and related to the upgrade process on O.S. with a lot of packages installed.

I upgraded from 9.04 and 10,04 15 computers in total (13 Desktops and 2 Servers)

The upgrade process was successful on 9 computers while on the remaining 6 (5 desktops and 1 Servers with a LAMP stack using Lighttpd) I detected problems related to the ScreeSaver package (unlock the screen was not possible), security problems (every attemp to process a php page caused a 403 error), proxy detection problems similar to the reported one.

In this scenario the only possible hypothesis is that in presence of complex configuration, the actual upgrade corrupts some settings after updating the packages.

Tushar Gaikwad (tushargkwd) wrote :

Applying the Proxy settings in "System-Wide" mode should allow internet access to all the applications......But sometimes it can malfunction.

Maybe you can refer to this topic, which might help you...

http://ubuntuforums.org/showthread.php?t=1839

Regrads,
Tushar

Alfredo Gemma (alfredo-gemma) wrote :

Tushar,

In that forum they just suggest to set the http_proxy variable in the classical "fashion":

export http_proxy=http://login:password@proxy:port

Although exporting the http_proxy variable can be useful in some occasion (i.e. with software not supporting explicitly proxies), in this case can not be considered a solution and however, It is proven not to work.

Thank you anyway for your feedback.

Changed in empathy (Ubuntu):
status: New → Confirmed
cuby (cuby) wrote :

I cannot connect using "ubuntu software center". I have a proxy with authentication.
Direct connection works well.
I have Ubuntu 10.10 i386 final, up to date.
This bug may be related to:
https://bugs.launchpad.net/ubuntu/+source/software-center/+bug/545134

Konstantin Ivanov (liner.mgn) wrote :

I have this bug, Empathy and update manager does not work with proxy settings.
This bug also affects Rhythmbox.
I changed proxy configuration in System->Parameters->Proxy several times and used many combinations - the bug still present.

tags: added: rhythmbox

It sounds like I have the same problem with Firefox. Chromium, w3m or uzbl are working fine when manually defining proxy settings but Firefox doesn't. I tried to set up proxy within firefox but it seems to be ignored.

Omer Akram (om26er) wrote :

thanks for the bug report. if the issue is with empathy report for empathy and if the issue is with update-manager/software-center or such you have to report against the related packages. i am closing this bug as invalid and if the issue is still there please open a new bug which explains the issue clearly. thanks

Changed in empathy (Ubuntu):
status: Confirmed → Invalid
Alfredo Gemma (alfredo-gemma) wrote :

Omer,

As you can see reading all posts, the problem affects mainly empathy and Update-Manager.

In this situation, are you asking to report twice the same bug: one related to empathy package and the other for Update Manager?

Thank you.

Sayantan Das (sayantan13) wrote :

I think this is a major bug. Rendering it invalid does not solve any purpose for anyone who is planning to deploy ubuntu in enterprise environments where there is proxy. Please, please fix this bug . it is affecting chat sessions in my office network.
exporting proxy using export http_proxy doesnt help either.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers