log in button is not enabled when adding IRC account

Bug #615081 reported by Leo Arias on 2010-08-08
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Empathy
Fix Released
Medium
empathy (Ubuntu)
Medium
Bilal Akhtar

Bug Description

Binary package hint: empathy

When I try to add a freenode IRC chat account, the log in button is not enabled. It is necessary to change the network to something else and then get back to freenode.

Steps to reproduce:
Go to Edit > Accounts
Click the Add button
Select the IRC protocol
(don't change the network, it should be left as Freenode)
Fill the textfields
(log in button is disabled, see attachment)

Workaround:
In order to enable the log in button, change the network to something else than Freenode and then back.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: empathy 2.31.5.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.35-14.19-generic 2.6.35
Uname: Linux 2.6.35-14-generic i686
Architecture: i386
Date: Sun Aug 8 12:09:41 2010
InstallationMedia: Ubuntu-Netbook 10.04 "Lucid Lynx" - Release i386 (20100429.4)
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
SourcePackage: empathy

Leo Arias (elopio) wrote :
Omer Akram (om26er) wrote :

this might be actually caused by the fix to bug 615081

Changed in empathy (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Omer Akram (om26er) wrote :

confirmed this bug is caused by our fix

Changed in empathy (Ubuntu):
importance: Low → Medium
Omer Akram (om26er) wrote :

oops I meant fix to bug 569289 caused this bug.

Changed in empathy (Ubuntu):
assignee: nobody → Bilal Akhtar (bilalakhtar)
importance: Medium → High
status: Confirmed → In Progress
Changed in empathy (Ubuntu):
importance: High → Medium
Omer Akram (om26er) wrote :

did you try the upstream way (as Guillaume Desmottes said?) wouldnt it be much simpler if we had only one patch for this issue. your fix seems like a hack.

Bilal Akhtar (bilalakhtar) wrote :

One patch? Well, that could be done, but so long we don't have any problem in having many patches, as long as all of them apply fine.

Why does it seem like a hack? It is the proper way to go.

Vish (vish) wrote :

Kindly open an upstream bug and forward the Patch upstream.
Same problem will occur with the patch upstream upstream committed too.
This is not an Ubuntu specific bug.

Bilal Akhtar (bilalakhtar) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at:
https://bugzilla.gnome.org/show_bug.cgi?id=626620

Changed in empathy:
importance: Undecided → Unknown
status: New → Unknown
Changed in empathy (Ubuntu):
status: In Progress → Triaged
Changed in empathy:
status: Unknown → New
tags: added: patch-forwarded-upstream
tags: added: patch-accepted-upstream
removed: patch-forwarded-upstream
Vish (vish) wrote :

This has now been fixed upstream.

Changed in empathy (Ubuntu):
status: Triaged → Fix Committed
Changed in empathy:
status: New → Fix Released
Leo Arias (elopio) wrote :

Thanks a lot :D

Bilal Akhtar (bilalakhtar) wrote :

Vish,
The fix is NOT yet in ubuntu.

Changed in empathy (Ubuntu):
status: Fix Committed → In Progress
Omer Akram (om26er) wrote :

Bilal you should cancel the sponser request for this bug. when empathy 2.31.90 gets out this bug will be marked fixed. but for now fix committed as its fixed upstream

Changed in empathy (Ubuntu):
status: In Progress → Fix Committed
Bilal Akhtar (bilalakhtar) wrote :

Omer,

FeatureFreeze is in effect, and there are very less chances of a newer version of empathy to come in maverick, as it would need an FFe. Hence, I am not cancelling this sponsorship request, but allowing some sponsor to come and check if its acceptable and go ahead.

Omer Akram (om26er) wrote :

No, empathy 2.31.6 is not the stable version. 2.32 will be and for that no feature freeze exception is required. it will come into Maverick when its released.

Omer Akram (om26er) wrote :

feature freeze exception is for those apps that are not yet updated to the unstable version. for example Maverick still have evolution 2.30.x so If the desktop team wants 2.31.6 in Maverick then there will have to be a feature freeze exception request.

Omer Akram (om26er) wrote :

empathy 2.31.90 is now in Maverick

Changed in empathy (Ubuntu):
status: Fix Committed → Fix Released
Leo Arias (elopio) wrote :

Thanks a lot. It works now :)
*hugs*

Changed in empathy:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.