Remote desktop not refreshed when using desktop sharing

Bug #599773 reported by Nicola Jelmorini on 2010-06-29
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Undecided
Unassigned
vinagre (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: empathy

I'm trying to use the desktop sharing functionality in Empathy with two gmail accounts.

Everything works fine until the appearance of the remote desktop on my PC. I can move the mouse, and who is close to the remote PC confirm me that his mouse moves following my mouse.
Unfortunately I don't see the refresh of the remote screen. I can work with the mouse on the remote PC, but I don't receive the updated image of the screen. When I accept to share the desktop, in vinagre I get only the first image, then it remains static.

Attached to this bug report I send you the remote Desktop image that I can see on my PC in vinagre. This is the only image I receive without refresh as I said.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: empathy 2.30.1.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-23.37-generic 2.6.32.15+drm33.5
Uname: Linux 2.6.32-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
CheckboxSubmission: e4b1d244d414c70431fbbcedfd192c44
CheckboxSystem: e704f33cc0866ff0f0256a33de39ea1c
Date: Tue Jun 29 14:14:08 2010
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100429)
ProcEnviron:
 LANGUAGE=it_CH:it:it_IT:en
 LANG=it_CH.utf8
 SHELL=/bin/bash
SourcePackage: empathy

Nicola Jelmorini (jelmorini) wrote :
Brian Curtis (bcurtiswx) wrote :

Thanks for your bug report and helping to make Ubuntu better. I have a feeling this is a vinagre problem and not empathy, but I won't close the empathy task until the vinagre triagers take a look at this. Could you try using remote desktop viewer (instead of empathy) between the two computers to see if that gives you any different results?

Changed in empathy (Ubuntu):
status: New → Incomplete
Nicola Jelmorini (jelmorini) wrote :

Hi Brian,

sorry for the delay. Eventually I have made the test you asked.
I used the remote desktop viewer directly between the two computers, without Empathy.
The result is identical. I mean that the problem I exposed here is still present. I receive only the first remote screen, and then it remain static. No more screen refresh.

swatspyder (andrewdefilippis) wrote :

This issue is solved by disabling Desktop Effects from within System > Preferences > Appearance > Visual Effects > "None"

The problem with this issue is that the "fix" is just a workaround. I would like to continue using Visual Effects on my desktop, and use VNC.

Nicola Jelmorini (jelmorini) wrote :

Thank you swatspyder. Your workaround function well for me too.

If Computer A want to share his desktop and Computer B accept to share it, then Computer A must disable, temporarily, all Compiz Visual Effects.

I hope that new Compiz 0.9 and/or some work on vinagre will resolve this bug in the future, because remote desktop sharing through Empathy is the best solution: no more pain with firewall and router ports, or enabled remote destkop option in the Preferences.

Bernard Banko (beernarrd) wrote :

Same problem here with the difference that I get just a black screen without any picture. The workaround works for me, too.

Adam Collard (adam-collard) wrote :

This is a problem in Vinagre, closing down empathy half.

Changed in empathy (Ubuntu):
status: Incomplete → Invalid

There is a discussion of this problem here: http://ubuntuforums.org/showthread.php?t=1383356&page=2

It has been seen with a number of vnc viewers (not just vinagre) and appears to be a problem with xdamage extensions. From post 15 by v_2ryann :

    Here is the answer guys, on how to do it without changing the effects:

    1) Open a terminal o press ALT+F2, then run/type: gconf-editor
    2) Go to /desktop/gnome/remote_access and enable "disable_xdamage"

    I found it found here:
    http://swiss.ubuntuforums.org/showthread.php?t=1496368

The gconf-editor says this about the XDamage extension of X.org: "This extension does not work properly on some video drivers when using 3D effects. Disabling it will make vino work on these environments with a slower rendering as side effect. "

One post suggested a possible link with nvida drivers, but my machine does has ati drivers and experiences the same problem. Many people on the forum thread above (and others) have said turning off desktop visual effects (which presumably use xdamage) solves the problem.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers