Ubuntu

Cannot click on status URLs in Empathy

Reported by Ken Sharp on 2010-06-11
46
This bug affects 10 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: empathy

Contacts (in AIM for example) can add URLs to their statuses and Empathy will create a clickable link when hovering over the username.

Unfortunately when you move the mouse to try and click on the URL the "tooltip" immediately disappears making it impossible to actually click on anything.

Using Ubuntu Lucid and Empathy 2.30.1

Ken Sharp (kennybobs) wrote :
Omer Akram (om26er) wrote :

Tooltips only stay as long as the cursor is on the icon. when it moves they disappear.

Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
status: New → Invalid
Ken Sharp (kennybobs) wrote :

I know that. So what is the point in having Empathy parse the URL at all?

Brian Curtis (bcurtiswx) wrote :

@Ken. I see what you're saying. The tooltip shows the clickable link, and then you'd have to right click on the contact and go to "information" and then you'd be able to click the link. Do you have a suggestion as to what changes should be made. Should the tooptip not show the clickable link?

Changed in empathy (Ubuntu):
status: Invalid → Incomplete
Ken Sharp (kennybobs) wrote :

There a number of possible ways to make the URL useful:

1. The tooltip can remain until the pointer moves outside of the window focus.
2. Right clicking on the user could bring up an option "Open URL..."
3. A user's status could appear under the username.

I guess it depends on whatever would be easiest.

Changed in empathy (Ubuntu):
status: Incomplete → New
kyleabaker (kyleabaker) wrote :

I think that in terms of being easiest, it should be specified as easiest for the end-user and not just the easiest fix.

In that case, it would make the most sense to implement the first option Ken mentioned and allow the tooltip to display until the cursor exits the buddy list area. I've seen this style of implementation in several other instant messengers such as Digsby and Trillian so it seems to be the most natural approach.

One thing to note is that this implementation usually positions the tooltip either left or right of the buddy list a bit to give a more aesthetic appearance and uniform as you hover different contacts. I'm not sure if this particular stylistic idea could be implemented, but it would help improve usability.

Brian Curtis (bcurtiswx) wrote :

This is actually working a designed. If you wish to click links from buddies, please right click their entries and click on information. THis will allow you to click on links.

Changed in empathy (Ubuntu):
status: New → Invalid
Ken Sharp (kennybobs) wrote :

It was designed to create a hyperlink to be completely useless? That's some design!

bgruber (bsg4+ubuntu052006) wrote :

nowadays, you still can't click on the link in the tooltip, but you also can't click the link in the contacts manager (which is what you get when you right-click and choose "Information." I think it may be time to reopen this.

Ken Sharp (kennybobs) on 2013-02-22
Changed in empathy (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in empathy (Ubuntu):
status: New → Confirmed
NeLaS (organelas) wrote :

Agreed, this is a considerable usability issue for me...

On Empathy 3.6.4 links on statuses or tooltips are not clickable.

When opening the "Information" menu by right-click it opens the contact on Gnome Contacts (3.6.2 here). A non-clickable status is displayed there and it is not even possible to copy the text to paste into a browser.

There is already a bug reported for Gnome Contacts https://bugzilla.gnome.org/show_bug.cgi?id=675690 So it should get eventually fixed.

Although for me it feels more natural to have the links clickable upon Empathy contact list, no need for tooltips.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.