Empathy does not honor default browser when clicking URLs in chat

Bug #576734 reported by Diwaker Gupta on 2010-05-07
This bug affects 5 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)

Bug Description

Binary package hint: empathy

How to reproduce:
- Open a chat window
- Type in a regular URL
- On the receiver side, just click on the URL

Expected behavior:
- the URL opens in whatever the default system browser is

Actual behavior:
- the URL always opens in Firefox

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: empathy 2.30.1-0ubuntu1
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
Uname: Linux 2.6.32-22-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Thu May 6 18:09:26 2010
 PATH=(custom, user)
SourcePackage: empathy

Diwaker Gupta (diwaker) wrote :
Leo Arias (elopio) wrote :


I tried to reproduce your problem but I couldn't.

I installed chromium
Went to System>Preferences>Preferred Applications
Set chromium as the default browser.
Opened a link from empathy.
Chromium opened, as expected.

DistroRelease: Ubuntu 10.04
InstallationMedia: Ubuntu 10.04 LTS "Lucid Lynx" - Release i386 (20100429)
Package: empathy 2.30.1-0ubuntu1
PackageArchitecture: i386
ProblemType: Bug
ProcVersionSignature: Ubuntu 2.6.32-22.33-generic
SourcePackage: empathy
Tags: lucid
Uname: Linux 2.6.32-22-generic i686

Diwaker Gupta (diwaker) wrote :

Leo, this is what I did:

- Install chrome
- From within Chrome, go to Options and make Chrome the default browser
- URLs from all other applications (Psi, Kmail, Konsole etc) seem to work just fine (that is, they open in Chrome). However, URLs from Empathy still open in Firefox

Note that I'm running Kubuntu. Perhaps this has something to do with it? I also checked "Default Applications" using the "System Settings" application that ships with Kubuntu and the default web browser is indeed set to Chrome.

Omer Akram (om26er) wrote :

thanks for taking time to report this bug and helping to make ubuntu better. Please open gnome-default-applications-properties and there select the default browser to chromium. if its not installed install it with the command that it will give you. "probably it is using gnome's prefered app" in either case upstream developers are sure its not empathy bug so I will mark this invalid.

Changed in empathy (Ubuntu):
status: New → Invalid
tutuca (tutuca) wrote :

For me it's actually the other way around. But the same behavior. It opens the links in chrome even though my default browser is firefox

kapouer (kapouer) wrote :

xdg-mime default chromium-browser.desktop x-scheme-handler/http
xdg-mime default chromium-browser.desktop x-scheme-handler/https

instant effect.

predder (predder) wrote :

I had this issue but as Omer said, it appears that when Chrome is set as the default browser from within chrome it doesn't update the gnome defaults. After running the "gnome-default-applications-properties" application and set it manually after which it all worked as expected.

MaskedDriver (maskeddriver) wrote :

#7 worked for me.

This leads to a further questions... I updated my browser information using galternatives and within the browser

update-alternatives --config gnome-www-browser
update-alternatives --config x-www-browser
I changed both of these to /usr/bin/chrome, but that didn't resolve this issue for me.
Chrome -> Properties -> Set Chrome as Default Browser

Why doesn't the Application Properties update even after all of these steps?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers