Empathy uses telepathy-haze instead of telepathy-sofiasip to provide SIP functionality

Bug #563072 reported by John Markh on 2010-04-14
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)
Wishlist
Unassigned

Bug Description

Binary package hint: empathy

By default, Empathy uses telepathy-haze to provide SIP functionality. Unfortunately, I did not manage to make SIP connection (not ever registration).

<---------- snip ---------------------->
haze/haze-DEBUG: 10-04-14 10:16:16.100119: haze_connection_manager_init: Initializing (HazeConnectionManager *)0x9f610a0
tp-glib-DEBUG: 10-04-14 10:16:16.102200: started version 0.3.4 (telepathy-glib version 0.10.1)
purple/prefs-INFO: 10-04-14 10:16:16.103195: /purple/savedstatus/isidleaway changed, scheduling save.
haze/haze-DEBUG: 10-04-14 10:16:16.104604: _haze_cm_set_param: setting parameter account (telepathy name account)
haze/haze-DEBUG: 10-04-14 10:16:16.104640: _haze_cm_set_param: setting parameter password (telepathy name password)
haze/haze-DEBUG: 10-04-14 10:16:16.104669: _haze_cm_set_param: setting parameter dopublish (telepathy name dopublish)
haze/haze-DEBUG: 10-04-14 10:16:16.104691: _haze_cm_set_param: setting parameter port (telepathy name port)
haze/haze-DEBUG: 10-04-14 10:16:16.104712: _haze_cm_set_param: setting parameter udp (telepathy name udp)
haze/haze-DEBUG: 10-04-14 10:16:16.104732: _haze_cm_set_param: setting parameter useproxy (telepathy name useproxy)
haze/haze-DEBUG: 10-04-14 10:16:16.104752: _haze_cm_set_param: setting parameter proxy (telepathy name proxy)
haze/haze-DEBUG: 10-04-14 10:16:16.104773: _haze_cm_set_param: setting parameter authuser (telepathy name authuser)
haze/haze-DEBUG: 10-04-14 10:16:16.104798: _haze_cm_set_param: setting parameter authdomain (telepathy name authdomain)
haze/haze-DEBUG: 10-04-14 10:16:16.106331: haze_connection_class_init: Initializing (HazeConnectionClass *)0x9f60818
haze/haze-DEBUG: 10-04-14 10:16:16.106755: haze_connection_init: Initializing (HazeConnection *)0x9fc6810
haze/haze-DEBUG: 10-04-14 10:16:16.107640: haze_connection_constructor: Post-construction: (HazeConnection *)0x9fc6810
purple/network-WARNING: 10-04-14 10:16:18.54857: Couldn't create UPnP mapping
purple/network-WARNING: 10-04-14 10:16:18.64428: Couldn't create UPnP mapping
purple/simple-MESSAGE: 10-04-14 10:16:18.64774: listenfd: 13
purple/simple-MESSAGE: 10-04-14 10:16:18.65088: connecting to sip.spikko.com port 5090
purple/dns-MESSAGE: 10-04-14 10:16:18.142779: DNS query for 'sip.spikko.com' queued
purple/dns-MESSAGE: 10-04-14 10:16:18.144349: Created new DNS child 3251, there are now 1 children.
purple/dns-MESSAGE: 10-04-14 10:16:18.144942: Successfully sent DNS request to child 3251
purple/dns-MESSAGE: 10-04-14 10:16:18.169920: Got response for 'sip.spikko.com'
purple/dnsquery-MESSAGE: 10-04-14 10:16:18.170450: IP resolved for sip.spikko.com
purple/proxy-MESSAGE: 10-04-14 10:16:18.170823: Attempting connection to 82.80.252.29
purple/proxy-MESSAGE: 10-04-14 10:16:18.171148: Connecting to sip.spikko.com:5090 with no proxy
purple/proxy-MESSAGE: 10-04-14 10:16:18.171566: Connection in progress
purple/proxy-MESSAGE: 10-04-14 10:16:18.353665: Connecting to sip.spikko.com:5090.
purple/proxy-CRITICAL: 10-04-14 10:16:18.354022: Error connecting to sip.spikko.com:5090 (Connection refused).
purple/proxy-CRITICAL: 10-04-14 10:16:18.354370: Connection attempt failed: Connection refused
purple/connection-MESSAGE: 10-04-14 10:16:18.354741: Connection error on 0x9fc9f68 (reason: 0 description: Unable to connect: Connection refused)
haze/haze-DEBUG: 10-04-14 10:16:18.355097: close_all: closing im channels
purple/account-MESSAGE: 10-04-14 10:16:18.355726: Disconnecting account <email address hidden> (0x9fc6370)
purple/connection-MESSAGE: 10-04-14 10:16:18.356044: Disconnecting connection 0x9fc9f68
purple/connection-MESSAGE: 10-04-14 10:16:18.356419: Destroying connection 0x9fc9f68
haze/haze-DEBUG: 10-04-14 10:16:18.356848: haze_connection_dispose: disposing of (HazeConnection *)0x9fc6810
haze/haze-DEBUG: 10-04-14 10:16:18.396015: close_all: closing im channels
haze/haze-DEBUG: 10-04-14 10:16:18.396492: haze_connection_finalize: deleting account <email address hidden>
purple/account-MESSAGE: 10-04-14 10:16:18.396908: Destroying account 0x9fc6370
<---------- snip ---------------------->

after installing telepathy-sipsofia, I was able to use SIP functionality.

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: empathy 2.30.0.1-0ubuntu3
ProcVersionSignature: Ubuntu 2.6.32-20.30-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-20-generic i686
Architecture: i386
Date: Wed Apr 14 10:25:52 2010
EcryptfsInUse: Yes
ExecutablePath: /usr/bin/empathy
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100322)
ProcEnviron:
 SHELL=/bin/bash
 LANG=en_CA.utf8
SourcePackage: empathy

John Markh (dragonsol) wrote :
John Markh (dragonsol) on 2010-04-14
summary: - Empathy uses telepathy-haze instead of telepathy-sipsofia to provide SIP
+ Empathy uses telepathy-haze instead of telepathy-sofiasip to provide SIP
functionality
Sebastien Bacher (seb128) wrote :

it's not really a bug, it uses what is installed, it could recommends or suggests telepathy-sofiasip though

Changed in empathy (Ubuntu):
importance: Undecided → Wishlist
meral (meral) wrote :

If anyone else stumbles upon this:

uninstall telepathy-haze
install telepathy-sofiasip
relogin

voila, new settings and a working empathy sip!

This issue is active in lucid lynx, still. The problem is really just that the wrong software is installed by default in empathy.

What brought me to this thread: Could not use SIP in empathy: Account was grey'ed out when Tried to open "New Call".

I just write this to give google some more keywords that could lead people to this thread :)

Best regards

Changed in empathy (Ubuntu):
status: New → Fix Released
status: Fix Released → Confirmed
Victor Vargas (kamus) wrote :

Thanks for the work around, this works fine for me too today while I was testing our sip extensions (telepathy-sofiasip provide lots of options to do it well).

Changed in empathy (Ubuntu):
status: Confirmed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers