empathy accounts fail to connect after manually unlocking keyring

Bug #558872 reported by Waldo000000 on 2010-04-09
This bug affects 19 people
Affects Status Importance Assigned to Milestone
empathy (Ubuntu)

Bug Description

Binary package hint: empathy

The following problem only occurs when I use auto-login.

If I DO NOT use auto-login, empathy is automatically started after logging in and my accounts connect automatically, i.e. there's a green speech bubble icon in the indicator applet and my contact list is populated.

If I DO use auto-login, upon starting up I am prompted with "Enter password to unlock your login keyring". I enter my keyring successfully, but then empathy does not appear to be started at all (e.g. no speech bubble icon in the indicator applet). If I manually start empathy via the Indicator Applet, the contacts window is blank. If I then do Edit -> Accounts, my accounts are "Offline - Status is set to offline". If I uncheck "Enabled" and then recheck "Enabled", the accounts connect and are reported as "Available". However, the contacts window remains blank. If I Quit empathy and then start empathy again, everything is fine (I finally get the green speech bubble icon and can see my contacts).

Output of `lsb_release -rd`:
Description: Ubuntu lucid (development branch)
Release: 10.04

Output of `apt-cache policy empathy`:
  Installed: 2.30.0-0ubuntu4
  Candidate: 2.30.0-0ubuntu4
  Version table:
 *** 2.30.0-0ubuntu4 0
        500 http://au.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: empathy 2.30.0-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-19.28-generic
Uname: Linux 2.6.32-19-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Fri Apr 9 10:59:36 2010
ExecutablePath: /usr/bin/empathy
 PATH=(custom, user)
SourcePackage: empathy

Waldo000000 (waldo000000) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you look in the account dialog if those are listed correctly when you get the issue?

Changed in empathy (Ubuntu):
importance: Undecided → Low
Waldo000000 (waldo000000) wrote :

Yes, the accounts are listed as I would expect - it's just that they are reported as being "Offline - Status is set to offline", as I mentioned.

Omer Akram (om26er) wrote :

Do you have gwibber accounts set?

m0rtal (alexander-nagorny) wrote :

No, gwibber crashes @ my pc :(

Omer Akram (om26er) wrote :

Can you please tell us which type of method of internet connection are you using. ?

m0rtal (alexander-nagorny) wrote :


Waldo000000 (waldo000000) wrote :

Internet connection is via wireless network.

Omer Akram (om26er) wrote :

I added empathy to startup applications and when the system starts I am asked for the keyring password, I provide it and I am online but If my wireless connection takes a few seconds to connect I get an empty empathy window but as soon as wireless connects empathy automatically connects.

Can you please open gconf-editor go to /apps/empathy and untick the option use_conn and then try to reproduce the problem. Thanks

Changed in empathy (Ubuntu):
status: New → Incomplete
Waldo000000 (waldo000000) wrote :

I made the suggested changes via gconf-editor, but there was no observed change in behaviour.

The clarify: when the system starts I am asked for the keyring password. While the system waits, my wireless connection connects successfully. When I then provide my password, empathy does not connect, and has an empty empathy window that persists until I quit and restart empathy.

Paul Nickerson (pgn674) wrote :

I had this problem, and I found a work around.

For those who don't want to read a lot: I set my keyring manager's password to blank, and set empathy and gwibber as startup applications. To find out how, read on.

First, what I saw wrong: I did an in-place upgrade today from 9.10. I have auto log-on enabled; did it a ways back, many Ubuntu versions ago. When I booted up, keyring manager would ask me to unlock. After typing in my password, I would notice that Indicator Applet Session had all the status options grayed out, and had no text box for typing in. In the Indicator Applet menu, there were no little white arrows on the left (which seem to appear when the relevant program is running, background or foreground). If I clicked on Chat to open Empathy, Empathy showed no contacts, and opening Edit > Accounts showed they were all "Offline - Status is set to offline". Gwibber seemed to work fine, once I opened it by clicking Broadcast in the Indicator Applet menu (though I did not try posting anything). However, the text box still did not appear in the Indicator Applet Session. I did not try the things the OP did to get the Empathy accounts to connect.

Now, the work around: I opened up Seahorse using Applications > Accessories > Passwords and Encryptions Keys, right clicked "Passwords: login", and changed my password to be black (it wasn't before). By the way, this is probably generally a bad idea security wise. After rebooting, the keyring manager did not pop up asking for anything, but things still looked the same. But then, clicking Chat and Broadcast in Indicator Applet made Indicator Applet Session work wonderfully, and my accounts logged in in Empathy. Then, I just set empathy and gwibber to run automatically in System > Preferences > Startup Applications, rebooted, and everything was awesome. Gwibber does pop up on screen when the desktop loads, but that's OK for now.

Michele Mattioni (mattions) wrote :

I just discovered that if you click on the mail icon and open chat, empathy automatically connect.

Jason (jaseeverett) wrote :

Same exact thing happens to me. Have to 'reconnect' each account manually and then shut down empathy and restart it. Not keen on removing my password as Paul suggested as a workaround. May have to go back to Pidgin. Bit disappointing as I just uninstalled Pidgin.

Sarah Strong (sarahstrong) wrote :

I also experience this bug.

Ubuntu Lucid 10.04, clean installed.
My account is set to automatically log in, but empathy and my wireless connection require passwords from my default keyring. When I start Ubuntu, a dialog pops up requesting that I unlock my default keyring.

If I wait more than a minute or two before providing my password to this dialog, I experience this bug:

When I access Empathy via Indicator Applet (envelope) -> Chat, the Empathy contacts window pops up with my status set to Available but no accounts visible.

If I go to Edit->Accounts, each of my accounts is set to Enabled but with the message "Offline - Status is set to offline."

If I change my online status, for instance by setting my status at the top of the Empathy contact window to Offline and then Available again, there is no change. Quitting and restarting empathy, however, connects me properly.

I expect that Empathy stops requesting to connect to services when it's denied access to the keyring for too long.


I am facing the same bug, at the same time pidgin is working well, can any buddy have an idea when it will be going to fixed and release under patch ?


Omer Akram (om26er) wrote :

The issue you are reporting is an upstream one and it would be nice if somebody having it could send the bug to the developers of the software by following the instructions at https://wiki.ubuntu.com/Bugs/Upstream/GNOME.

Omer Akram (om26er) wrote :

Is there any news about this bug? Has someone affected by this bug sent the report upstream? May you tell us the bug number? Thanks in advance.

Erik Zoltan (erik-zoltan) wrote :

I have been struggling with this bug in Ubuntu 10.10 Maverick (64 bit).

I tried the following and it solved the problem. I went into System / Preferences / Passwords and Encryption Keys. I expanded the "Passwords: login" key and I clicked on the keys that were causing problems (in my case, anything related to Facebook and Identi.ca) that I couldn't connect to with Empathy. I pressed "Delete" on each one, to delete it.

When I rebooted, I had to go back into Empathy and tell it the passwords that it should use to connect to those accounts for which I had removed the password from the Passwords and Encryption Keys dialog.

Rebooting again, it now prompts me for my keyring password just one time. When I specify it correctly, it connects to my accounts in Empathy and sets my status to "Available".

I hope this simple procedure works of others too. If so, then the developers should be able to use this information to narrow down exactly what's going wrong.


Omer Akram (om26er) wrote :

Is there any news about this bug? Has someone affected by this bug sent the report upstream? May you tell us the bug number? Thanks in advance.

Omer Akram (om26er) wrote :

Could you send this bug to gnome? else this bug will be closed in two weeks.

Péter (fourdots) wrote :

Created this issue in gnome's bugzilla:

"[Ubuntu] empathy accounts fail to connect after manually unlocking keyring"

Changed in empathy:
importance: Unknown → Low
status: Unknown → New
Changed in empathy:
status: New → Incomplete
Changed in empathy:
status: Incomplete → New
Péter (fourdots) wrote :

Could you guys please go 'confirm' this bug upstream. Also mention whether you're still experiencing it in 11.04 if you've upgraded.

I don't know what they're doing up there..

Let's inspire them to get it fixed.

Marja Erwin (marja-e) wrote :

I don't know what a keyring is, but edited my details in "passwords and encryption keys," since that was suggested to fix a minor bug. Now empathy can't connect any more. I'm not sure if this is the same bug.

Changed in empathy:
status: New → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.