no buddy icon or incorrect buddy icon for facebook

Bug #529229 reported by Stewart G. on 2010-02-27
34
This bug affects 5 people
Affects Status Importance Assigned to Milestone
Empathy
New
Medium
empathy (Ubuntu)
Low
Unassigned
notify-osd (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: empathy

When a facebook contact becomes available, usually no buddy icon is displayed in the notification. Eventually an icon may be displayed after a long delay. Buddy icons should load from a cache for the notifications.

When a facebook contact signs off, the wrong buddy icon may be shown, or it may show the correct icon initially, and then change to display the buddy icon of another contact. I think this is happening when multiple contacts sign off while the notification is still displayed.

linux: Ubuntu 10.04 (Lucid) 64-bit
empathy: 2.29.91-1ubuntu2

pablomme (pablomme) wrote :

I have seen facebook contacts coming online, their notification displaying no picture (while it is being downloaded, I assume), and after a delay displaying the picture for a different contact. This is similar to the case described in the summary for contact logouts, but for contact logins instead. I assume this is the same bug, so confirming.

I'm running up-to-date 32-bit lucid installed from scratch at alpha 3.

Changed in empathy (Ubuntu):
status: New → Confirmed
Changed in empathy (Ubuntu):
importance: Undecided → Low
Changed in empathy (Ubuntu):
status: Confirmed → Triaged
Omer Akram (om26er) wrote :

Thank you for your bug report. This bug has been reported to the developers of the software. You can track it and make comments at: https://bugzilla.gnome.org/show_bug.cgi?id=611472

pablomme (pablomme) wrote :

The bug is basically that when there is something to notify about multiple
contacts simultaneously or in quick succession, the pictures in the
notification bubble change but the contact names do not.

So, is it possible that the bug could actually be in the notify-osd Ubuntu
package? If I remember correctly, the old notification-daemon does display
multiple notifications at once, and I don't see how it could happen there.

Omer Akram (om26er) wrote :

@pablomme can you please uninstall notify-osd and install notification-daemon and see if in that case notifications show wrong buddy icon. That will be really helpful

Changed in notify-osd (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
pablomme (pablomme) wrote :

I think this may have been fixed with notify-osd 0.9.27-0ubuntu1. From the changelog "Small maintainance release to fix LP: #525546, so appending works correctly.". Bug #525546 is about the body text of a notification not being updated in certain situations, which would seem a perfectly sensible reason for this bug.

I have seen a couple of notifications from empathy properly update the text and the picture when several contacts log in simultaneously. This is not something I can reproduce at will, though, so don't take my word for it just yet. It would be useful if someone else (with zillions of chat contacts, preferably) could test the updated notify-osd and confirm that it works.

Stewart G. (birbeck) wrote :

I had removed notify-osd last night and installed notification-daemon. It looked like it was working but I did not have ample time to test it. I will try again with the latest notify-osd. IIRC pidgin was working correctly and would stack notifications, at least it does on my 9.10 workstation.

Stewart G. (birbeck) wrote :

Screenshot showing correct buddy icon in contact list, but no icon in the notification.

Stewart G. (birbeck) wrote :

After a few hours use, it does appear better. I have not seen any incorrect buddy icons and when multiple buddies sign on/off the correct notification image and text are updated.

Facebook icons still do not always show in the notification when a buddy signs on or off, however, they are always there for my other XMPP contacts (google talk and my office chat). If I have the contact list open, I can see the proper icon in the contact list but no icon in the notification.

pablomme (pablomme) wrote :

> After a few hours use, it does appear better. I have not seen any
> incorrect buddy icons and when multiple buddies sign on/off the
> correct notification image and text are updated.

I'll flag notify-osd as fix released then.

> Facebook icons still do not always show in the notification when
> a buddy signs on or off

The problem is that this bug is actually two, one was a bug (in notify-osd, it turns out) and the second an enhancement request. It would have been better to file each separately. Perhaps it would be still be advisable to do so to avoid confusion (e.g., the duplicates of this bug are of the fixed part, not of the feature request). If you want to do that, flag as invalid here for empathy and file a new bug. And also clarify this upstream, possibly filing a new bug in the Gnome bug tracker too.

Changed in notify-osd (Ubuntu):
status: Incomplete → Fix Released
Changed in empathy:
importance: Unknown → Medium
status: Unknown → New
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.